mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > Software

Reply
 
Thread Tools
Old 2005-01-28, 14:31   #1
phillipkwood
 

16CA16 Posts
Default running only at night

Is there any way I can just have the GIMPS program run at night? People in the lab don't like the sound of the fan during the day-
(running windows XP on some Gateway machines).
thanks for any insights!
Phil
phillipkwood@yahoo.com
  Reply With Quote
Old 2005-01-28, 16:07   #2
PrimeFun
 
PrimeFun's Avatar
 
Jul 2003

2·3·5 Posts
Default

From readme.txt in your prime95 directory:

You can configure this program to have different properties at different
times of the day and/or to not run during certain times of the day.
Unfortunately, you must manual edit the prime.ini file. Let's say you
want to install the program on a friend's machine and he runs a screen
saver at night. He also runs a disk defragmenter at midnight on weekdays.
This prime.ini file will run the program at a higher priority than his
screen saver at night and on weekends. It also sleeps for an hour when
his defragmenter starts running. Finally, at night fewer save files are
generated to allow his disk to stay powered down longer.
UserID=foo
Other prime.ini entries
Time=1-5/8:30-17:30
Priority=1
DiskWriteTime=30
Time=1-5/1:00-8:30,1-5/17:30-24:00,6-7/0:00-24:00
Priority=5
DiskWriteTime=240
The 1-5 refers to days of the week, with Monday=1 and Sunday=7. The
time portion refers to the hours of the day based on a 24-hour clock.
You do not need to specify days of the week (e.g. Time=1-7/0:00-8:00
is the same as Time=0:00-8:00). Unpredictable results will occur if
there are overlapping time intervals. Also note that any options that
appear in the Time= sections should not appear earlier in the prime.ini
file and you can no longer edit these options from the user interface
PrimeFun is offline   Reply With Quote
Old 2005-01-28, 16:14   #3
Mystwalker
 
Mystwalker's Avatar
 
Jul 2004
Potsdam, Germany

11001111112 Posts
Default

But is it possible to stop Prime95 with that?
Mystwalker is offline   Reply With Quote
Old 2005-01-28, 16:21   #4
PrimeFun
 
PrimeFun's Avatar
 
Jul 2003

2·3·5 Posts
Default

Opps!

I thought you could by putting a priority of 0 but I just tried it and it didn't work...

I think you can do what you want with Xp's task scheduler

Start | Accesories | System Tools | Scheduled Tasks

after you set the start time go into advanced options and tell it not to run for longer than x hours...

Another method would be to combine the Time & Throttle functions to put a long delay between iterations during the day

If you are running on a laptop or in a hot room and you want to slow the
program down to reduce heat, then you can add this line to prime.ini:
Throttle=n
where n is the number of milliseconds to sleep after each iteration.

Last fiddled with by PrimeFun on 2005-01-28 at 16:32
PrimeFun is offline   Reply With Quote
Old 2005-01-28, 17:02   #5
JuanTutors
 
JuanTutors's Avatar
 
Mar 2004

50910 Posts
Default

If you put only:

Time=1-5/0:03-0:05
Priority=8
DiskWriteTime=30

Prime95 will run for those two minutes at priority 8 on those 5 days, and will not run any other time.
JuanTutors is offline   Reply With Quote
Old 2005-01-28, 19:17   #6
JuanTutors
 
JuanTutors's Avatar
 
Mar 2004

1111111012 Posts
Default

Quote:
Originally Posted by dominicanpapi82
If you put only:

Time=1-5/0:03-0:05
Priority=8
DiskWriteTime=30

Prime95 will run for those two minutes at priority 8 on those 5 days, and will not run any other time.
In case I wasn't clear: In general set what times you want it to runat, what priority you want it to run at during those times, and whatyou want the disk write time to be during those times. If there are anytimes you didn't set, Prime95 won't run at those times. That's thepoint I was making.
JuanTutors is offline   Reply With Quote
Old 2005-01-30, 11:17   #7
cheesehead
 
cheesehead's Avatar
 
"Richard B. Woods"
Aug 2002
Wisconsin USA

22·3·641 Posts
Default

(Come on, guys -- give him an example that looks like what he wants. :-)

Quote:
Originally Posted by phillipkwood
Is there any way I can just have the GIMPS program run at night?
First, define what times-of-day and days-of-week is meant by "night". Then use Time= cmmand(s) to specify that the program is to run at those times.

A) Suppose "night" means before 5:45 AM and after 6:30 PM every day. Then you would use:

Time=1-7/0:00-5:45,1-7/18:30-24:00

B) Suppose "night" means before 5:45 AM and after 6:30 PM Monday through Friday, before 8 AM and after 4 PM on Saturdays, and all day on Sundays. Then use:

Time=1-5/0:00-5:45,1-5/18:30-24:00
Time=6/0:00-8:00,6/16:00-24:00
Time=7/0:00-24:00

or youcouldsqueezeitallononelinelike:

Time=1-5/0:00-5:45,1-5/18:30-24:00,6/0:00-8:00,6/16:00-24:00,7/0:00-24:00

C) Suppose that in the same schedule as B), you want it to save to disk every 30 minutes on weekdays, but only every 60 minutes on Saturday/Sunday. Then:

Time=1-5/0:00-5:45,1-5/18:30-24:00
DiskWriteTime=30
Time=6/0:00-8:00,6/16:00-24:00
DiskWriteTime=60
Time=7/0:00-24:00
DiskWriteTime=60

or

Time=1-5/0:00-5:45,1-5/18:30-24:00
DiskWriteTime=30
Time=6/0:00-8:00,6/16:00-24:00,7/0:00-24:00
DiskWriteTime=60

Last fiddled with by cheesehead on 2005-01-30 at 11:27
cheesehead is offline   Reply With Quote
Old 2005-01-30, 13:46   #8
cheesehead
 
cheesehead's Avatar
 
"Richard B. Woods"
Aug 2002
Wisconsin USA

1E0C16 Posts
Default

To rephrase what dominicanpapi82 already said:

1) If the prime.ini file has no Time= line, then Prime95 by default runs all the time.

2) But if there is at least one Time= line, then Prime95 runs only during the time intervals specified on the Time= lines.

What happens is that when you start Prime95, it reads the prime.ini and, if there is at least one Time= line but the current time is not within any time interval specified on any Time= line, then Prime95 goes to sleep until the start of the next time specified on any Time= line. (It's a light sleeper, waking for a microsecond every two seconds to check whether the user has entered any command.) "Sleep" means that the OS keeps the program on its list of current tasks, but the program doesn't execute any instructions or use any execution time.

Illustration: If, in my examples B) or C) above, you started Prime95 at noon on a Tuesday, Prime95 would, after reading its .ini files, sleep until 6:30 PM that same day, then start processing tasks from its worktodo.ini file.

When it starts up at the beginning of a Time= specified time interval, it sets a timer for the end of that time interval. When that timer "rings' at the end of the interval, Prime95 sleeps until the beginning of the next time interval.

Quote:
Originally Posted by PrimeFun
I thought you could by putting a priority of 0 but I just tried it and it didn't work...
If Prime95 reads "Priority=0", it figures you really meant "Priority=1" (I think -- but I didn't really track it all the way down in the source code).

Last fiddled with by cheesehead on 2005-01-30 at 14:00
cheesehead is offline   Reply With Quote
Old 2018-01-29, 00:34   #9
mggtiger
 
"mggtiger"
Jan 2018
Chicago area

1 Posts
Default Tried everything -- can't get Prime95 to run only at night

Nice, fast i7-7700K that I'd like to contribute to the cause. Windows 10 Home, 32Gb, SSD, no graphics card.

The CPU fan is too loud to run Prime95 in the daytime (or should I say, "prime time"?). I added
StaggerStarts=10
PauseWhileRunning=* during 1-7/0:01-7:00
to both local.txt and to prime.txt, since I wasn't sure from the documentation where they were supposed to go.

But when I start Prime95 during the daytime, it proceeds to run anyway.
What's the trick? I don't want to have to remember to manually start Prime95 every night.

Help will be much appreciated!
mggtiger is offline   Reply With Quote
Old 2020-09-25, 19:17   #10
SWWright
 
Sep 2020

310 Posts
Default

Your PauseWhileRunning is pausing Prime95 from midnight until 7 in the morning, after which it is free to run.

If you do not want Prime95 running during the day, the setting should be as follows:

PauseWhileRunning=* during 1-7/09:00-17:00

This will force Prime95 to pause from 9 AM to 5 PM every day of the week.
SWWright is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Running prime95 over night then automatically stop/start patgie Information & Answers 13 2018-01-28 19:08
The night was humid. (add a line or two) only_human Lounge 5 2014-08-16 15:46
Is there a setting to run at night only? petrw1 Information & Answers 1 2013-10-19 01:35
Things that go bump in the night xilman Astronomy 1 2010-10-13 20:17
Running all TF and P-1 at night JuanTutors Software 7 2004-08-21 13:31

All times are UTC. The time now is 03:59.

Mon Apr 19 03:59:31 UTC 2021 up 10 days, 22:40, 0 users, load averages: 1.31, 1.44, 1.53

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.