Go Back > Great Internet Mersenne Prime Search > Software

Thread Tools
Old 2004-12-22, 18:26   #1
Dec 2004

3 Posts
Default Newb help (it crashes)

Hi, I'm running Xandros 3.0 (which runs on some version of Debian), and I downloaded the debian package. It did the factoring correctly, then it says (I had to restart it to get the output because I had it in a startup script and I'm not sure where the output for that went):

Mersenne number primality test program version 23.9
Starting P-1 factoring on M34338919 with B1=405000, B2=8505000
Chance of finding a factor is an estimated 5.29%
M34338919 stage 1 complete. 14902 transforms. Time: 757.632 sec.
Starting stage 1 GCD - please be patient.
Stage 1 GCD complete. Time: 267.931 sec.
Segmentation fault

Any ideas? I tried sprime also, still a seg fault. I can give more info, just let me know what you need to solve this. Thank you!
Proggie is offline   Reply With Quote
Old 2004-12-22, 19:36   #2
P90 years forever!
Prime95's Avatar
Aug 2002
Yeehaw, FL

1D3D16 Posts

Please try version 24.6, the link is buried in this thread:

There was a rare memory corruption bug in the GCD code. I'm curious if this bug is the cause of your problem.
Prime95 is offline   Reply With Quote
Old 2004-12-23, 04:43   #3
Dec 2004

3 Posts

Well, it might be too early to say, but it seems to be working. It actually is producing some results. I'll repost to this thread if it dies again. thank you!
Proggie is offline   Reply With Quote
Old 2005-01-04, 15:54   #4
Jeff Gilchrist
Jeff Gilchrist's Avatar
Jun 2003
Ottawa, Canada

3×17×23 Posts

Hi George,

I just had the exact same problem with mprime 2.39 on FC3 with a new P4 3Ghz box. I tried upgrading to the beta build of 24.6 you post and it has finished stage 1 and is now onto stage 2 so I guess that did solve the problem.


Last fiddled with by Jeff Gilchrist on 2005-01-04 at 15:54
Jeff Gilchrist is offline   Reply With Quote
Old 2005-01-05, 07:35   #5

241 Posts
Thumbs up

I was experiencing segmentation faults using version 23.9 on RHEL AS 3.0 after "Stage 1 GCD complete". I installed version 24.6 and it is now in Stage 2 and appears to be running OK. Thanks for the fix!
  Reply With Quote

Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Newb who needs help with PC EddieTheBear Hardware 19 2015-10-23 13:22
newb needs help - factoring RSA512 error barthmaul Msieve 22 2014-12-04 08:25
Newb question PicGrabber Msieve 20 2014-10-31 20:06
Questions from a GIMPS newb hj47 Hardware 10 2008-10-28 20:00
linux question ( newb) crash893 Software 2 2003-12-26 18:50

All times are UTC. The time now is 21:49.

Sun May 9 21:49:46 UTC 2021 up 31 days, 16:30, 0 users, load averages: 2.97, 3.03, 3.05

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.