mersenneforum.org  

Go Back   mersenneforum.org > Extra Stuff > Linux

Reply
 
Thread Tools
Old 2008-05-27, 22:17   #1
dstillwe
 

2×7×47 Posts
Default Missing shared libs in SLES 10

When I try to run mprime under SLES 10 x86_64, I get errors saying that certain shared libraries are missing.
I tried the 'easy' (foolish) method of trying to copy some of these shared libs from a Redhat 5 install with some minimal success.

With just the standard SLES install, I get an error saying libcurl.so.4 is missing. I copied it from Redhat.
Next I get an error saying that libssl.so.6 is missing. I copied it from Redhat.
Next I get an error saying that libcrypto.so.6 is missing. I copied it from Redhat.
Next I get a floating point error when trying to launch mprime.

Any suggestions on where to get the actual files that I need, or another method to make this work?
This is a validation system, so I have no access to get files or updates that I may need to pay for or have a subscription to.

Thanks,
Darrel
  Reply With Quote
Old 2008-06-06, 01:42   #2
mdettweiler
A Sunny Moo
 
mdettweiler's Avatar
 
Aug 2007
USA (GMT-5)

11000011010012 Posts
Default

Quote:
Originally Posted by dstillwe View Post
When I try to run mprime under SLES 10 x86_64, I get errors saying that certain shared libraries are missing.
I tried the 'easy' (foolish) method of trying to copy some of these shared libs from a Redhat 5 install with some minimal success.

With just the standard SLES install, I get an error saying libcurl.so.4 is missing. I copied it from Redhat.
Next I get an error saying that libssl.so.6 is missing. I copied it from Redhat.
Next I get an error saying that libcrypto.so.6 is missing. I copied it from Redhat.
Next I get a floating point error when trying to launch mprime.

Any suggestions on where to get the actual files that I need, or another method to make this work?
This is a validation system, so I have no access to get files or updates that I may need to pay for or have a subscription to.

Thanks,
Darrel
Which version of mprime are you using? I remember I once got a floating point error under mprime v25.6 when trying to use it with a save file from mprime v24.14; are you by any chance trying to do that?
mdettweiler is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Missing bit levels? NBtarheel_33 Data 6 2016-05-31 15:27
Missing top 10? R.D. Silverman GMP-ECM 3 2011-03-18 21:35
Linkhelpers, Link error while linking a shared lib linkhelpers Linux 1 2009-09-17 03:49
A missing identity fivemack Factoring 4 2008-03-04 05:04
missing? tha Data 6 2003-09-14 21:36

All times are UTC. The time now is 12:24.

Sat Apr 10 12:24:56 UTC 2021 up 2 days, 7:05, 1 user, load averages: 2.88, 2.58, 2.27

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.