mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > Software

Reply
 
Thread Tools
Old 2002-12-13, 17:50   #1
randyC
 
Dec 2002

5 Posts
Default ntprime user having trouble with prime95

I am attempting to install the latest primenet software on a new computer (running Windows 2000 Pro).
I downloaded p95v2212.zip and winnt2212.zip and extracted them.
I copied a prime.ini file from another computer; that computer runs ntprime v21.4.
I noted in readme.nt that ntsetup.exe is obsolete, and I should run prime95.exe for configuration.
I noted in readme.txt that running prime95.exe should start a graphical application, but when I try (either from explorer or from a command prompt) no ui appears, but the program uses 100% CPU, as if immediately starting a test.

I saw similar behavior when upgrading from ntprime v21.4 on another computer that uses Windows 2000 Pro.

This is the first time I have tried using prime95.exe. Am I misunderstanding how it is supposed to work?

prime.ini:
UseHTTP=1
OldUserID=
OldUserPWD=
UserPWD=<redacted>
UserName=<redacted>
UserEmailAddr=<redacted>
SendEmail=1
UserID=randyC
UsePrimenet=1
DialUp=0
DaysOfWork=8
WorkPreference=0
OutputIterations=262144
ResultsFileIterations=1048576
DiskWriteTime=30
ModemRetryTime=180
NetworkRetryTime=180
NetworkRetryTime2=180
DaysBetweenCheckins=7
TwoBackupFiles=1
SilentVictory=1
ManualComm=0
Left=154
Top=154
Right=1113
Bottom=883
AskedAboutMemory=1
Newsletters=0

randyC
randyC is offline   Reply With Quote
Old 2002-12-13, 22:05   #2
garo
 
garo's Avatar
 
Aug 2002
Termonfeckin, IE

53148 Posts
Default

Can you give us the contents of your local.ini as well. Most likely there is a NoIcon=1 line which is causing the UI to be hidden. Also, remove the CPU type and speed line if you have copied the local.ini from a machine with a different spped and type.

Finally, look in the taskmanager to see if Prime95 is getting any CPU cycles.
garo is offline   Reply With Quote
Old 2002-12-19, 21:13   #3
randyC
 
Dec 2002

5 Posts
Default

For the new install I started from scratch to work around the problem.

I will shift focus to a machine I am attempting to upgrade. This machine was running ntprime v21.4 before the upgrade. This machine uses Windows NT 4.0. This is the machine from which I copied ntprime for the new install. The prime.ini file is identical to the one I posted.

Here is the local.ini file:
OldRollingAverage=1362
LastEndDatesSent=1040104502
RollingStartTime=0
ComputerID=PII-400
SelfTest448Passed=1
RollingAverage=947
CPUType=9
CPUSpeed=400
SelfTest384Passed=1
SelfTest512Passed=1
SelfTest640Passed=1
SelfTest768Passed=1
CPUHours=24
DayMemory=8
NightMemory=160
DayStartTime=480
DayEndTime=1200
SelfTest896Passed=1
OldCpuType=9
OldCpuSpeed=398

I don't see an entry "NoIcon=1".

Same scenario: When I run prime95, no ui appears, and prime95 becomes top cpu user.

Suggestions?
randyC is offline   Reply With Quote
Old 2002-12-19, 23:05   #4
outlnder
 
outlnder's Avatar
 
Aug 2002

2×3×53 Posts
Default

Uninstall, delete the folder, then run ver. 22.12 of prime95.exe. It works just fine with Win2K.
outlnder is offline   Reply With Quote
Old 2002-12-20, 03:03   #5
randyC
 
Dec 2002

5 Posts
Default

outlnder:

If you had taken the time to read my last posting before posting your curt reply, you would have noticed that I am already aware of the "scorched earth" solution you suggested.

Instead I am hoping to avoid the time consuming, error prone process of recreating the ini files for two computers. To do this I am asking if anyone else is familiar with the problem I am experiencing, in the hope that my problem can be solved in a more methodical manner.

This pursuit, if successful, would have the side effect of documenting the solution for others who may have similar issues due to the demise of ntsetup.exe. Who knows, maybe the solution could make it into a future readme.nt.
randyC is offline   Reply With Quote
Old 2002-12-20, 04:22   #6
Prime95
P90 years forever!
 
Prime95's Avatar
 
Aug 2002
Yeehaw, FL

7×1,097 Posts
Default

Is the ntprime.exe service running? If so, try stopping the service before you run prime95.exe. Its just a shot in the dark.
Prime95 is online now   Reply With Quote
Old 2002-12-20, 14:53   #7
randyC
 
Dec 2002

5 Posts
Default

Prime95:

I stopped the ntprime service before running prime95.exe, per instructions.
randyC is offline   Reply With Quote
Old 2002-12-20, 15:30   #8
Prime95
P90 years forever!
 
Prime95's Avatar
 
Aug 2002
Yeehaw, FL

7×1,097 Posts
Default

Your .ini files look completely normal - I'm stumped.
Prime95 is online now   Reply With Quote
Old 2002-12-21, 23:15   #9
patrik
 
patrik's Avatar
 
"Patrik Johansson"
Aug 2002
Uppsala, Sweden

52·17 Posts
Default

randyC:
Quote:
I noted in readme.txt that running prime95.exe should start a graphical application, but when I try (either from explorer or from a command prompt) no ui appears,
Quote:
This is the first time I have tried using prime95.exe.
Has anyone explained the basic behaviour of prime95 to you? I.e., that prime95 may not start as a ui at once, but places an icon in the system tray. Then you open the ui via the "2^p-1" icon.
patrik is offline   Reply With Quote
Old 2002-12-22, 03:08   #10
outlnder
 
outlnder's Avatar
 
Aug 2002

2×3×53 Posts
Default

Don't bother, I don't believe anyone can explain anything to this person.
outlnder is offline   Reply With Quote
Old 2002-12-24, 03:52   #11
randyC
 
Dec 2002

510 Posts
Default

patrik:

You win the prize.

Apparently I was looking too hard for that graphical application; I didn't notice the icon in the system tray.

On my fresh prime95 install the icon was placed on the task bar, not the system tray. This may have added to my confusion.

Thanks for stating what may have been obvious to an experienced Windows user.
randyC is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
New Prime95 user wants team Xav Teams 15 2013-03-10 02:24
asm trouble science_man_88 Programming 52 2010-10-06 21:52
Check up on ntprime service progress? khanricksteele Information & Answers 5 2009-12-27 20:47
Access to Prime95 from different user profiles Unregistered Software 1 2006-11-05 16:57
Some help on ntprime please koekie Software 2 2003-02-12 08:51

All times are UTC. The time now is 01:09.


Thu Dec 2 01:09:32 UTC 2021 up 131 days, 19:38, 1 user, load averages: 1.38, 1.20, 1.00

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.