mersenneforum.org  

Go Back   mersenneforum.org > New To GIMPS? Start Here! > Information & Answers

Reply
 
Thread Tools
Old 2009-01-16, 05:04   #1
Jud McCranie
 
Jud McCranie's Avatar
 
Oct 2007

1328 Posts
Default One computer can't connect to Priment

I just discovered that one of my five computers hasn't been able to connect to Primenet since 11-12-08. All of the others are OK. All are using version 25.7 or 25.8. If I try to connect manually on that computer it gives an error message "CURL error - invalid arguements" or something like that. It was using 25.7 and I upgraded it to 25.8, but it still has the same problem. It is using Windows XP and other than this it connects to the internet just fine.
What is the problem?
Jud McCranie is offline   Reply With Quote
Old 2009-01-16, 10:51   #2
S485122
 
S485122's Avatar
 
"Jacob"
Sep 2006
Brussels, Belgium

1,753 Posts
Default

Look at your prime.txt file. There is a section [PrimeNet]. It could be that the data for the proxy server is wrong...

Jacob
S485122 is offline   Reply With Quote
Old 2009-01-16, 16:38   #3
Jud McCranie
 
Jud McCranie's Avatar
 
Oct 2007

2·32·5 Posts
Default

Quote:
Originally Posted by S485122 View Post
Look at your prime.txt file. There is a section [PrimeNet]. It could be that the data for the proxy server is wrong...

Jacob
It has the following, which is the same as on a computer where Prime95 is working OK:

[PrimeNet]
Debug=1
ProxyHost=
ProxyUser=
ProxyPass=
ProxyMask=0
Jud McCranie is offline   Reply With Quote
Old 2009-01-16, 17:44   #4
Jud McCranie
 
Jud McCranie's Avatar
 
Oct 2007

10110102 Posts
Default

The error is:
CURL library error: failed to connect to 71.6.220.163. Invalid arguments.
A couple of lines above that it gives the url it is trying to connect to.
Jud McCranie is offline   Reply With Quote
Old 2009-01-16, 23:50   #5
Jud McCranie
 
Jud McCranie's Avatar
 
Oct 2007

2×32×5 Posts
Default

Apparently it hasn't been able to communicate to Primenet since I upgreaded it to version 25.7 and switched to the new Primenet stuff. The other computers worked after the change.
Jud McCranie is offline   Reply With Quote
Old 2009-01-17, 02:39   #6
Prime95
P90 years forever!
 
Prime95's Avatar
 
Aug 2002
Yeehaw, FL

32×853 Posts
Default

Quote:
Originally Posted by Jud McCranie View Post
Apparently it hasn't been able to communicate to Primenet since I upgreaded it to version 25.7 and switched to the new Primenet stuff. The other computers worked after the change.
You could try "Debug=2" to the PrimeNet section of prime.txt
Prime95 is offline   Reply With Quote
Old 2009-01-17, 02:55   #7
Jud McCranie
 
Jud McCranie's Avatar
 
Oct 2007

5A16 Posts
Default

Quote:
Originally Posted by Prime95 View Post
You could try "Debug=2" to the PrimeNet section of prime.txt
That didn't fix it, but I think it gave more info:
-----------------
trying 71.6.220.163
failed to connect ... invalid arguments
no error
couldn't connect to host
closing connection #0
----------------

If I uninstalled and reinstalled, might that help? If I did that, would it lose the results it hasn't sent?
Jud McCranie is offline   Reply With Quote
Old 2009-01-17, 13:49   #8
Prime95
P90 years forever!
 
Prime95's Avatar
 
Aug 2002
Yeehaw, FL

32×853 Posts
Default

The extra information wasn't very helpful.

I can't imagine reinstalling would help, but it cannot hurt.

I've no idea what is wrong. You could try the very lightly tested "UseCURL=0" option in the [PrimeNet] section.
Prime95 is offline   Reply With Quote
Old 2009-01-17, 14:07   #9
S485122
 
S485122's Avatar
 
"Jacob"
Sep 2006
Brussels, Belgium

1,753 Posts
Default

Quote:
Originally Posted by Jud McCranie View Post
If I uninstalled and reinstalled, might that help? If I did that, would it lose the results it hasn't sent?
Save all your result files (fXXXXXXX, mXXXXXXX, pXXXXXXX, qXXXXXX, results.txt, worktodo.txt and prime.log) I would save the configuration files as well, but I would not use them for the new installation. Be sure to set your user ID and computer ID though.
With the change of computer ID you might lose your current assigments.

I you do not want to loose credit for the work already done, log into your account on the primenet server (www.mersenne.org) and then submit your results manually.

Jacob
S485122 is offline   Reply With Quote
Old 2009-01-18, 02:11   #10
Jud McCranie
 
Jud McCranie's Avatar
 
Oct 2007

2·32·5 Posts
Default

Neither of those worked. (useCURL or reinstalling). There were no fxxxx files,etc. Below is some text from two files, this probably dates to the time I upgraded to version 25, and perhaps I forgot to stop Prime95 or something.
---------------------------
results
-------
[Wed Nov 12 15:00:27 2008]
Spool file is corrupt. Attempting to salvage data.
Spool file is corrupt. Attempting to salvage data.
[Fri Dec 05 15:22:44 2008]
UID: JudMcCranie/upstairs, M44362613 is not prime. Res64: 32DE55A05BC591AE. Wd1: 3FA85876,28455888,00000000, AID: 763A720920854F08288F03EFEB29E1C2


prime.log has many of these:
---------
Updating computer information on the server
URL: http://v5.mersenne.org/v5server/?v=0.95&px=GIMPS&t=uc&g=50e1b357590702d94b3568f3401319c5&hg=ea3ef3d406dc0acf88e6ea358b5a63ee&wg=481a1d0aca0d8dfb48e461c1e2bf020b&a=Windows,Prime95,v25.8,build+5&c=Intel(R)+Pentium(R)+4+CPU+3.00GHz&f=Prefetch,SSE,SSE2&L1=16&L2=1024&np=1&hp=2&m=503&s=2992&h=24&r=1113&ss=41&sh=DA9EB9EAD761E429F90B4A0EFE091D5F
== Info: About to connect() to v5.mersenne.org port 80
== Info: Trying 71.6.220.163...
== Info: Failed to connect to 71.6.220.163: Invalid arguments
== Info: No error
== Info: couldn't connect to host
== Info: Closing connection #0
CURL library error: Failed to connect to 71.6.220.163: Invalid arguments

Last fiddled with by Jud McCranie on 2009-01-18 at 02:12
Jud McCranie is offline   Reply With Quote
Old 2009-01-18, 02:27   #11
MatWur-S530113
 
MatWur-S530113's Avatar
 
Apr 2007
Spessart/Germany

2428 Posts
Default

Hello,

maybe it is a spool-file from the old prime95 v24, I think they are not compatible. Try this: save the spool file (*.spl) to another directory and try to connect to the server without it. If it works send the old *.spl file to George Woltman, maybe he is able to recover some data out of it. If it doesn't work it could be a firewall which suppresses the connection.

best regards,

Matthias

edit: before moving the spl-file exit prime95 please ;)

Last fiddled with by MatWur-S530113 on 2009-01-18 at 02:31
MatWur-S530113 is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot connect to mersenne.ca by wifi thyw mersenne.ca 1 2016-06-20 00:14
Client can't connect to server Cow_tipping Prime Sierpinski Project 1 2011-10-11 19:06
One PC Can't Connect to PrimeNet Rodrigo PrimeNet 5 2010-10-20 04:26
can't connect to primenet dbw784 Software 13 2004-06-28 11:10
can't connect to server daWabbit Software 7 2002-08-31 23:10

All times are UTC. The time now is 12:29.


Tue Nov 30 12:29:05 UTC 2021 up 130 days, 6:58, 0 users, load averages: 1.13, 1.11, 1.04

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.