mersenneforum.org  

Go Back   mersenneforum.org > Extra Stuff > Linux

Reply
 
Thread Tools
Old 2007-11-17, 15:22   #1
apocalypse
 
Feb 2003

2·3·29 Posts
Default Problems after upgrading to ubuntu gutsy

Hi -

I upgraded from kubuntu feisty to gutsy (2.6.22-14) yesterday, and subsequently mprime fails immediately with a SIGFPE:
Quote:
$ ./mprime -d
Mersenne number primality test program version 24.14
Contacting PrimeNet Server.
host = mersenne.org, port = 80
Floating point exception (core dumped)
I ran the torture test overnight with no warning or errors.
I tried running the statically-linked version with the same result.
The last few lines from strace are:
Quote:
open("/etc/ld.so.cache", O_RDONLY) = 4
fstat64(0x4, 0xffe10370) = 0
old_mmap(NULL, 76524, PROT_READ, MAP_PRIVATE, 4, 0) = 0xfffffffff7f10000
close(4) = 0
open("/lib32/libnss_mdns4_minimal.so.2", O_RDONLY) = 4
read(4, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0p\7\0\000"..., 512) = 512
fstat64(0x4, 0xffe10404) = 0
old_mmap(NULL, 9628, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 4, 0) = 0xfffffffff7c9a000
old_mmap(0xf7c9c000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 4, 0x1000) = 0xfffffffff7c9c000
close(4) = 0
--- SIGFPE (Floating point exception) @ 0 (0) ---
+++ killed by SIGFPE (core dumped) +++
I tried running the pre-beta mprime255a-linux64, and that appears to work, but I'd rather run on the stable software.

Can anyone help?

Thanks!

Last fiddled with by apocalypse on 2007-11-17 at 15:42
apocalypse is offline   Reply With Quote
Old 2007-12-02, 20:19   #2
Eric Strand
 

7,193 Posts
Default Problems after upgrading to ubuntu gutsy

I've encountered the same problem, though my installation history differs a bit - I am using a fresh install of gutsy.

mprime worked as expected UNTIL I installed the ia32-libs package necessary for another application I was evaluating.

Removing the ia32-libs package solved the problem, and mprime works again as expected. So obviously there is some conflict caused by it, but it's beyond my knowledge to figure out the exact issue.

Hopefully this bit of information will help you.

--Eric
  Reply With Quote
Old 2007-12-03, 05:57   #3
BlisteringSheep
 
BlisteringSheep's Avatar
 
Oct 2006
On a Suzuki Boulevard C90

2×3×41 Posts
Default

The command
Code:
ldd ./mprime
will show you which dynamic libraries the executable will use when it is run. When there are multiple libraries with the same name on the system, it is possible to influence which it will pick with the LD_LIBRARY_PATH environment variable, ie:
Code:
setenv LD_LIBRARY_PATH /lib64:/lib32
for t/csh or
Code:
export LD_LIBRARY_PATH=/lib64:/lib32
for b/a/sh.

Last fiddled with by BlisteringSheep on 2007-12-03 at 05:57 Reason: typo
BlisteringSheep is offline   Reply With Quote
Old 2007-12-22, 23:24   #4
embretr
 
Dec 2007

3 Posts
Default Same trouble.

I've got the same kind of problem. Ubuntu 7.10, and the static linked mprime 2414 fails me miserably.

Quote:
embretr@Butterfly2:~/prime$ ./mprime -d
Mersenne number primality test program version 24.14
Contacting PrimeNet Server.
Floating point exception (core dumped)
same procedure works flawlessly on a similar box with ubuntu 6.10 :/

I will try to downgrade to see if that will improve the situation
embretr is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrading a cat. 0 box ckdo PrimeNet 3 2018-03-12 15:24
Upgrading a LGA 775 foxmccloud123 Hardware 14 2013-05-19 06:09
Upgrading Ubuntu from 9.04 to 11.04 ET_ Linux 9 2012-03-05 20:04
Ubuntu 9.04: Installing GMP-ECM; problems with GMP Andi47 Linux 4 2009-10-01 06:31
Screen resolution problem after upgrading ubuntu fivemack Linux 6 2008-05-24 12:51

All times are UTC. The time now is 09:58.

Tue Jan 19 09:58:41 UTC 2021 up 47 days, 6:10, 0 users, load averages: 1.55, 1.63, 1.82

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.