mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > PrimeNet

Reply
 
Thread Tools
Old 2015-10-14, 19:25   #1035
Prime95
P90 years forever!
 
Prime95's Avatar
 
Aug 2002
Yeehaw, FL

22×1,789 Posts
Default

Quote:
Originally Posted by Mark Rose View Post
The expected behaviour would be for it to return no work, unless I'm misunderstanding something.
Well, TF for DC looked for any exponents in the range that were marked as available for TF, P-1, or DC. I've changed the query to only look for DC.
Prime95 is offline   Reply With Quote
Old 2015-10-14, 19:32   #1036
Mark Rose
 
Mark Rose's Avatar
 
"/X\(‘-‘)/X\"
Jan 2013

3·953 Posts
Default

Quote:
Originally Posted by Prime95 View Post
Well, TF for DC looked for any exponents in the range that were marked as available for TF, P-1, or DC. I've changed the query to only look for DC.
Excellent, thank you!
Mark Rose is offline   Reply With Quote
Old 2015-10-28, 05:42   #1037
S485122
 
S485122's Avatar
 
Sep 2006
Brussels, Belgium

22×3×131 Posts
Default Team Summary page

.

Last fiddled with by S485122 on 2015-10-28 at 05:59 Reason: Wrong thread
S485122 is offline   Reply With Quote
Old 2015-11-22, 01:00   #1038
Mark Rose
 
Mark Rose's Avatar
 
"/X\(‘-‘)/X\"
Jan 2013

3×953 Posts
Default

I found a bug. I was looking through the CPU benchmarks and found a couple of suspect results. I checked 2 of the 6 results that looked suspect, and marked them as such. The page returned with a couple of success messages, but also this warning:

Code:
Notice: Undefined variable: t_cpu_model in C:\inetpub\www\report_benchmarks\default.php on line 366 Notice: Undefined variable: t_cpu_model in C:\inetpub\www\report_benchmarks\default.php on line 378 Notice: Undefined variable: t_cpu_model in C:\inetpub\www\report_benchmarks\default.php on line 378 Notice: Undefined variable: t_cpu_model in C:\inetpub\www\report_benchmarks\default.php on line 382 Notice: Undefined variable: t_cpu_model in C:\inetpub\www\report_benchmarks\default.php on line 386
When I load the benchmarks for the CPU anew no errors occur and the 2 suspect results are hidden.
Mark Rose is offline   Reply With Quote
Old 2015-11-22, 01:30   #1039
James Heinrich
 
James Heinrich's Avatar
 
"James Heinrich"
May 2004
ex-Northern Ontario

BD516 Posts
Default

I've just patched the report_benchmarks file to suppress any such errors.
James Heinrich is online now   Reply With Quote
Old 2015-11-22, 04:59   #1040
Mark Rose
 
Mark Rose's Avatar
 
"/X\(‘-‘)/X\"
Jan 2013

3×953 Posts
Default

Quote:
Originally Posted by James Heinrich View Post
I've just patched the report_benchmarks file to suppress any such errors.
Excellent. :)
Mark Rose is offline   Reply With Quote
Old 2015-11-22, 05:07   #1041
retina
Undefined
 
retina's Avatar
 
"The unspeakable one"
Jun 2006
My evil lair

2×3×5×191 Posts
Default

Quote:
Originally Posted by Mark Rose View Post
Excellent. :)
Hmm. Suppression of errors is the same as fixing the errors? Or is it just pretending it didn't happen?
retina is offline   Reply With Quote
Old 2015-11-22, 05:09   #1042
James Heinrich
 
James Heinrich's Avatar
 
"James Heinrich"
May 2004
ex-Northern Ontario

302910 Posts
Default

A little of both.
James Heinrich is online now   Reply With Quote
Old 2015-11-22, 08:25   #1043
Mark Rose
 
Mark Rose's Avatar
 
"/X\(‘-‘)/X\"
Jan 2013

3·953 Posts
Default

Quote:
Originally Posted by retina View Post
Hmm. Suppression of errors is the same as fixing the errors? Or is it just pretending it didn't happen?
Gotta love error_reporting(0); ;)
Mark Rose is offline   Reply With Quote
Old 2016-01-10, 16:01   #1044
GhettoChild
 
"Ghetto_Child"
Jul 2014
Montreal, QC, Canada

41 Posts
Default

why am I getting this error for ANY exponent I manually request, regardless of the range/size of the exponent?

Error code: 40
Error text: No assignment available meeting CPU, program code and work preference requirements, cpu_id: *****, cpu # = 0, user_id = ****
GhettoChild is offline   Reply With Quote
Old 2016-01-11, 02:42   #1045
Prime95
P90 years forever!
 
Prime95's Avatar
 
Aug 2002
Yeehaw, FL

22·1,789 Posts
Default

Quote:
Originally Posted by GhettoChild View Post
why am I getting this error for ANY exponent I manually request, regardless of the range/size of the exponent?

Error code: 40
Error text: No assignment available meeting CPU, program code and work preference requirements, cpu_id: *****, cpu # = 0, user_id = ****
What work type are you trying, what exponent range?
Prime95 is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Official "Faits erronés dans de belles-lettres" thread ewmayer Lounge 39 2015-05-19 01:08
Official "all-Greek-to-me Fiction Literature and Cinema" Thread ewmayer Science & Technology 41 2014-04-16 11:54
Official "Lasciate ogne speranza" whinge-thread cheesehead Soap Box 56 2013-06-29 01:42
Official "Ernst is a deceiving bully and George is a meanie" thread cheesehead Soap Box 61 2013-06-11 04:30
Official "String copy Statement Considered Harmful" thread Dubslow Programming 19 2012-05-31 17:49

All times are UTC. The time now is 00:17.

Fri Sep 25 00:17:47 UTC 2020 up 14 days, 21:28, 0 users, load averages: 1.72, 1.74, 1.66

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.