mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > PrimeNet

Reply
 
Thread Tools
Old 2014-11-26, 02:23   #848
Madpoo
Serpentine Vermin Jar
 
Madpoo's Avatar
 
Jul 2014

2×1,637 Posts
Default

Quote:
Originally Posted by James Heinrich View Post
You're reporting the results as an anonymous user:
Code:
UID: ANONYMOUS, M78219187 completed P-1, B1=730000, B2=15330000, E=6, ....
Please be sure that you're logged in to mersenne.org when requesting manual assignments. Nevertheless, your duplicate results were submitted with the same assignment ID and shouldn't have been registered as a duplicate entry. I'm not sure if I understand all that code but I'll see if I can trace why that happened.

Would you mind please submitting another copy of the results line for one of those assignments (let's use M78219187) the way you usually do and let me know what text is shown on screen, especially any error or notification messages (will usually show up in orange/red text).
Yeah, if I understand it right, if there's a duplicate assignment ID (the AID: part of the result) then it should see it as a duplicate. However, that might not work necessarily if checking the same thing in different batches. I think it might remove the original assignment once a result is checked in... the next time it's tried to check in, it can't find a matching AID anymore, so it looks at other things like the username, exponent, etc. to see if it's the same thing. With ECM results it's hard to tell since you could have just run more curves with the same settings... like, is that the same 150 curves, or 150 more?

There could be more going on there... like James I haven't really looked much at that part of the site.
Madpoo is offline   Reply With Quote
Old 2014-11-26, 03:24   #849
Madpoo
Serpentine Vermin Jar
 
Madpoo's Avatar
 
Jul 2014

2×1,637 Posts
Default

Quote:
Originally Posted by ric View Post
A very minor point, but somehow annoying for some of my scripts: when a username contains non-ASCII characters (ä, ü, ø et al.), at least in report_ll and exponent status pages, username is fetched as an empty string.

A few examples: 559554121 - report LL, 25087351 - report LL (the line with bad result), again 55954121 - exp status. In this last example, username does not appear within the results section, but is however present within history (the last line).

I recall that a few weeks ago there have been adjustments to fetching procedures in order to retrieve all names as coded with Unicode/UTF-8, if someone could put a glance on this...
Ah... well, there's your problem. :) Yeah, it's a UTF-8 encoding thing.

I've been working on an update to the exponent report page anyway, so I just added in the proper encoding for the user name fields (in the LL result, assignment, and history sections).

The good news is, it works. The bad news is, I'm waiting on a couple more tests before I launch the updated page.

I guess for now it's not a big deal to tweak the existing page and add the proper encoding on those bits. Easy enough.
Madpoo is offline   Reply With Quote
Old 2014-11-26, 04:26   #850
LaurV
Romulan Interpreter
 
LaurV's Avatar
 
Jun 2011
Thailand

25·3·7·13 Posts
Default

Quote:
Originally Posted by Madpoo View Post
Ah... well, there's your problem. :).
Actually not, it seems that there is nothing passed to firefox. The HTML source says:
Code:
<tr><td align="right"><a href="/M55954121">55954121</a></td><td>ANONYMOUS</td><td>ajm</td><td>D224A31541C53C32</td><td>2014-02-28 04:01</td></tr>
<tr><td align="right"><a href="/M55954121">55954121</a></td><td></td><td>La_undecima</td><td>D224A31541C53C32</td><td>2014-11-20 16:26</td></tr>
So the user name is totally missing.
Anyhow, this is cosmetic.

Last fiddled with by LaurV on 2014-11-26 at 04:29 Reason: red bold to clarify, edit bad links to local source :)
LaurV is offline   Reply With Quote
Old 2014-11-26, 04:29   #851
Madpoo
Serpentine Vermin Jar
 
Madpoo's Avatar
 
Jul 2014

2·1,637 Posts
Default

Quote:
Originally Posted by LaurV View Post
You can not. Some people don't want to be looked up. For example, I "looked up" for Chris' account "For Research" for ages without success until he told me (and said public on the forum) that his username was "wabbit" (technically, he said it first, but I didn't pay attention) when I wanted to report some results and give him some "credits". By the way, knowing a valid username of somebody else, could result in a situation when some idiot deliberately reports wrong results for other people, to discredit them; as it is now, you don't need my password to report a result, only my user name, so technically you can report 100 random (wrong) LL results for me, making me look like a credit whore; well, not that I am not, but you got the idea This can have side effects for GIMPS as exponents with one LL done will not be LL-ed again (DC-ed) for few years causing a prime to be missed for a while. Just a stupid example how a personal feud can have bad effect on the general project. If you don't know my user name, you can't do that.
Hmmm... I'm doing some testing and tweaking with that page.

I've got a test page setup to only *display* the public name, but (and fixed for UTF8 output), but it will accept *either* the login name *or* the public name.

Since the public name is NOT unique, then you could indeed see some bizarre results. Obviously "ANONYMOUS" is the biggest culprit, with 33,925 instances. But there are some other heavily used public names like "chris" (175 of them), "Alex" (142), "Mike" (131) and so on.

In all there are 3876 public names that show up twice or more, and that's out of 82,627 distinct public user names (that's 4.7% which are duplicates).

So... not really sure how practical it would be to show results that match some user name like "chris"... good luck finding just the Chris you intended.

This is another of those "what's the use case" for this report and the ability to search by user name? Knowing how people use the data is always my first question, because otherwise I may be solving a problem nobody has. :)

At the very least I'll work in those utf8 encoding things to that user names with accents and whatnots will show up okay.
Madpoo is offline   Reply With Quote
Old 2014-11-26, 05:02   #852
Madpoo
Serpentine Vermin Jar
 
Madpoo's Avatar
 
Jul 2014

2×1,637 Posts
Default

Quote:
Originally Posted by LaurV View Post
Actually not, it seems that there is nothing passed to firefox. The HTML source says:
Code:
<tr><td align="right"><a href="/M55954121">55954121</a></td><td>ANONYMOUS</td><td>ajm</td><td>D224A31541C53C32</td><td>2014-02-28 04:01</td></tr>
<tr><td align="right"><a href="/M55954121">55954121</a></td><td></td><td>La_undecima</td><td>D224A31541C53C32</td><td>2014-11-20 16:26</td></tr>
So the user name is totally missing.
Anyhow, this is cosmetic.
Well, it's probably just PHP or IIS choking on it and omitting it.

Anyway, it works now. Enjoy!
Madpoo is offline   Reply With Quote
Old 2014-11-26, 05:14   #853
LaurV
Romulan Interpreter
 
LaurV's Avatar
 
Jun 2011
Thailand

210408 Posts
Default

It works well now on my side here.
Thanks for very prompt fixing! (actually, ric's problem, hehe)
LaurV is offline   Reply With Quote
Old 2014-11-26, 12:15   #854
ric
 
ric's Avatar
 
Jul 2004
Milan, Ita

2648 Posts
Default Ahem...

Quote:
Originally Posted by Madpoo View Post
Well, it's probably just PHP or IIS choking on it and omitting it.

Anyway, it works now. Enjoy!
Madpoo, thanks for your prompt support to such a minor point - and apologies in advance for being this much picky on such a cosmetic thing.

While the issue is resolved in the "exponent status" page, where everything looks now fine, alas, I see that the "report_ll" page is still not extracting the names, at least in this case (see bad result), as per:
Code:
<tr><td align="right">25087351</td><td></td><td>Marvel-home</td><td>58856B83331F13F6</td><td>0000002A</td><td></td></tr>
.

Furthermore, while exp status extracts the correct encoded values both in simple text and in full-html modes, the report_ll page instead is fine when viewed in html, but not yet when invoked in simple text mode (this is html) - (this is simple text) in both cases, the second entry.

TIA
ric
ric is offline   Reply With Quote
Old 2014-11-26, 23:06   #855
Madpoo
Serpentine Vermin Jar
 
Madpoo's Avatar
 
Jul 2014

1100110010102 Posts
Default

Quote:
Originally Posted by ric View Post
Madpoo, thanks for your prompt support to such a minor point - and apologies in advance for being this much picky on such a cosmetic thing.

While the issue is resolved in the "exponent status" page, where everything looks now fine, alas, I see that the "report_ll" page is still not extracting the names, at least in this case (see bad result), as per:
Code:
<tr><td align="right">25087351</td><td></td><td>Marvel-home</td><td>58856B83331F13F6</td><td>0000002A</td><td></td></tr>
.

Furthermore, while exp status extracts the correct encoded values both in simple text and in full-html modes, the report_ll page instead is fine when viewed in html, but not yet when invoked in simple text mode (this is html) - (this is simple text) in both cases, the second entry.

TIA
ric
Huh... well, how do you like that. Until this very moment I had completely missed the fact that there's a whole other possible table on that page for "bad results". I'd fixed up the verified/unverified stuff but I apparently missed the fact that there's a section for bad stuff. Go figure. I don't even have it showing in a proper table either.

Well, I'll get that going... I also didn't fix up the text only names. I saw that but I wasn't sure if the text page is encoded in utf8 to the browser but then I see that it's not just dumping as a raw TXT file to download, but showing it in a text box. I think I knew that I was just in a hurry or being lazy. I'll wrap those so they encode properly.

EDIT: Actually the problem with the text only results was that I *was* utf8 encoding them, and they shouldn't have been, so anything with accents was showing up funkified. Fixed.

Last fiddled with by Madpoo on 2014-11-26 at 23:12
Madpoo is offline   Reply With Quote
Old 2014-11-27, 11:29   #856
ric
 
ric's Avatar
 
Jul 2004
Milan, Ita

22·32·5 Posts
Default

Quote:
Originally Posted by Madpoo View Post
<snip>
so anything with accents was showing up funkified. Fixed.
Great work! Thanks again.
ric
ric is offline   Reply With Quote
Old 2014-12-28, 15:09   #857
tha
 
tha's Avatar
 
Dec 2002

5·157 Posts
Default

On the "exponent status" page, can there be a destinction made between "expired on" and "checked in on". Currently assignments are said to have expired as they were checked in, which can create confusion.
tha is offline   Reply With Quote
Old 2014-12-30, 07:57   #858
Madpoo
Serpentine Vermin Jar
 
Madpoo's Avatar
 
Jul 2014

CCA16 Posts
Default Server maintenance in a few minutes

I'm going to give the web server a quick reboot. I was waiting for a nice quiet time post-Christmas, this seems like it.

It'll be down in about 5 minutes from now (midnight PST) and I think it'll be about 5-10 minutes before it's back up.
Madpoo is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Official "Faits erronés dans de belles-lettres" thread ewmayer Lounge 39 2015-05-19 01:08
Official "all-Greek-to-me Fiction Literature and Cinema" Thread ewmayer Science & Technology 41 2014-04-16 11:54
Official "Lasciate ogne speranza" whinge-thread cheesehead Soap Box 56 2013-06-29 01:42
Official "Ernst is a deceiving bully and George is a meanie" thread cheesehead Soap Box 61 2013-06-11 04:30
Official "String copy Statement Considered Harmful" thread Dubslow Programming 19 2012-05-31 17:49

All times are UTC. The time now is 15:48.

Tue Sep 22 15:48:30 UTC 2020 up 12 days, 12:59, 1 user, load averages: 1.75, 1.69, 1.65

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.