mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > PrimeNet

Reply
 
Thread Tools
Old 2019-02-03, 00:26   #1640
chalsall
If I May
 
chalsall's Avatar
 
"Chris Halsall"
Sep 2002
Barbados

221368 Posts
Default

Quote:
Originally Posted by Madpoo View Post
I'll use M96312371 as an example. When you got the assignment, it didn't have any P-1 done on it yet.
Just putting this out there for consideration...

If people use the usual assignment procedures, no LL'ing assignment will be given which has not been P-1'ed, and probably optimally TF'ed.

This candidate seems to be a bit unusual. ramgeis first did the LL test, then did a P-1 test, and then did a second LL test.

No disrespect intended, but this candidate will need another test by an independent player before the results can be trusted.

Last fiddled with by chalsall on 2019-02-03 at 00:28 Reason: s/has not be P-1'ed/has not been P-1'ed/;
chalsall is offline   Reply With Quote
Old 2019-02-03, 01:00   #1641
GP2
 
GP2's Avatar
 
Sep 2003

22·3·5·43 Posts
Default

Quote:
Originally Posted by chalsall View Post
This candidate seems to be a bit unusual. ramgeis first did the LL test, then did a P-1 test, and then did a second LL test.

No disrespect intended, but this candidate will need another test by an independent player before the results can be trusted.
ramgeis and Madpoo have been discussing this very exponent and a couple of others, a few messages upstream in this same thread.
GP2 is offline   Reply With Quote
Old 2019-02-03, 01:31   #1642
Madpoo
Serpentine Vermin Jar
 
Madpoo's Avatar
 
Jul 2014

2·1,637 Posts
Default

Quote:
Originally Posted by chalsall View Post
Just putting this out there for consideration...

If people use the usual assignment procedures, no LL'ing assignment will be given which has not been P-1'ed, and probably optimally TF'ed.

This candidate seems to be a bit unusual. ramgeis first did the LL test, then did a P-1 test, and then did a second LL test.

No disrespect intended, but this candidate will need another test by an independent player before the results can be trusted.
I didn't see an LL test on that exponent, just the two PRP tests.

Anyway, I looked and there are currently 481 exponents available for P-1 work that currently have at least one LL or PRP test completed.

That's weird, and that seems to be the crux of this problem... LL/PRP being done without first finishing the HIGHLY recommended P-1 test to start.

PRP-1 functionality is cool, but if the client doesn't support that or we need to do a double-check of an LL test, then we gotta get those P-1 tests done first on the off-chance it finds a factor.

459 of those 481 are for LL tests, with the remainder having a PRP test done previously. And of course a good amount of them are in that zone of 90M-100M exponents, right where ramgeis' work has been lately and when the issue came up.

I was pointing out that in the case of Prime95 at least, I'm fairly certain when it creates the worktodo entry, if no P-1 has been done yet, the worktodo entry ends with a ",0". Otherwise a ",1" means P-1 is done and isn't necessary. Prime95 will see that and do the P-1.

My guess is those 481 oddballs are from non-Prime95 clients doing work without doing the P-1 first, and if I'm following the check-in code correctly, it sees that and then tries to assign them out *specifically* as P-1 work to make sure it's done first.

It's that type of work that ramgeis was picking up on his next "get assignment" pass, which makes me wonder if that work type is technically being treated the same as a first-time check, rather than a double-check in certain cases.

We could just be at a point where we need to pick up the pace on P-1, or modify the assignment handling on the back end to better cope. I'm glancing at the "get assignment" code and I could be wrong, but the P-1 assignment types seem to be treated like a first-time check, which would normally be true, but isn't in 481 specific cases at the moment.
Madpoo is offline   Reply With Quote
Old 2019-02-03, 12:10   #1643
ric
 
ric's Avatar
 
Jul 2004
Milan, Ita

101101002 Posts
Default Result gone MIA?

Last night, one of my boxes returned a result for M82911853. Something must have gone wild in the process, since:
  • exponent has disappeared from assignments list, as it should
  • however, it does not appear neither in "account results", nor in "recent cleared results"
  • if I look at exponent details, test completion is reported, but it does not appear in its "history" section.
My local log reports
Code:
[Sun Feb 03 00:23:53 2019 - ver 29.4]
Sending result to server: UID: RU/Xeon12C, M82911853 is not prime. Res64: <>. Wg5: 8277296A,29364637,00000000, AID: <>

CURL library error: Operation timed out after 180 seconds with 0 bytes received
[Sun Feb 03 02:48:54 2019 - ver 29.4]
Updating computer information on the server
Sending result to server: UID: RU/Xeon12C, M82911853 is not prime. Res64: <>. Wg5: 8277296A,29364637,00000000, AID: <>

PrimeNet error 40: No assignment
This computer has already sent in this LL result for M82911853
Again, a very minor annoyance, reported just to leave track of it.
ric is offline   Reply With Quote
Old 2019-02-04, 01:31   #1644
Madpoo
Serpentine Vermin Jar
 
Madpoo's Avatar
 
Jul 2014

2·1,637 Posts
Default

Quote:
Originally Posted by ric View Post
...
CURL library error: Operation timed out after 180 seconds with 0 bytes received
...
Again, a very minor annoyance, reported just to leave track of it.
Odd. It seems like the server had a hiccup of some sort writing the raw results line to the table where those live. The result itself was saved (there's a different, more concise table just for the LL results) so it's only affecting the history section which is also where the recent results are pulled from.

I'll have to look at the server logs around that time and see what happened, but judging from the curl timeout, I'd guess there was a SQL blocking issue. If I have to I can manually add that result line into the history.

EDIT: I didn't find anything unusual in the server logs apart from the fact that it logged your result actually coming in 6 minutes later than I expected. So that may have been a network issue between client/server of some kind. Anyway, I manually added the history result.

Last fiddled with by Madpoo on 2019-02-04 at 02:31
Madpoo is offline   Reply With Quote
Old 2019-02-10, 00:37   #1645
xx005fs
 
"Eric"
Jan 2018
USA

32×23 Posts
Default Efficiency in % of your computers calculated wrong?

I recently realized that my 90 day average and past 24 hour of GHz-Days submitted was extremely high even though I only submitted a fraction (about 1/2) of the calculated amount. Is that a mistake on the calculation on the server or is it just limited to my computer? Just FYI I submitted about 3000GHz-Days of work today.
Attached Thumbnails
Click image for larger version

Name:	error.png
Views:	25
Size:	53.9 KB
ID:	19877  

Last fiddled with by xx005fs on 2019-02-10 at 00:37
xx005fs is offline   Reply With Quote
Old 2019-02-10, 01:36   #1646
TheJudger
 
TheJudger's Avatar
 
"Oliver"
Mar 2005
Germany

21238 Posts
Default

xxx005fs: doing some work on GPUs an submitting manually? If so than this is normal!

Oliver
TheJudger is offline   Reply With Quote
Old 2019-02-10, 01:48   #1647
xx005fs
 
"Eric"
Jan 2018
USA

32×23 Posts
Default

Quote:
Originally Posted by TheJudger View Post
xxx005fs: doing some work on GPUs an submitting manually? If so than this is normal!

Oliver
Indeed I'm submitting work on GPU. But it used to be okay like 2 weeks ago. The calculations were normal. BTW how can you submit GPU work without doing manual assignment or manually assign an assignment to a specific worker?
xx005fs is offline   Reply With Quote
Old 2019-02-10, 07:28   #1648
Mark Rose
 
Mark Rose's Avatar
 
"/X\(‘-‘)/X\"
Jan 2013

23·3·7·17 Posts
Default

The server knows how much throughput your CPUs should give, based on the hours per day they're configured to run and so on. When you submit GPU work the server isn't aware of your GPUs and so the calculation is off.
Mark Rose is offline   Reply With Quote
Old 2019-02-10, 07:46   #1649
xx005fs
 
"Eric"
Jan 2018
USA

32·23 Posts
Default

Quote:
Originally Posted by Mark Rose View Post
The server knows how much throughput your CPUs should give, based on the hours per day they're configured to run and so on. When you submit GPU work the server isn't aware of your GPUs and so the calculation is off.
Ahhhhh i see now. I always thought they were just the pure GHz-Days numbers. Thanks. I am looking for a way to manually assign things to my GPU as if I would on a CPU (aka giving it a "computer name" and get and receive work with assignment GUID). Is there any way to do that?
xx005fs is offline   Reply With Quote
Old 2019-02-10, 21:56   #1650
chalsall
If I May
 
chalsall's Avatar
 
"Chris Halsall"
Sep 2002
Barbados

2×5×72×19 Posts
Default

Quote:
Originally Posted by xx005fs View Post
Thanks. I am looking for a way to manually assign things to my GPU as if I would on a CPU (aka giving it a "computer name" and get and receive work with assignment GUID). Is there any way to do that?
Short answer: No. Longer answer:

The closest thing available at the moment is the MISFIT Application for Winblows, or the mfloop script for Linux. These are quite reliable; many people use them in a "fire and forget" scenario.

Importantly, these won't use a "GUID", but if you only have one GPU this shouldn't be a huge problem. They will be provided with an "AID" (Assignment ID), if you fetch from Primenet. These will also be tied to your particular Primenet and/or GPU72 Account (whichever you choose to use), and so you'll see them on your assignments page, and receive the credit upon completion.

Hope that helps.
chalsall is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Official "Faits erronés dans de belles-lettres" thread ewmayer Lounge 39 2015-05-19 01:08
Official "all-Greek-to-me Fiction Literature and Cinema" Thread ewmayer Science & Technology 41 2014-04-16 11:54
Official "Lasciate ogne speranza" whinge-thread cheesehead Soap Box 56 2013-06-29 01:42
Official "Ernst is a deceiving bully and George is a meanie" thread cheesehead Soap Box 61 2013-06-11 04:30
Official "String copy Statement Considered Harmful" thread Dubslow Programming 19 2012-05-31 17:49

All times are UTC. The time now is 17:07.

Tue Sep 22 17:07:39 UTC 2020 up 12 days, 14:18, 1 user, load averages: 1.57, 1.70, 1.67

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.