mersenneforum.org  

Go Back   mersenneforum.org > Factoring Projects > Aliquot Sequences

Reply
 
Thread Tools
Old 2018-09-28, 14:28   #540
ChristianB
 
Apr 2013
Germany

1001101012 Posts
Default

Quote:
Originally Posted by ET_ View Post
Is it normal trying to factorize a 9-digit input using NFS?
No, it's not. It's just a fallback in case yafu fails for some reason. As I wrote earlier, it's better to increase the number of primes that are tested before the other tools. But that doesn't help against squares like 1010726611801 = 1005349^2 that are outside of the trial range. But it seems that at least in my case I just need to test with a newer msieve again. EdH, thanks for comparing.

Last fiddled with by ChristianB on 2018-09-28 at 14:30
ChristianB is offline   Reply With Quote
Old 2018-09-28, 19:56   #541
EdH
 
EdH's Avatar
 
"Ed Hall"
Dec 2009
Adirondack Mtns

2·7·239 Posts
Default

Quote:
Originally Posted by ChristianB View Post
... EdH, thanks for comparing.
Glad I can be helpful on occasion. The fix appears to be in r986:
Code:
Msieve v. 1.53 (SVN 985)
Fri Sep 28 15:52:38 2018
random seeds: ba9c90bf 271fe161
factoring 187991521 (9 digits)
commencing number field sieve (9-digit input)
error generating or reading NFS polynomials
elapsed time 00:00:00
Code:
Msieve v. 1.53 (SVN 986)
Fri Sep 28 15:52:02 2018
random seeds: 3b5f2f10 9cf2a0db
factoring 187991521 (9 digits)
p5 factor: 13711
p5 factor: 13711
elapsed time 00:00:00
EdH is offline   Reply With Quote
Old 2018-10-03, 16:22   #542
bsquared
 
bsquared's Avatar
 
"Ben"
Feb 2007

1100110110102 Posts
Default

Just-updated SVN 376 in /branch/wip has a fix (the starting SIQS line with input number is now always printed when starting SIQS).

Have not tested with aliqueit, but I expect this will solve the problem when using yafu.

One "issue" that remains is that aliqueit searches for "prp" strings in the output to indicate factors, since that is how yafu used to print them prior to aprcl code being added to the project. Now we know the factors are primes, but I am deliberately not changing the output to factor.log (from "prp" to "p") because of this dependency. I'm assuming most of the workload of yafu is in processing aliquot sequences. Not a big deal but my OCD is suffering
bsquared is offline   Reply With Quote
Old 2018-10-04, 10:32   #543
LaurV
Romulan Interpreter
 
LaurV's Avatar
 
Jun 2011
Thailand

2·3·31·47 Posts
Default

It should be no issue, aliqueit checks primality of the factors.
LaurV is offline   Reply With Quote
Old 2019-12-23, 00:50   #544
VBCurtis
 
VBCurtis's Avatar
 
"Curtis"
Feb 2005
Riverside, CA

10DF16 Posts
Default

I'm having a bit of trouble updating factorDB with my aliquot work:
running "./aliqueit -s nnnn {sequence}" results in:
Code:
Sending 273 lines...
--2019-12-22 16:44:36--  http://factordb.com/report.php
Resolving factordb.com (factordb.com)... 116.203.33.155
Connecting to factordb.com (factordb.com)|116.203.33.155|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 0 [text/html]
Saving to: ‘aliqueit_tmp_wget_19004963774880799438801’

aliqueit_tmp_wget_1900     [ <=>                       ]       0  --.-KB/s    in 0s      

2019-12-22 16:44:37 (0.00 B/s) - ‘aliqueit_tmp_wget_19004963774880799438801’ saved [0/0]
Do I need a newer aliqueit version? OS is ubuntu 16.04, aliqueit version 1.13.
VBCurtis is offline   Reply With Quote
Old 2019-12-23, 03:39   #545
EdH
 
EdH's Avatar
 
"Ed Hall"
Dec 2009
Adirondack Mtns

334610 Posts
Default

Quote:
Originally Posted by VBCurtis View Post
I'm having a bit of trouble updating factorDB with my aliquot work:
running "./aliqueit -s nnnn {sequence}" results in:
Code:
Sending 273 lines...
--2019-12-22 16:44:36--  http://factordb.com/report.php
Resolving factordb.com (factordb.com)... 116.203.33.155
Connecting to factordb.com (factordb.com)|116.203.33.155|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 0 [text/html]
Saving to: ‘aliqueit_tmp_wget_19004963774880799438801’

aliqueit_tmp_wget_1900     [ <=>                       ]       0  --.-KB/s    in 0s      

 2019-12-22 16:44:37 (0.00 B/s) - ‘aliqueit_tmp_wget_19004963774880799438801’ saved [0/0]
Do I need a newer aliqueit version? OS is ubuntu 16.04, aliqueit version 1.13.
The trouble is Ubuntu 16.04 (again). Wget needs an option telling it to use an earlier switch. I'm off to look for the post(s) with more info. I ran into this twice! Of course, to get Aliqueit to add the switch, you'll need to recompile. It might be easier to use a different system.


Edit: I guess my problem was actually receipt of zero-length files (which you also have) as well as not updating the db, but I suspect this may be the same issue. Anyway, here's the earlier post that helped me fix my trouble.

Last fiddled with by EdH on 2019-12-23 at 03:52
EdH is offline   Reply With Quote
Old 2019-12-23, 05:22   #546
VBCurtis
 
VBCurtis's Avatar
 
"Curtis"
Feb 2005
Riverside, CA

10000110111112 Posts
Default

I'll take this as a final hint to upgrade my primary desktop from 16.04 to 18.{whatever is LTS}. Thanks for the tip!
VBCurtis is offline   Reply With Quote
Old 2019-12-23, 16:49   #547
EdH
 
EdH's Avatar
 
"Ed Hall"
Dec 2009
Adirondack Mtns

64228 Posts
Default

Quote:
Originally Posted by VBCurtis View Post
I'll take this as a final hint to upgrade my primary desktop from 16.04 to 18.{whatever is LTS}. Thanks for the tip!
However, openmpi doesn't work in 18.04 LTS, as last I knew.* It will only work with the server. If you add a hostfile, it crashes. That has been keeping me from upgrading all my 16.04 machines.

The db problem only seems to be with wget. I wonder if there may be a way to set something in a wget config file.

*I'm hoping openmpi gets fixed before 16.04 LTS EoL next year. I check every once in a while and I've tried installing from source, but I could never figure out all the dependencies that didn't take care of themselves.


Edit: Good news - It looks like 16.04 LTS EoL isn't until April 2021.

Last fiddled with by EdH on 2019-12-23 at 17:40
EdH is offline   Reply With Quote
Old 2019-12-23, 17:57   #548
chris2be8
 
chris2be8's Avatar
 
Sep 2009

22·11·43 Posts
Default

After playing around with wget on a Ubuntu 16.04.6 LTS system I found that:
wget -d on it's own sends User-Agent: Wget/1.17.1 (linux-gnu) which fails.
On another system wget sends User-Agent: Wget/1.18 (linux-gnu) which works.
Changing the user agent with wget -d -U 'Wget/1.18.1 (linux-gnu)' works.
As does wget -d -U 'Wget/1.17 (linux-gnu)'

So it appears that factordb only rejects one case. But don't ask me why.

Nb The -d is to get debug output. It should not have any effect on whether the connection works.

Chris
chris2be8 is offline   Reply With Quote
Old 2019-12-23, 20:36   #549
chris2be8
 
chris2be8's Avatar
 
Sep 2009

22·11·43 Posts
Default

And after a bit more digging I found that set up a .wgetrc in my home dir containing:
Code:
user-agent = Wget/1.17 (linux-gnu)
was enough to make it work. Which might avoid having to update aliqueit.

Chris
chris2be8 is offline   Reply With Quote
Old 2019-12-23, 21:48   #550
EdH
 
EdH's Avatar
 
"Ed Hall"
Dec 2009
Adirondack Mtns

2·7·239 Posts
Default

Quote:
Originally Posted by chris2be8 View Post
And after a bit more digging I found that set up a .wgetrc in my home dir containing:
Code:
user-agent = Wget/1.17 (linux-gnu)
was enough to make it work. Which might avoid having to update aliqueit.

Chris
Excellent! I created .wgetrc with your suggested line, and it works great for my 16.04 machines:

Before:
Code:
2019-12-23 16:45:18 (0.00 B/s) - \u2018primo5000.zip\u2019 saved [0/0]
After:
Code:
2019-12-23 16:46:23 (120 KB/s) - \u2018primo5000.zip\u2019 saved [109170]
Thanks!
EdH is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Resuming aliqueit johnadam74 Aliquot Sequences 4 2016-03-28 12:32
Apparent aliqueit issue with specifying factors pakaran Aliquot Sequences 2 2015-09-12 23:10
Using Several Instances of Aliqueit for a large gnfs job EdH Aliquot Sequences 6 2011-12-13 18:58
Setting up aliqueit science_man_88 Aliquot Sequences 185 2011-11-08 12:18
Tried out aliqueit.exe: ggnfs failing Greebley Aliquot Sequences 35 2010-02-13 15:23

All times are UTC. The time now is 12:51.

Thu Sep 24 12:51:05 UTC 2020 up 14 days, 10:02, 2 users, load averages: 1.70, 1.65, 1.67

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.