mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > Software

Reply
 
Thread Tools
Old 2003-01-21, 19:53   #1
BillW
 

B4D16 Posts
Default Multiple systems/multiple CPUs. Best configuration?

I have been involved in this project for a number of years (User:Whitney). Just recently, I decided to use some excess cycles on other system. Since these systems (all Linux) all have my home directory mounted via NFS I thought I could run mprime on each system and redirect the output to system specific directories using the following script:
----------------------------------------------------
#!/bin/sh
if [ ! -d ./`hostname` ]; then
mkdir `hostname`
fi

CPUS=`grep vendor_id /proc/cpuinfo -c`

while [ $CPUS != 0 ]; do
./mprime -w`hostname` -b -a$CPUS
CPUS=`expr $CPUS - 1`
done
---------------------------------------------------------

All that I do is log onto the target system and run the script. The correct number of processes are started depending on the number of CPU's.

It's not clear if this is the correct technique and that all the work is credited to my account. None of the system specific ini files have any info regarding my account, although there is a prime.ini file in the parent directory that was created when I was only running mprime from that single directory.

The files that are contained in the host specific directory for a dual cpu system are:

[root@dtl8a223 eng17264.adv.eng]# ls -la
total 80
drwxr-xr-x 2 wwhitney media 512 Jan 21 14:45 .
drwxrwxr-x 5 wwhitney media 1024 Jan 21 14:32 ..
-rw-r--r-- 1 wwhitney media 173 Jan 21 14:24 loca0001.ini
-rw-r--r-- 1 wwhitney media 173 Jan 21 14:24 loca0002.ini
-rw-r--r-- 1 wwhitney media 92 Jan 21 14:24 prim0001.ini
-rw-r--r-- 1 wwhitney media 172 Jan 21 14:24 prim0001.log
-rw-r--r-- 1 wwhitney media 92 Jan 21 14:24 prim0002.ini
-rw-r--r-- 1 wwhitney media 172 Jan 21 14:24 prim0002.log
-rw-r--r-- 1 wwhitney media 19 Jan 21 14:24 work0001.ini
-rw-r--r-- 1 wwhitney media 19 Jan 21 14:24 work0002.ini
[root@dtl8a223 eng17264.adv.eng]#
Do I have these systems configured properly or should I be doing something different?

Thanks, Bill
  Reply With Quote
Old 2003-01-21, 20:11   #2
garo
 
garo's Avatar
 
Aug 2002
Termonfeckin, IE

2·5·251 Posts
Default

Instead of the prime.ini and local.ini for a dual sytem prim0001.ini and loca0001.ini etc are created. Make sure that the Username and password are correctly set to your username in the prim0001.ini and prim0002.ini files. Also, make sure the computer ID is correctly set in the loca0001.ini and 0002 files. Then all these systems should show up under your individual account report.

Otherwise the setup looks good.
garo is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Scripting startup on multiple systems stebbo Software 5 2016-09-17 08:45
Multiple GPU's Windows 10 cardogab7341 GPU Computing 5 2015-08-09 13:57
Using multiple PCs numbercruncher Information & Answers 18 2014-04-17 00:17
Are multiple gpu's necessary for CUDA... WraithX GPU Computing 16 2012-03-22 10:44
Multiple Installations. A_Pryme Software 35 2005-02-16 05:51

All times are UTC. The time now is 14:34.

Thu Nov 26 14:34:45 UTC 2020 up 77 days, 11:45, 4 users, load averages: 1.96, 1.49, 1.47

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.