mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > Software

Reply
 
Thread Tools
Old 2021-07-29, 22:38   #353
petrw1
1976 Toyota Corona years forever!
 
petrw1's Avatar
 
"Wayne"
Nov 2006
Saskatchewan, Canada

23×3×199 Posts
Default Immediate PC crash on starting Prime95

PS. Windows 10

There have been a couple power outages recently here.
When one of my 5 PCs came up it had lost worktodo.txt and local.txt.
I recreated them and restarted and the PC immediately shutdown (no blue screen...just boom)
I deleted the pminus1 workfiles (on a whim) and it proceeded to work.

The most recent outage; same symptoms. The above did not help.
I upgraded to the newest version here...same result.

I downgraded to the version on the public GIMPS website and now it runs.

I can't be sure it is version related or just a flaky PC.

PS: memtest ran error free.

Last fiddled with by petrw1 on 2021-07-30 at 06:00
petrw1 is online now   Reply With Quote
Old 2021-07-30, 08:38   #354
drkirkby
 
"David Kirkby"
Jan 2021
Althorne, Essex, UK

3×149 Posts
Default

I don't know the cause, but I submitted the results from a PRP test of M105212323 using mprime 30.6b4. The log does not indicate any errors, but the proof file was never generated.

Code:
[Worker #2 Jul 28 01:55] Generating proof for M105212323.  Proof power = 9, Hash length = 64
[Worker #2 Jul 28 02:00] M105212323 is not prime.  RES64: 2C388CF0B9F55BCD. Wh8: 5FC89719,92743653,00000000
[Comm thread Jul 28 02:00] Sending result to server:...
After the result was sent to there's noting more in the logs - no error message. There's nothing left in the working directory.

It could of course be a problem with my computer, but it is not overclocked, has mostly empty PCI slots and has ECC RAM.
drkirkby is offline   Reply With Quote
Old 2021-07-30, 09:06   #355
paulunderwood
 
paulunderwood's Avatar
 
Sep 2002
Database er0rr

22·3·17·19 Posts
Default

Quote:
Originally Posted by drkirkby View Post
I don't know the cause, but I submitted the results from a PRP test of M105212323 using mprime 30.6b4. The log does not indicate any errors, but the proof file was never generated.

Code:
[Worker #2 Jul 28 01:55] Generating proof for M105212323.  Proof power = 9, Hash length = 64
[Worker #2 Jul 28 02:00] M105212323 is not prime.  RES64: 2C388CF0B9F55BCD. Wh8: 5FC89719,92743653,00000000
[Comm thread Jul 28 02:00] Sending result to server:...
After the result was sent to there's noting more in the logs - no error message. There's nothing left in the working directory.

It could of course be a problem with my computer, but it is not overclocked, has mostly empty PCI slots and has ECC RAM.
When you say "working directory" what do you mean? Are you sure it is absolutely empty? Do you have the correct permissions for the "working directory"? Have you allowed some time to elapse for the upload and the reporting?

Last fiddled with by paulunderwood on 2021-07-30 at 09:06
paulunderwood is offline   Reply With Quote
Old 2021-07-30, 10:20   #356
drkirkby
 
"David Kirkby"
Jan 2021
Althorne, Essex, UK

3×149 Posts
Default

Quote:
Originally Posted by paulunderwood View Post
When you say "working directory" what do you mean? Are you sure it is absolutely empty? Do you have the correct permissions for the "working directory"? Have you allowed some time to elapse for the upload and the reporting?
I run all the GIMPS work from $HOME/gimps. Everything runs from there. The PRP test result was uploaded more than 52 hours ago, but I don't believe a proof has been uploaded.

An hour and fifteen minutes after M105212323 was known not to be prime, M105196813 was completed on the machine, working in the same directory. Looking at what happened with M105196813
Code:
[Worker #3 Jul 28 03:09] Generating proof for M105196813.  Proof power = 9, Hash length = 64
[Worker #3 Jul 28 03:15] M105196813 is not prime.  RES64: B36955DB15C715B8. Wh8: DD238B1C,24691551,00000000
[Comm thread Jul 28 03:26] MD5 of p105196813.proof is 638b15dc2ea53a58984ef43d9c5506dc
[Comm thread Jul 28 03:26] Proof file exponent is 105196813
[Comm thread Jul 28 03:26] Filesize of p105196813.proof is 131496078
 
[Comm thread Jul 28 03:43] Proof file p105196813.proof successfully uploaded
So for M105196813, the proof was successfully uploaded 28 minutes after the number was known not to be prime, with most of that 28 minutes being the upload - the proof had been generated 11 minutes after the number was known not to be prime. I think it is safe to say that no proof will be generated or uploaded for M105212323, since it should have happened long before now.

I don't know if its any coincidence, but I had run two P-1 tests on M105212323, as I was doing a bit of benchmarking. It will be interesting to see if M105211111 gets a proof uploaded when it completes, as I had run multiple P-1 tests on that too. M105211111 should complete by about 23:00 UTC today. My strategy for running the multiple P-1 tests on M105212323 was

  1. Start the mprime with the entry in worktodo.txt indicating 1 test would be saved.
  2. When I'd seen that the P-1 had finished, and the PRP started, I would kill mprime and delete any files on disk related to it.
  3. Edit worktodo.txt to put the number of saved tests to 2.
  4. Run mprime again, but this time let the PRP test finish after the P-1 had been run.
I find it a bit hard to believe that doing this would have stopped the proof being generated, but it is something I did which I don't normally do.

Last fiddled with by drkirkby on 2021-07-30 at 10:34
drkirkby is offline   Reply With Quote
Old 2021-07-30, 15:58   #357
petrw1
1976 Toyota Corona years forever!
 
petrw1's Avatar
 
"Wayne"
Nov 2006
Saskatchewan, Canada

23×3×199 Posts
Default

Quote:
Originally Posted by petrw1 View Post
PS. Windows 10

There have been a couple power outages recently here.
When one of my 5 PCs came up it had lost worktodo.txt and local.txt.
I recreated them and restarted and the PC immediately shutdown (no blue screen...just boom)
I deleted the pminus1 workfiles (on a whim) and it proceeded to work.

The most recent outage; same symptoms. The above did not help.
I upgraded to the newest version here...same result.

I downgraded to the version on the public GIMPS website and now it runs.

I can't be sure it is version related or just a flaky PC.

PS: memtest ran error free.
My first 2 results since are showing up under -Anonymous-.

This is my Comm window:
Code:
[Main thread Jul 29 16:15] Mersenne number primality test program version 30.3
[Main thread Jul 29 16:15] Optimizing for CPU architecture: Core i3/i5/i7, L2 cache size: 4x256 KB, L3 cache size: 6 MB
[Main thread Jul 29 16:15] Starting workers.
[Comm thread Jul 30 06:21] Sending result to server: UID: petrw1/Rocky, M35385751 completed P-1, B1=1500000, B2=45000000, E=6, Wh4: 91BFD03E
[Comm thread Jul 30 06:21] 
[Comm thread Jul 30 06:21] PrimeNet success code with additional info:
[Comm thread Jul 30 06:21] CPU credit is 7.0144 GHz-days.
[Comm thread Jul 30 06:21] Done communicating with server.
[Comm thread Jul 30 07:19] Sending result to server: UID: petrw1/Rocky, M35329157 completed P-1, B1=1500000, B2=45000000, E=6, Wh4: 9338DECD
[Comm thread Jul 30 07:19] 
[Comm thread Jul 30 07:19] PrimeNet success code with additional info:
[Comm thread Jul 30 07:19] CPU credit is 7.0144 GHz-days.
[Comm thread Jul 30 07:19] Done communicating with server.
These are the exponent status pages from here:
https://www.mersenne.org/report_expo...exp_hi=&full=1

Code:
35385751	No factors below 274
P-1	
B1=	1 500 000
B2=	45 000 000
Date	User	Type	Result
2021-07-30	-Anonymous-	NF-PM1	B1=1500000, B2=45000000, E=6
petrw1 is online now   Reply With Quote
Old 2021-07-31, 05:20   #358
petrw1
1976 Toyota Corona years forever!
 
petrw1's Avatar
 
"Wayne"
Nov 2006
Saskatchewan, Canada

477610 Posts
Default This part got fixed....

Something was awry in local or prime.txt I checked the Test... Primenet... box and both fields were there.
I did manual comm and checked again and userid was blank.
I filled it in again and re commed and its okay now.

I'll try again tomorrow to see if I can run 30.5 yet....not holding my breath.

Quote:
Originally Posted by petrw1 View Post
My first 2 results since are showing up under -Anonymous-.

This is my Comm window:
Code:
[Main thread Jul 29 16:15] Mersenne number primality test program version 30.3
[Main thread Jul 29 16:15] Optimizing for CPU architecture: Core i3/i5/i7, L2 cache size: 4x256 KB, L3 cache size: 6 MB
[Main thread Jul 29 16:15] Starting workers.
[Comm thread Jul 30 06:21] Sending result to server: UID: petrw1/Rocky, M35385751 completed P-1, B1=1500000, B2=45000000, E=6, Wh4: 91BFD03E
[Comm thread Jul 30 06:21] 
[Comm thread Jul 30 06:21] PrimeNet success code with additional info:
[Comm thread Jul 30 06:21] CPU credit is 7.0144 GHz-days.
[Comm thread Jul 30 06:21] Done communicating with server.
[Comm thread Jul 30 07:19] Sending result to server: UID: petrw1/Rocky, M35329157 completed P-1, B1=1500000, B2=45000000, E=6, Wh4: 9338DECD
[Comm thread Jul 30 07:19] 
[Comm thread Jul 30 07:19] PrimeNet success code with additional info:
[Comm thread Jul 30 07:19] CPU credit is 7.0144 GHz-days.
[Comm thread Jul 30 07:19] Done communicating with server.
These are the exponent status pages from here:
https://www.mersenne.org/report_expo...exp_hi=&full=1

Code:
35385751	No factors below 274
P-1	
B1=	1 500 000
B2=	45 000 000
Date	User	Type	Result
2021-07-30	-Anonymous-	NF-PM1	B1=1500000, B2=45000000, E=6
petrw1 is online now   Reply With Quote
Old 2021-07-31, 23:35   #359
petrw1
1976 Toyota Corona years forever!
 
petrw1's Avatar
 
"Wayne"
Nov 2006
Saskatchewan, Canada

477610 Posts
Default

Quote:
Originally Posted by petrw1 View Post
Something was awry in local or prime.txt I checked the Test... Primenet... box and both fields were there.
I did manual comm and checked again and userid was blank.
I filled it in again and re commed and its okay now.

I'll try again tomorrow to see if I can run 30.5 yet....not holding my breath.
After 2 days of it running version 30.3 just find I stopped Prime95 and tried a few different version of 30.4/30.5 ... all caused my PC to shutdown seconds after starting Prime95.

I reverted back to 30.3 ... guess what BOOM! PC Shutdown on start of Prime95; 3 tries; 3 shutdowns.

So it is software conflicts or faulty hardware....???

Running a Prime95 stress test now...after 2 hours all tests passed so far.

PS...is there some secret debug option in Prime95 what will spew out logs that can be analyzed after a failure such as this?
petrw1 is online now   Reply With Quote
Old 2021-08-01, 20:28   #360
petrw1
1976 Toyota Corona years forever!
 
petrw1's Avatar
 
"Wayne"
Nov 2006
Saskatchewan, Canada

23·3·199 Posts
Default

So the latest is that this PC has no issue running DC, ECM or Pfactor. But still shuts down as soon as it starts or continues a Pminus1.

For now I've converted my Pminus1 to comparable Pfactor and it seems to be content.
petrw1 is online now   Reply With Quote
Old 2021-08-01, 20:58   #361
Viliam Furik
 
Viliam Furik's Avatar
 
"Viliam Furík"
Jul 2018
Martin, Slovakia

683 Posts
Default

Quote:
Originally Posted by petrw1 View Post
So the latest is that this PC has no issue running DC, ECM or Pfactor. But still shuts down as soon as it starts or continues a Pminus1.

For now I've converted my Pminus1 to comparable Pfactor and it seems to be content.
It's possible there is some weird connection to my problems with Pminus1. (starting here at post #329)

Are your workers well-fed?

I didn't have problems with system shutdowns, only the Prime95 stopped. But still, there may be more to it.

What is your worker configuration, and CPU model?
Viliam Furik is online now   Reply With Quote
Old 2021-08-01, 21:23   #362
Prime95
P90 years forever!
 
Prime95's Avatar
 
Aug 2002
Yeehaw, FL

2·3·19·67 Posts
Default

Is it continuing from a savefile? If so, try renaming it.

If that fixes it, send me the savefile and worktodo.txt
Prime95 is offline   Reply With Quote
Old 2021-08-01, 22:49   #363
drkirkby
 
"David Kirkby"
Jan 2021
Althorne, Essex, UK

44710 Posts
Default

I assume it is an oversight, but in the source distribution of version 30.6b4, there's no assembly code for factor64 on linux. There's an object file (factor64.o), and assembly code for other platforms, but not 64-bit linux.
Code:
drkirkby@canary:/tmp/src$ find . -name 'factor64*'
./prime95/amd64/factor64.obj
./prime95/macosx64/factor64.o
./prime95/factor64.mac
./prime95/factor64.asm
./linux64/factor64.o
 drkirkby@canary:/tmp/src$
drkirkby is offline   Reply With Quote
Reply

Thread Tools


All times are UTC. The time now is 23:59.


Tue Oct 26 23:59:30 UTC 2021 up 95 days, 18:28, 1 user, load averages: 0.99, 1.19, 1.23

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.