mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > Software

Reply
 
Thread Tools
Old 2002-10-15, 17:56   #1
cmokruhl
 
Sep 2002

2·3 Posts
Default SkipTrialFactoring=1 doesn't work?

On my P4 machines, I want to skip the trial factoring before running the LL test since the LL test runs very fast. The undocumented feature "SkipTrialFactoring=1" seem to be just what the doctor ordered. However, I have that in the prime.ini files and it still does trial factoring. Am I doing something wrong?

Assuming this doesn't work, can I accomplish the same thing by changing the worktodo.ini files:

Test=13949693,65,0
to
Test=13949693,65,1

By the way, I'm using 22.10 on Linux.
cmokruhl is offline   Reply With Quote
Old 2002-10-15, 19:04   #2
dswanson
 
dswanson's Avatar
 
Aug 2002

23·52 Posts
Default

The "SkipTrialFactoring=1" feature bypasses the trial factorization up to n bits. In your example, "Test=13949693,65,0", trial factorization has already been completed to 65 bits so no further factorization is needed. Thus skipping the trial factoring does nothing.

It sounds like what you're really trying to skip is the P-1 factorization. Yes, changing the 0 to a 1 as you show accomplishes this.

However, from an overall GIMPS efficiency viewpoint, it'd be better if you allowed the P-1 factorization to run. George has picked the P-1 limits such that, on average, the CPU cycles expended per factor found using P-1 is less than the CPU cycles expended per LL test completed.

In other words, if you did 100 first-time LL tests with P-1 turned on, on average you'd find about 5 factors and complete 95 LL tests. If you did the same 100 first-time LL tests with P-1 turned off, you'd find 0 factors and complete 100 LL tests. But the total time spent doing those 100 LL tests would be longer than the time spend doing 100 P-1 factorizations plus 95 LL tests. So you're less efficient without P-1.
dswanson is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
GPU72 doesn't show all available DC work Mark Rose GPU to 72 2 2014-01-24 00:33
mfaktc doesn't work for me sonjohan GPU Computing 11 2012-01-27 15:10
autoreconf (from autoconf 2.68) doesn't work... Ralf Recker GMP-ECM 1 2011-07-25 14:14
Prime95 as a service in XP doesn't always work petrw1 PrimeNet 8 2008-01-27 01:59
Desktop doesn't work. clowns789 Software 7 2003-10-19 21:33

All times are UTC. The time now is 10:39.

Wed Oct 21 10:39:22 UTC 2020 up 41 days, 7:50, 0 users, load averages: 1.42, 1.42, 1.50

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.