mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > Software > Mlucas

Reply
 
Thread Tools
Old 2009-05-02, 23:48   #1
smoky
 
May 2009

7 Posts
Default Mlucas on HP-UX/PA-RISC setup question

Hello,

After just a day, this is becoming quite addictive!

I have an HP C3750 running HP-UX 11.11. I downloaded the corresponding Mlucas from the Mlucas Download page.

I then went to the Assignments page and requested an assignment. At this point, the instructions seem to diverge.

The assignment first line starts ECM=... (with eight comma separated integers) and is followed by the statement "Distribute the lines above to your computer's worktodo.txt files."

The Download page suggests "Copy the Test=... or DoubleCheck=... lines returned by the server into the worktodo.ini file ..."

Would someone have some additional details on how the ECM=... line can be transformed into a working worktodo.ini file, or what else I might need to do?

Thanks very much!

Smoky
smoky is offline   Reply With Quote
Old 2009-05-03, 22:23   #2
cheesehead
 
cheesehead's Avatar
 
"Richard B. Woods"
Aug 2002
Wisconsin USA

22×3×641 Posts
Default

Quote:
Originally Posted by smoky View Post
The assignment first line starts ECM=... (with eight comma separated integers) and is followed by the statement "Distribute the lines above to your computer's worktodo.txt files."

The Download page suggests "Copy the Test=... or DoubleCheck=... lines returned by the server into the worktodo.ini file ..."
V24 and earlier versions of prime95 (for MS Windows) used the filename worktodo.ini. V25 of prime95 uses the filename worktodo.txt for exactly the same purpose.

I do not know for sure whether mlucas had the same change. Not being an mlucas user or scholar, I can only guess that mlucas may have had the same change, for compatibility with the Windows prime95 (* sigh *). Which name ending had your setup been using up until now for its "worktodo" file? Continue using the same one.

The change from ".ini" to ".txt" in prime95 had to be made for technical reasons related to features of Microsoft's Vista OS that weren't in its earlier OSes. Not all GIMPS documentation has been updated, as you found out. Sorry about that.

Quote:
Would someone have some additional details on how the ECM=... line can be transformed into a working worktodo.ini file, or what else I might need to do?
Just copy the ECM= line(s) into whichever "worktodo" file (".txt" or ".ini") you have previously been using for all other assignments.

Last fiddled with by cheesehead on 2009-05-03 at 22:42
cheesehead is offline   Reply With Quote
Old 2009-05-03, 22:43   #3
mdettweiler
A Sunny Moo
 
mdettweiler's Avatar
 
Aug 2007
USA (GMT-5)

141518 Posts
Default

Quote:
Originally Posted by cheesehead View Post
Just copy the ECM= line(s) into whichever "worktodo" file (".txt" or ".ini") you have previously been using for all other assignments.
But, I thought Mlucas doesn't do ECM work, just LL?
mdettweiler is offline   Reply With Quote
Old 2009-05-03, 22:45   #4
cheesehead
 
cheesehead's Avatar
 
"Richard B. Woods"
Aug 2002
Wisconsin USA

22×3×641 Posts
Default

I don't know. smoky should find out whether it does or not fairly quickly.

Last fiddled with by cheesehead on 2009-05-03 at 22:48
cheesehead is offline   Reply With Quote
Old 2009-05-03, 23:44   #5
smoky
 
May 2009

716 Posts
Default

cheesehead, thank you for this assistance.

Quote:
Originally Posted by cheesehead View Post
Just copy the ECM= line(s) into whichever "worktodo" file (".txt" or ".ini") you have previously been using for all other assignments.
First, this Mlucas does use the .ini extension.

(This is a new setup on this host. I have not copied any files from prime95 on an OS X box where I have had no problems yet.)

I have copied the ECM=... line into worktodo.ini file. Starting Mlucas, I get -

worktodo.ini file found...checking next exponent in range...
ERROR: Unrecognized/unsupported option.


Any further assistance would be appreciated.
smoky is offline   Reply With Quote
Old 2009-05-04, 01:13   #6
Uncwilly
6809 > 6502
 
Uncwilly's Avatar
 
"""""""""""""""""""
Aug 2003
101×103 Posts

207008 Posts
Default

Looking at the online MLucas readme, it does not appear to handle ECM.

Go back to the Primenet site and get a first time (or better yet, double check) primality test. Abandon the ECM test.
Uncwilly is online now   Reply With Quote
Old 2009-05-04, 01:40   #7
smoky
 
May 2009

7 Posts
Default

Quote:
Originally Posted by Uncwilly View Post
Looking at the online MLucas readme, it does not appear to handle ECM.

Go back to the Primenet site and get a first time (or better yet, double check) primality test. Abandon the ECM test.
Thanks, I appreciate the assistance.

I have tried each of "Smallest available first-time tests" and "Double-check tests" from Primenet. In each case, starting Mlucas reports the same issue:

looking for worktodo.ini file...
worktodo.ini file found...checking next exponent in range...
p=390
ERROR: p must be at least 1024.


How do I set p > 1024 ?
smoky is offline   Reply With Quote
Old 2009-05-04, 14:36   #8
Uncwilly
6809 > 6502
 
Uncwilly's Avatar
 
"""""""""""""""""""
Aug 2003
101×103 Posts

26·33·5 Posts
Default

I am not sure. But, if you post the line in your worktodo, others should be able to help.
Uncwilly is online now   Reply With Quote
Old 2009-05-04, 21:45   #9
rgiltrap
 
rgiltrap's Avatar
 
Apr 2006
Down Under

89 Posts
Default

First things first have you done the self test?

You need to run "Mlucas -s m" and see if that works first.

If that is successful send us your worktodo.ini

Cheers, Rob.

Last fiddled with by rgiltrap on 2009-05-04 at 21:46
rgiltrap is offline   Reply With Quote
Old 2009-05-05, 00:18   #10
smoky
 
May 2009

710 Posts
Default

Quote:
Originally Posted by Uncwilly View Post
I am not sure. But, if you post the line in your worktodo, others should be able to help.

Quote:
Originally Posted by rgiltrap View Post
First things first have you done the self test?

You need to run "Mlucas -s m" and see if that works first.

If that is successful send us your worktodo.ini

Cheers, Rob.
Thanks for this assistance.

I ran "Mlucas -s m" - it had a exit code of 0 (success). But with no pre-existing worktodo.ini - it didn't create one. Is that what's expected? It did update mlucas.cfg.
smoky is offline   Reply With Quote
Old 2009-05-05, 00:41   #11
ewmayer
2ω=0
 
ewmayer's Avatar
 
Sep 2002
República de California

2·13·443 Posts
Default

Quote:
Originally Posted by smoky View Post
Thanks, I appreciate the assistance.

I have tried each of "Smallest available first-time tests" and "Double-check tests" from Primenet. In each case, starting Mlucas reports the same issue:

looking for worktodo.ini file...
worktodo.ini file found...checking next exponent in range...
p=390
ERROR: p must be at least 1024.


How do I set p > 1024 ?
Hi, smoky:

You need to obtain a prime exponent from the Primenet server (or from the manual assignments reservation thread on this forum) and paste that into the worktodo.ini file like so:

Test=[exponent]

Cheers,
-Ernst

Last fiddled with by ewmayer on 2009-05-05 at 00:41
ewmayer is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Quad CPU setup question tcharron Software 19 2013-02-14 20:38
GPU setup bcp19 GPU Computing 4 2011-10-15 14:09
Setup on Mac RussJones Information & Answers 4 2011-01-04 14:08
A Followup question on Mlucas... DeadSpam Mlucas 41 2007-03-14 18:40
A quick question regarding iterations in Mlucas... DeadSpam Mlucas 4 2007-03-05 14:06

All times are UTC. The time now is 16:33.

Wed Sep 30 16:33:16 UTC 2020 up 20 days, 13:44, 0 users, load averages: 1.91, 1.91, 1.85

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.