mersenneforum.org  

Go Back   mersenneforum.org > New To GIMPS? Start Here! > Information & Answers

Reply
 
Thread Tools
Old 2021-05-04, 13:09   #1
drkirkby
 
"David Kirkby"
Jan 2021
Althorne, Essex, UK

3·149 Posts
Default [Comm thread May 4 09:22] ERROR: Unable to open spool file.

I'm seeing this error running mprime on CentOS linux
Code:
 [Comm thread May 4 09:22] ERROR: Unable to open spool file.
I'm pretty sure I know what is the cause, but are not sure how to resolve. Yesterday I was configuring mprime to start as the computer boots, and started it as root once. Now it is starting properly as a normal user. I suspect mprime has created a file which is owned by root, to which a normal user can't read/write. Can anyone tell me what that file is? I'll then be able to sort it out.

Or if there's some other reason. I was messing around with a UPS yesterday, which again required some work as root. It is remotely possible that something changed by that is messing up mprime, but I suspect the program is due to running mprime as root for a short time

Last fiddled with by drkirkby on 2021-05-04 at 13:12
drkirkby is offline   Reply With Quote
Old 2021-05-04, 13:19   #2
paulunderwood
 
paulunderwood's Avatar
 
Sep 2002
Database er0rr

F1716 Posts
Default

Do ls -laR * in your mprime directory. If you see ownership to root run sudo chown -R dave:dave * in your mprime directory, assuming "dave" is your username.

Last fiddled with by paulunderwood on 2021-05-04 at 13:21
paulunderwood is offline   Reply With Quote
Old 2021-05-04, 13:34   #3
drkirkby
 
"David Kirkby"
Jan 2021
Althorne, Essex, UK

3·149 Posts
Default

Thank you, I think I found the problem before seeing your post. There was a .pid file owned by root. I deleted that. I hoping that it is the case, but I'm not 100% convinced, as I have another issue, but probably unrelated to this one.
drkirkby is offline   Reply With Quote
Old 2021-05-04, 13:38   #4
drkirkby
 
"David Kirkby"
Jan 2021
Althorne, Essex, UK

3·149 Posts
Default How can I recover an asignment lost from worktodo.txt ?

I've got this assignment

https://www.mersenne.org/report_expo...0826539&full=1

and I think it might be completed, but there's nothing in my worktodo.txt file. I have a .proof file. I expect that could be manually uploaded, but is there a way to put back the necessary line in worktodo.txt to get this completed in the usual way, without a manual upload?

Dave

Last fiddled with by drkirkby on 2021-05-04 at 13:39
drkirkby is offline   Reply With Quote
Old 2021-05-04, 13:42   #5
Uncwilly
6809 > 6502
 
Uncwilly's Avatar
 
"""""""""""""""""""
Aug 2003
101×103 Posts

1000710 Posts
Default

Quote:
Originally Posted by drkirkby View Post
This advice should work for this situation too.
https://www.mersenneforum.org/showpo...33&postcount=5
That is the easiest way to make sure that you have the line for the Worktodo.txt correct.
Uncwilly is online now   Reply With Quote
Old 2021-05-04, 13:44   #6
paulunderwood
 
paulunderwood's Avatar
 
Sep 2002
Database er0rr

3,863 Posts
Default

Quote:
Originally Posted by drkirkby View Post
I've got this assignment

https://www.mersenne.org/report_expo...0826539&full=1

and I think it might be completed, but there's nothing in my worktodo.txt file. I have a .proof file. I expect that could be manually uploaded, but is there a way to put back the necessary line in worktodo.txt to get this completed in the usual way, without a manual upload?

Dave
I think the worktodo.txt file if for work to do and not upload. You have to await comms with the server for the spool to be processed.

(Yes, you can go to primenet and get your assignments and copy and paste the relevant line, BUT that will start the proof process again???)

Last fiddled with by paulunderwood on 2021-05-04 at 14:41
paulunderwood is offline   Reply With Quote
Old 2021-05-04, 14:38   #7
drkirkby
 
"David Kirkby"
Jan 2021
Althorne, Essex, UK

3·149 Posts
Default

Quote:
Originally Posted by Uncwilly View Post
This advice should work for this situation too.
https://www.mersenneforum.org/showpo...33&postcount=5
That is the easiest way to make sure that you have the line for the Worktodo.txt correct.
I tried copying the line from worktodo.txt, but it restarts the assignment from 0.00%. It is now showing as 0% complete on the server, but I'm sure it has completed.
drkirkby is offline   Reply With Quote
Old 2021-05-04, 14:43   #8
drkirkby
 
"David Kirkby"
Jan 2021
Althorne, Essex, UK

3×149 Posts
Default

Quote:
Originally Posted by paulunderwood View Post
I think the worktodo.txt file if for work to do and not upload. You have to await comms with the sever for the spool to be processed.

(Yes, you can go to primenet and get your assignments and copy and paste the relevant line, BUT that will start the proof process again???)
It starts the whole process again - not just the proof! So it would take a full 2-days. I don't mind if its half-hour to generate the proof again, although I have it.



Dave
drkirkby is offline   Reply With Quote
Old 2021-05-04, 14:48   #9
paulunderwood
 
paulunderwood's Avatar
 
Sep 2002
Database er0rr

3,863 Posts
Default

Quote:
Originally Posted by drkirkby View Post
It starts the whole process again - not just the proof! So it would take a full 2-days. I don't mind if its half-hour to generate the proof again, although I have it.
Sure. My advice is stop mprime and exit. Remove the line form worktodo.txt. Start mprime. Wait for a communication between the server and the local spool file OR do a manual upload of the proof this time.

Last fiddled with by paulunderwood on 2021-05-04 at 14:51
paulunderwood is offline   Reply With Quote
Old 2021-05-04, 14:54   #10
drkirkby
 
"David Kirkby"
Jan 2021
Althorne, Essex, UK

6778 Posts
Default

Em,

I thought I had backed up the files before running mprime again with the exponent, but looking at the dates, everything is in the last hour or so, except the proof file, which is 12 hours old.

Maybe I will have to repeat it all again, unless the information in the proof file can somehow be uploaded.



Dave

Last fiddled with by drkirkby on 2021-05-04 at 14:55
drkirkby is offline   Reply With Quote
Old 2021-05-04, 15:06   #11
paulunderwood
 
paulunderwood's Avatar
 
Sep 2002
Database er0rr

3,863 Posts
Default

Quote:
Originally Posted by drkirkby View Post
Em,

I thought I had backed up the files before running mprime again with the exponent, but looking at the dates, everything is in the last hour or so, except the proof file, which is 12 hours old.

Maybe I will have to repeat it all again, unless the information in the proof file can somehow be uploaded.
Please see my previous post. I defer to another to tell how to do a manual upload of the proof file. Firstly you will have to copy and paste the json information for the exponent from the results.txt file to mersenne.org-->Manual Testing-->results (and submit). Then run a script to upload the actual proof file.

Last fiddled with by paulunderwood on 2021-05-04 at 15:10
paulunderwood is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
P95 - Windows 7 - Unable to open log file ThomRuley PrimeNet 2 2017-01-15 20:43
Unable to open SPOOL file petrw1 PrimeNet 4 2015-11-24 16:06
"ERROR: Unable to open spool file." no1hasdisid Software 1 2013-05-06 05:24
Unable to open log file Unregistered Information & Answers 2 2011-06-07 16:15
Cannot open spool and log file lidocorc Software 4 2008-12-09 05:27

All times are UTC. The time now is 03:25.


Thu Oct 21 03:25:36 UTC 2021 up 89 days, 21:54, 1 user, load averages: 1.52, 1.38, 1.21

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.