mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > Hardware > GPU Computing

Reply
 
Thread Tools
Old 2014-10-12, 16:05   #1
EdH
 
EdH's Avatar
 
"Ed Hall"
Dec 2009
Adirondack Mtns

47×79 Posts
Default Trouble With CUDA 6.5 on Fedora 20 (5.5 worked in F17/19)

I had CUDA 5.5 working fine under an earlier Fedora 64-bit system (F17-F19) on this machine with an old GT216 [GeForce GT 220] (rev a2). However, when I tried to upgrade to 19 I had had troubles with the upgrade and that system (some kind of hybrid 17/19, now) is dying due to diminishing root space. So, I made a new install of Fedora 20 64-bit and went through all the steps for installing CUDA 6.5. All seemed to work fine and tests seemed OK, all the way to "making" the samples, when after a long set of successes, I get a failure:
Code:
/usr/local/cuda-6.5/bin/nvcc -ccbin g++   -m64       -gencode arch=compute_11,code=compute_11 -o cudaDecodeGL FrameQueue.o ImageGL.o VideoDecoder.o VideoParser.o VideoSource.o cudaModuleMgr.o cudaProcessFrame.o videoDecodeGL.o  -L../../common/lib/linux/x86_64 -L/usr/lib64/nvidia -lGL -lGLU -lX11 -lXi -lXmu -lglut -lGLEW -lcuda -lcudart -lnvcuvid
nvcc warning : The 'compute_11', 'compute_12', 'compute_13', 'sm_11', 'sm_12', and 'sm_13' architectures are deprecated, and may be removed in a future release.
/usr/bin/ld: cannot find -lnvcuvid
collect2: error: ld returned 1 exit status
make[1]: *** [cudaDecodeGL] Error 1
make[1]: Leaving directory `/home/user/Programming/cuda/NVIDIA_CUDA-6.5_Samples/3_Imaging/cudaDecodeGL'
make: *** [3_Imaging/cudaDecodeGL/Makefile.ph_build] Error 2
Note also that it seemed that every step ended with the same statement, shown above:
Code:
"...architectures are deprecated, and may be removed in a future release."
deviceQuery, which ran on my previous system was compiled, but it shows the following failure, if I try it now:
Code:
$ ./deviceQuery
./deviceQuery Starting...

 CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 35
-> CUDA driver version is insufficient for CUDA runtime version
Result = FAIL
$
I can't seem to find a way to upgrade the nvidia driver any further than the version 340.29 that is currently installed.

Thanks for any assistance...
EdH is offline   Reply With Quote
Old 2014-10-12, 20:33   #2
EdH
 
EdH's Avatar
 
"Ed Hall"
Dec 2009
Adirondack Mtns

47×79 Posts
Default Followup

Total error in this message - no progress to report

Last fiddled with by EdH on 2014-10-12 at 20:45 Reason: Apparently, I don't know what I'm doing, as many probably already thought
EdH is offline   Reply With Quote
Old 2014-10-12, 21:13   #3
Xyzzy
 
Xyzzy's Avatar
 
"Mike"
Aug 2002

24×509 Posts
Default

Quote:
Originally Posted by EdH View Post
Code:
"...architectures are deprecated, and may be removed in a future release."
We compiled the samples last night (successfully) and we had that same message as each sample was compiled. Sorry we can't offer any more help!
Xyzzy is offline   Reply With Quote
Old 2014-10-13, 00:09   #4
EdH
 
EdH's Avatar
 
"Ed Hall"
Dec 2009
Adirondack Mtns

47×79 Posts
Default

Quote:
Originally Posted by Xyzzy View Post
We compiled the samples last night (successfully) and we had that same message as each sample was compiled. Sorry we can't offer any more help!
I did notice your install. Thank you for responding. Disappointingly, the earlier version was running fine. As a side note, I also have an Ubuntu 14.04 laptop with a capable card on which I installed CUDA via the repositories. I can't even figure out where things are on it. I'm kind of holding off on it, trying to get the desktop settled before delving into the laptop...
EdH is offline   Reply With Quote
Old 2014-10-13, 02:56   #5
EdH
 
EdH's Avatar
 
"Ed Hall"
Dec 2009
Adirondack Mtns

47·79 Posts
Default Last Followup

Three times does indeed seem charmed. After a third total reinstall, all seems to be working as described in the documentation...

Now, can I get the Ubuntu version running?...
EdH is offline   Reply With Quote
Old 2014-10-13, 19:16   #6
EdH
 
EdH's Avatar
 
"Ed Hall"
Dec 2009
Adirondack Mtns

47·79 Posts
Default Ubuntu 14.04 Also Resolved

In case someone stumbles onto this thread and cares:

I have finally gotten CUDA 6.5 running on the aforementioned Ubuntu 14.04 laptop. In order to accomplish this, I had to install synaptic because apt-get kept coming up with broken items having to do with 6.5 and 6.5-14. Anyway, I ran synaptic and uninstalled all cuda items. Then I closed synaptic and ran all the steps in the Getting Started Guide, except the initial removal of any previous versions. This time everything went perfectly "by the book."

So now all is fine.
EdH is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Might someone recall which revision of msieve still worked with CUDA 6.5 and arch 1.2? EdH Msieve 4 2016-11-26 20:44
Sieving Drive all base 2/4 k's worked by CRUS gd_barnes Conjectures 'R Us 143 2014-10-21 23:55
How to tell what's being worked on? Rodrigo LMH > 100M 50 2010-08-23 22:03
How RSA certificates worked in Hotmail koders333 Science & Technology 1 2005-10-02 04:34
Fedora tha Software 2 2004-01-13 23:12

All times are UTC. The time now is 13:39.

Fri May 7 13:39:45 UTC 2021 up 29 days, 8:20, 0 users, load averages: 2.53, 2.64, 2.53

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.