mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > Software

Reply
 
Thread Tools
Old 2015-08-12, 16:55   #1
Sulamandora
 
Aug 2015

3 Posts
Default Windows 10 Issues

Been flustered since moving to Windows 10... Everytime I try and load Prime 95 I get this error:

Quote:
[Main thread Aug 11 23:37] Mersenne number primality test program version 28.5
[Main thread Aug 11 23:37] Optimizing for CPU architecture: Core i3/i5/i7, L2 cache size: 256 KB, L3 cache size: 6 MB
[Comm thread Aug 11 23:39] ERROR: Unable to open spool file.
[Comm thread Aug 11 23:39] Unable to open log file.
[Comm thread Aug 11 23:39] ERROR: Unable to open spool file.
[Comm thread Aug 11 23:39] Unable to open log file.
[Comm thread Aug 11 23:39] ERROR: Unable to open spool file.
[Comm thread Aug 11 23:39] Unable to open log file.
[Comm thread Aug 11 23:39] ERROR: Unable to open spool file.
[Comm thread Aug 11 23:39] Unable to open log file.
[Comm thread Aug 11 23:40] ERROR: Unable to open spool file.
[Comm thread Aug 11 23:40] Unable to open log file.
[Comm thread Aug 11 23:40] ERROR: Unable to open spool file.
[Comm thread Aug 11 23:40] Unable to open log file.
[Comm thread Aug 11 23:40] ERROR: Unable to open spool file.
[Comm thread Aug 11 23:40] Unable to open log file.
[Comm thread Aug 11 23:40] ERROR: Unable to open spool file.
[Comm thread Aug 11 23:40] Unable to open log file.
[Main thread Aug 11 23:40] Starting workers.
[Comm thread Aug 11 23:47] ERROR: Unable to open spool file.
[Comm thread Aug 11 23:47] Unable to open log file.
[Comm thread Aug 11 23:47] ERROR: Unable to open spool file.
[Comm thread Aug 11 23:47] Unable to open log file.
[Comm thread Aug 11 23:47] ERROR: Unable to open spool file.
[Comm thread Aug 11 23:47] Unable to open log file.
[Main thread Aug 11 23:51] Stopping all worker threads.
[Main thread Aug 11 23:51] Starting worker.
[Main thread Aug 11 23:51] Error creating worktodo.txt file
[Comm thread Aug 11 23:51] Error opening results file to output this message:
[Comm thread Aug 11 23:51] Unable to open log file.
[Comm thread Aug 11 23:51] Error creating worktodo.txt file
[Comm thread Aug 11 23:51] Unable to open log file.
[Main thread Aug 11 23:51] Starting workers.
[Main thread Aug 11 23:52] Error creating worktodo.txt file
[Comm thread Aug 11 23:52] Error opening results file to output this message:
[Comm thread Aug 11 23:52] Unable to open log file.
[Comm thread Aug 11 23:52] Error creating worktodo.txt file
[Comm thread Aug 11 23:52] Unable to open log file.
Anyone see something blaringly obvious that I've missed? Thanks!
Sulamandora is offline   Reply With Quote
Old 2015-08-12, 18:02   #2
paulunderwood
 
paulunderwood's Avatar
 
Sep 2002
Database er0rr

2·7·281 Posts
Default

It is probably due to file permissions Did you transfer your data via a CD?
paulunderwood is offline   Reply With Quote
Old 2015-08-12, 19:11   #3
Sulamandora
 
Aug 2015

3 Posts
Default

Quote:
Originally Posted by paulunderwood View Post
It is probably due to file permissions Did you transfer your data via a CD?
No I upgraded through the interwebs.
Sulamandora is offline   Reply With Quote
Old 2015-08-12, 20:11   #4
paulunderwood
 
paulunderwood's Avatar
 
Sep 2002
Database er0rr

393410 Posts
Default

Quote:
Originally Posted by Sulamandora View Post
No I upgraded through the interwebs.
I have never done that, but the permissions on the folder and/or the files therein most likely have the wrong permissions. To set them you will have to right click when in "explorer" and tick some options. Prime95 already seems executable -- the others need a "write" permission.
paulunderwood is offline   Reply With Quote
Old 2015-08-12, 20:24   #5
Madpoo
Serpentine Vermin Jar
 
Madpoo's Avatar
 
Jul 2014

31·107 Posts
Default

Quote:
Originally Posted by Sulamandora View Post
Been flustered since moving to Windows 10... Everytime I try and load Prime 95 I get this error:


Anyone see something blaringly obvious that I've missed? Thanks!
I was just having some fun on a couple of my servers. I setup a new admin user (not the default admin) to use to login and run P95... This is on a Server 2012 R2 install, but probably similar.

Anyway, I forgot there are default policies that restrict certain things for admins that aren't the default admins (part of the whole messy UAC stuff). The directory I was running Prime95 from was relying on "admin" permissions since I was lazy and didn't configure them explicitly... I found out when it tried to write intermediate files or the results file/modify the worktodo... none of that worked.

So anyway, check all of that out. If in doubt, you could just run Prime95 with "run as administrator" and see if it makes any difference. If so, you can check the file permissions where you have it installed and make sure your specific user has full access (or just keep running it as administrator and call it good)
Madpoo is offline   Reply With Quote
Old 2015-08-13, 06:47   #6
Sulamandora
 
Aug 2015

3 Posts
Default

Quote:
Originally Posted by Madpoo View Post
I was just having some fun on a couple of my servers. I setup a new admin user (not the default admin) to use to login and run P95... This is on a Server 2012 R2 install, but probably similar.

Anyway, I forgot there are default policies that restrict certain things for admins that aren't the default admins (part of the whole messy UAC stuff). The directory I was running Prime95 from was relying on "admin" permissions since I was lazy and didn't configure them explicitly... I found out when it tried to write intermediate files or the results file/modify the worktodo... none of that worked.

So anyway, check all of that out. If in doubt, you could just run Prime95 with "run as administrator" and see if it makes any difference. If so, you can check the file permissions where you have it installed and make sure your specific user has full access (or just keep running it as administrator and call it good)
Thanks! So it's definitely the permissions. I ran it as administrator and it works. I'll go in and manually set permissions later. Thank to both of you for the help!
Sulamandora is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
ECM RAM issues yoyo GMP-ECM 7 2018-04-28 05:51
New GPU; new issues... chalsall GPU Computing 18 2013-06-12 19:28
AffinityScramble issues willmore Software 9 2009-10-26 20:47
memory issues? jcjuice Hardware 7 2006-01-11 20:41
Speed issues... Xyzzy Lounge 42 2003-10-08 01:27

All times are UTC. The time now is 15:52.


Tue Nov 30 15:52:50 UTC 2021 up 130 days, 10:21, 0 users, load averages: 1.38, 1.43, 1.44

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.