mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > Hardware > GPU Computing

Reply
 
Thread Tools
Old 2012-12-05, 18:14   #1
Rodrigo
 
Rodrigo's Avatar
 
Jun 2010
Pennsylvania

2·467 Posts
Default How to tell mfakto to use IGP?

Almost ready to start contributing my new system to GIMPS, but there's one issue I haven't been able to resolve yet: how to make use of the integrated graphics, in addition to the add-in card, for TF. (For the background, see this thread.)

The Intel graphics is enabled in UEFI. The driver is up to date. Windows 7 Device Manager shows that it's working properly as "device 2". Yet mfakto doesn't seem to be recognizing the IGP: if I type in "mfakto-x64 -d 0", it uses the HD 7770. If I type in "mfakto-x64 -d 1", again it goes to the 7770. But if I type in "mfakto-x64 -d 2", it tells me that only 1 device was found and that I "Cannot use device 2 <bad parameter to option -d>."

Any help/hints are welcome!

Rodrigo
Rodrigo is offline   Reply With Quote
Old 2012-12-06, 02:21   #2
kracker
 
kracker's Avatar
 
"Mr. Meeseeks"
Jan 2012
California, USA

87916 Posts
Default

Not sure if intel HD 4000 has opencl 1.2... but just curious, is it shown in GPU-Z? (both)
kracker is offline   Reply With Quote
Old 2012-12-06, 03:01   #3
swl551
 
swl551's Avatar
 
Aug 2012
New Hampshire

23×101 Posts
Default

When I removed my AMD card one time for service I kicked of mfakto on the IGP (i5-2500k) and the throughput was horrid. Less than 10M/S.

In other words, there won't be any ROI for the power consumed by the IGP.

Look at passmark.com video benchmarks to get an idea of just how SLOW IGP is compared to something like an AMD 7870
swl551 is offline   Reply With Quote
Old 2012-12-06, 04:44   #4
Rodrigo
 
Rodrigo's Avatar
 
Jun 2010
Pennsylvania

2×467 Posts
Default

Quote:
Originally Posted by kracker View Post
Not sure if intel HD 4000 has opencl 1.2... but just curious, is it shown in GPU-Z? (both)
I just looked and the Intel GPU does show up. Let me know if you need any spec info from GPU-Z.

Huh, the check boxes at the bottom have check marks for OpenCL and Direct Compute 5.0, but they're unchecked for the Intel graphics. FWIW

Rodrigo
Rodrigo is offline   Reply With Quote
Old 2012-12-06, 04:46   #5
kracker
 
kracker's Avatar
 
"Mr. Meeseeks"
Jan 2012
California, USA

216910 Posts
Default

Quote:
Originally Posted by swl551 View Post
When I removed my AMD card one time for service I kicked of mfakto on the IGP (i5-2500k) and the throughput was horrid. Less than 10M/S.

In other words, there won't be any ROI for the power consumed by the IGP.

Look at passmark.com video benchmarks to get an idea of just how SLOW IGP is compared to something like an AMD 7870
I have a AMD iGPU, (integrated) it has about ~55M/s on it.

EDIT: I think it was using cpu(fallback), not gpu, don't think sandy bridge(gpu) can run mfakto..

Last fiddled with by kracker on 2012-12-06 at 04:47
kracker is offline   Reply With Quote
Old 2012-12-06, 04:46   #6
Rodrigo
 
Rodrigo's Avatar
 
Jun 2010
Pennsylvania

2·467 Posts
Default

Quote:
Originally Posted by swl551 View Post
When I removed my AMD card one time for service I kicked of mfakto on the IGP (i5-2500k) and the throughput was horrid. Less than 10M/S.

In other words, there won't be any ROI for the power consumed by the IGP.

Look at passmark.com video benchmarks to get an idea of just how SLOW IGP is compared to something like an AMD 7870
Will do, thanks.

Would the throughput for GIMPS purposes be worse than (say) a CPU, or still better?

Rodrigo
Rodrigo is offline   Reply With Quote
Old 2012-12-06, 05:56   #7
Rodrigo
 
Rodrigo's Avatar
 
Jun 2010
Pennsylvania

2·467 Posts
Default

Hmm, didn't there use to be an "edit" option to amend your post instead of having to write a separate one?

Anyway, I checked the Passmark.com page for video cards. The Intel HD 400 ranks #338 of 1876 listed. Not that far below the GeForce GT 430, which I use for CUDALucas on another machine.

Rodrigo

P.S. One more thing. Accodring to the OpenCL entry in Wikipedia, the Intel HD 4000 should be able to do OpenCL 1.2.

Last fiddled with by Rodrigo on 2012-12-06 at 06:07 Reason: well there, but my previous posts don't have the edit option
Rodrigo is offline   Reply With Quote
Old 2012-12-06, 12:39   #8
swl551
 
swl551's Avatar
 
Aug 2012
New Hampshire

23×101 Posts
Default

Try removing your add on card and see if mfakto finds the IGP. If so you can at least determine how well it might run. Like I said for me it ran poorly, but that was Sandy Bridge.

On a 7770 you'd be running 2 or 3 instances of mfakto anyway and adding a third, being the IGP, may slow down your other instances if CPU bottleneck occurs.

I'll try to run both on my PC and see if I can get it to work.

Last fiddled with by swl551 on 2012-12-06 at 12:46
swl551 is offline   Reply With Quote
Old 2012-12-06, 14:54   #9
bcp19
 
bcp19's Avatar
 
Oct 2011

7·97 Posts
Default

Quote:
Originally Posted by Rodrigo View Post
Hmm, didn't there use to be an "edit" option to amend your post instead of having to write a separate one?

Anyway, I checked the Passmark.com page for video cards. The Intel HD 400 ranks #338 of 1876 listed. Not that far below the GeForce GT 430, which I use for CUDALucas on another machine.

Rodrigo

P.S. One more thing. Accodring to the OpenCL entry in Wikipedia, the Intel HD 4000 should be able to do OpenCL 1.2.
You can only edit a message for something like the first hour after it was posted.
bcp19 is offline   Reply With Quote
Old 2012-12-06, 15:19   #10
Rodrigo
 
Rodrigo's Avatar
 
Jun 2010
Pennsylvania

2×467 Posts
Default

Quote:
Originally Posted by bcp19 View Post
You can only edit a message for something like the first hour after it was posted.
Ah, that explains it -- thanks.

Rodrigo
Rodrigo is offline   Reply With Quote
Old 2012-12-06, 15:22   #11
Rodrigo
 
Rodrigo's Avatar
 
Jun 2010
Pennsylvania

16468 Posts
Default

Quote:
Originally Posted by swl551 View Post
Try removing your add on card and see if mfakto finds the IGP. If so you can at least determine how well it might run. Like I said for me it ran poorly, but that was Sandy Bridge.

On a 7770 you'd be running 2 or 3 instances of mfakto anyway and adding a third, being the IGP, may slow down your other instances if CPU bottleneck occurs.

I'll try to run both on my PC and see if I can get it to work.
Let me know how you make out with this test. The PC with the 7770 is brand-new and IIRC it'll void the warranty if I open the case...

Rodrigo
Rodrigo is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
mfakto error while running jacob1235 GPU Computing 1 2018-02-03 19:03
TF with mfakto win 0.14 Yoshi24517 GPU Computing 5 2017-04-01 18:01
Mfakto cl_barret15_73_gs_2 - Not A Factor? airsquirrels GPU to 72 23 2016-01-07 06:26
mprime and mfakto on Playstation 4 0PolarBearsHere Hardware 2 2015-12-15 17:29
mfakto 0.13 with Windows 8.1 bplenhart GPU Computing 16 2013-12-05 01:24

All times are UTC. The time now is 14:59.


Tue Nov 30 14:59:18 UTC 2021 up 130 days, 9:28, 0 users, load averages: 1.49, 1.48, 1.45

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.