mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > PrimeNet > MISFIT

Reply
 
Thread Tools
Old 2016-07-29, 22:13   #12
Mark Rose
 
Mark Rose's Avatar
 
"/X\(‘-‘)/X\"
Jan 2013
Ͳօɾօղէօ

22×5×139 Posts
Default

Quote:
Originally Posted by petrw1 View Post
The vote against this theory...is I have 2 PCs with GPUs both fetching work from GPU72 via MisFit. The other works.

The only difference is that the one that stopped fetching successfully (on the 27th) is Win-7 the other has been upgraded to Win-10 a few months ago. Do they get/check certs differently?
You probably need to update the root certificates. It might be in Windows Update or whatever they call it these days?
Mark Rose is offline   Reply With Quote
Old 2016-07-29, 22:17   #13
chalsall
If I May
 
chalsall's Avatar
 
"Chris Halsall"
Sep 2002
Barbados

8,861 Posts
Default

Quote:
Originally Posted by petrw1 View Post
The only difference is that the one that stopped fetching successfully (on the 27th) is Win-7 the other has been upgraded to Win-10 a few months ago. Do they get/check certs differently?
Actually, I made a temporal mistake. The certificate for GPU72.com expired on the 27th at about 1200 UTC, and I applied a new cert about two hours later (from a different CA for expediency).

I'm not quite sure how MISFIT handles SSL. It would be very interesting if different versions of the operating system had an impact on the software.
chalsall is offline   Reply With Quote
Old 2016-07-30, 08:33   #14
kladner
 
kladner's Avatar
 
"Kieren, ktony"
Jul 2011

2·3·37·43 Posts
Default

Quote:
Originally Posted by 0PolarBearsHere View Post
Just to let you all know. I've worked out why it wasn't working.
I was trying to run the bat file using the cmd entry, rather than as an argument for cmd.exe
working config
-----
CMD:
Code:
C:\Windows\System32\cmd.exe
ARGS:
Code:
/c <path to bat file>
Have you tried using the Start command in a batch file?
Code:
start [/high /min] mfaktc.exe -d 0
The bracketed arguments are optional. The above assumes one has already navigated to the mfaktc directory.
kladner is online now   Reply With Quote
Old 2016-07-30, 12:15   #15
0PolarBearsHere
 
0PolarBearsHere's Avatar
 
Oct 2015

2×7×19 Posts
Default

Quote:
Originally Posted by kladner View Post
Have you tried using the Start command in a batch file?
Code:
start [/high /min] mfaktc.exe -d 0
The bracketed arguments are optional. The above assumes one has already navigated to the mfaktc directory.
Nah, mine was a different issue. mfaktc was already running and I couldn't get the work-fetch bit to run a bat file for me. The quoted method was how I got it calling the bat file.
0PolarBearsHere is offline   Reply With Quote
Old 2016-08-01, 03:50   #16
petrw1
1976 Toyota Corona years forever!
 
petrw1's Avatar
 
"Wayne"
Nov 2006
Saskatchewan, Canada

2·5·7·61 Posts
Default

Quote:
Originally Posted by chalsall View Post
Actually, I made a temporal mistake. The certificate for GPU72.com expired on the 27th at about 1200 UTC, and I applied a new cert about two hours later (from a different CA for expediency).

I'm not quite sure how MISFIT handles SSL. It would be very interesting if different versions of the operating system had an impact on the software.
Fetch still getting the same error....any one have any more ideas
petrw1 is offline   Reply With Quote
Old 2016-08-01, 05:04   #17
chalsall
If I May
 
chalsall's Avatar
 
"Chris Halsall"
Sep 2002
Barbados

886110 Posts
Default

Quote:
Originally Posted by petrw1 View Post
Fetch still getting the same error....any one have any more ideas
Hmmm... confused.

If you could provide an approximate time of the failed fetch attempt (UTC +/- 2 seconds please), that would help a lot. Also, if you could provide exactly what the client reports, that might also help.

I have been seeing successful fetch attempts from you, so I'm not quite sure what is going on here.
chalsall is offline   Reply With Quote
Old 2016-08-01, 21:24   #18
swl551
 
swl551's Avatar
 
Aug 2012
New Hampshire

2×401 Posts
Question

The issue has to be with the specific windows instance otherwise others would have cited same issue.

Did your win7 PC somehow restrict what version of TLS is required for the GPU72 site?


Firewall blocking? AV software being smart?


I no longer have a win7 PC in my stable so I can't test directly.

Also can you post your config file. It should l00ok like this

StagingFile:MISFITWorkToDo.txt
ReloadWhenBelow:15
FetchCount:2
Low:0
High:100000000
Pledge:73

#OPTION
#WhatMakesSense = 0
#LowestTFLevel = 1
#HighestTFLevel = 2
#LowestExponent = 3
#OldestExponent = 4
Option:0

ReplaceNAwithDate:true

URL:https://www.gpu72.com/account/getassignments/lltf/
UserID:XXXXX
UserPWD:YYYY

Last fiddled with by swl551 on 2016-08-01 at 21:36
swl551 is offline   Reply With Quote
Old 2016-08-01, 22:19   #19
chalsall
If I May
 
chalsall's Avatar
 
"Chris Halsall"
Sep 2002
Barbados

212358 Posts
Default

Quote:
Originally Posted by swl551 View Post
The issue has to be with the specific windows instance otherwise others would have cited same issue.
Agreed. And I'm seeing this in the SSL logs:
Code:
a.b.c.158 - UN [26/Jul/2016:17:28:20 -0400] "POST /account/getassignments/lltf/ HTTP/1.1" 200 19595 "-" "MISFIT-TF-FETCHER"
a.b.c.158 - UN [26/Jul/2016:18:59:57 -0400] "POST /account/getassignments/lltf/ HTTP/1.1" 200 22077 "-" "MISFIT-TF-FETCHER"
a.b.c.158 - UN [27/Jul/2016:05:57:00 -0400] "POST /account/getassignments/lltf/ HTTP/1.1" 200 19707 "-" "MISFIT-TF-FETCHER"
a.b.c.158 - UN [29/Jul/2016:17:34:05 -0400] "POST /account/getassignments/lltf/ HTTP/1.1" 200 19353 "-" "MISFIT-TF-FETCHER"
a.b.c.158 - UN [29/Jul/2016:17:49:45 -0400] "POST /account/getassignments/lltf/ HTTP/1.1" 200 19353 "-" "MISFIT-TF-FETCHER"
"a.b.c.158" is Wayne's IP. "UN" is Wayne's GPU72 username. So at least one of his MISFIT instances isn't having issue with the new SSL cert. Further, there are no messages in the error logs associated with this IP.

Wayne, it would really help if you gave Scott the information he requested, along with any error messages the client reports. I can't see anything on my end which even begins to explain what you are reporting.
chalsall is offline   Reply With Quote
Old 2016-08-01, 23:08   #20
Mark Rose
 
Mark Rose's Avatar
 
"/X\(‘-‘)/X\"
Jan 2013
Ͳօɾօղէօ

22·5·139 Posts
Default

Quote:
Originally Posted by petrw1 View Post
Fetch still getting the same error....any one have any more ideas
Can you visit https://www.gpu72.com/ on that machine in IE without issue?
Mark Rose is offline   Reply With Quote
Old 2016-08-03, 01:22   #21
chalsall
If I May
 
chalsall's Avatar
 
"Chris Halsall"
Sep 2002
Barbados

8,861 Posts
Default

Quote:
Originally Posted by petrw1 View Post
Fetch still getting the same error....any one have any more ideas
Wayne... You opened a trouble ticket.

Is this still open?
chalsall is offline   Reply With Quote
Old 2016-08-03, 02:42   #22
1997rj7
 
1997rj7's Avatar
 
Sep 2003

3×5×23 Posts
Default

I am having the same problem fetching work via Misfit from GPUto72. This is a Windows 7 machine that has been working fine for the last 20 months.

Fetching from GIMPS works fine.
1997rj7 is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pari gp Command divisors() ? Godzilla PARI/GP 30 2018-03-03 18:15
Automatic submit results + fetch assignments for mfaktc? DuskFalls GPU Computing 5 2017-12-02 00:34
unable to fetch assignments dragonbud20 MISFIT 2 2016-10-18 08:01
Automatic fetch of Trial Factoring work for GPU mfakt* LaurV GPU to 72 58 2014-10-07 07:12
Need an extra brain? Try an external one! ewmayer Lounge 3 2009-02-04 20:51

All times are UTC. The time now is 20:56.

Thu Apr 9 20:56:05 UTC 2020 up 15 days, 18:29, 1 user, load averages: 1.67, 1.53, 1.59

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.