mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > PrimeNet > GPU to 72

Reply
 
Thread Tools
Old 2012-08-13, 05:52   #23
Dubslow
Basketry That Evening!
 
Dubslow's Avatar
 
"Bunslow the Bold"
Jun 2011
40<A<43 -89<O<-88

160658 Posts
Default

Quote:
Originally Posted by kladner View Post
Is it possible to have P95 launch without attempting to start processing?
Unfortunately, no. While such a command line option exists on *nix, it does not for Windows. (I just checked the source to verify this. Windows accepts the -a (ini file names), -t (torture test) and -w (working dir) options.) You might ask George to include such a switch in the next build. (Edit: While I was sourcing, an alternate solution was posted )

Last fiddled with by Dubslow on 2012-08-13 at 05:53
Dubslow is offline   Reply With Quote
Old 2012-08-13, 13:29   #24
chalsall
If I May
 
chalsall's Avatar
 
"Chris Halsall"
Sep 2002
Barbados

23·1,103 Posts
Default

Quote:
Originally Posted by flashjh View Post
I checked on a few of my P-1 submissions on James' site, the E value still wasn't there. I submitted one manually and then it showed up... don't know if the E value is working?
It should be -- it's being sent. But I just check several submissions over the night, and they didn't have the E value. I've instructed Spidy to re-submit to James all results which had an E value.

James, any ideas?

Jerry, please let us know if you see this again. And rather than submitting the result manually, please just let us know what the exponent(s) involved are.
chalsall is offline   Reply With Quote
Old 2012-08-13, 14:48   #25
kladner
 
kladner's Avatar
 
"Kieren, ktony"
Jul 2011

100101001000112 Posts
Default

Quote:
Originally Posted by sdbardwick View Post
PauseWhileRunning=* along with PauseCheckInterval=1 will only allow 1 second of processing (maximum).
Thanks sdbardwick and Dubslow for giving some thought to the matter. Much appreciated!
kladner is offline   Reply With Quote
Old 2012-08-15, 05:31   #26
flashjh
 
flashjh's Avatar
 
"Jerry"
Nov 2011
Vancouver, WA

112310 Posts
Default

Quote:
Originally Posted by chalsall View Post
It should be -- it's being sent. But I just check several submissions over the night, and they didn't have the E value. I've instructed Spidy to re-submit to James all results which had an E value.

James, any ideas?

Jerry, please let us know if you see this again. And rather than submitting the result manually, please just let us know what the exponent(s) involved are.
Ok, the first time I did a random sampling. Tonight I checked everything since the time you manually submitted (~13 Aug 12 / 1429z). Since your manual submission, my E values still don't show up. Also, the exponents with factors don't show b1/b2/e value.

I attached a txt file with all the P-1 exponents I've submitted since just before the time mentioned above. I still have the reuslts files, so I can submit manually, if you need me to.
Attached Files
File Type: txt P1.txt (3.2 KB, 164 views)
flashjh is offline   Reply With Quote
Old 2012-08-15, 13:58   #27
kjaget
 
kjaget's Avatar
 
Jun 2005

3×43 Posts
Default

Some bug reports :

In my assignement report, I see exponents assigned that are not in the worktodo files. For example, M57057041. In prime.log, looks like I got the exponent :

Code:
Getting assignment from server
URL: http://v5.mersenne.org/v5server/?v=0.95&px=GIMPS&t=ga&g=6bbacb98b1159fd192da1a7e8eeae88e&c=0&ss=31322&sh=03E363A14A10CD622603E5431ABE9C5E
RESPONSE:
pnErrorResult=0
pnErrorDetail=GPU72 assigned P-1 factoring work.
g=6bbacb98b1159fd192da1a7e8eeae88e
k=8d264aee6a9b01dcf37013d8d421c5a0
A=1
b=2
n=57057041
c=-1
w=4
sf=73
saved=2
==END==

PrimeNet success code with additional info:
GPU72 assigned P-1 factoring work.
Got assignment 8d264aee6a9b01dcf37013d8d421c5a0: P-1 M57057041
Sending expected completion date for M57057041: Sep 21 2012
URL: http://v5.mersenne.org/v5server/?v=0.95&px=GIMPS&t=ap&g=6bbacb98b1159fd192da1a7e8eeae88e&k=8d264aee6a9b01dcf37013d8d421c5a0&c=0&p=0.0000&d=86400&e=3757310&ss=30333&sh=2618CB841745D7EB4192B2E3C4FDCDE5
RESPONSE:
pnErrorResult=43
pnErrorDetail=ap: no such assignment key, GUID: 6bbacb98b1159fd192da1a7e8eeae88e, key: 8d264aee6a9b01dcf37013d8d421c5a0
==END==
Followed by an error when updating completion dates :

Code:
Sending expected completion date for M57057041: Sep 21 2012
URL: http://v5.mersenne.org/v5server/?v=0.95&px=GIMPS&t=ap&g=6bbacb98b1159fd192da1a7e8eeae88e&k=8d264aee6a9b01dcf37013d8d421c5a0&c=0&p=0.0000&d=86400&e=3753270&ss=19912&sh=AC5EA1ACFF0A63C23F67F5935DE8336B
RESPONSE:
pnErrorResult=43
pnErrorDetail=ap: no such assignment key, GUID: 6bbacb98b1159fd192da1a7e8eeae88e, key: 8d264aee6a9b01dcf37013d8d421c5a0
And that's the last I saw of it on my side, but it's still listed in the GPU272 assignments page. A number of these exponents are there assigned to Workstation rather than Workstation (1) as I'd expect.

Next up, I can get exponents on some but not all of my machines. "Laptop" in particular is not working at all. I see "GPU72_Proxy -- Need Program Options" followed by "Updating computer information on the server", but no actual GPU72 assignments in the logs. And doing a quick unreserve of a high LL or P-1 test gets me that same exponent back rather than a low one from GPU272. Since I get the GPU72 proxy response in some cases I think it's set up correctly (same as the machines which do work) so I'm not sure where to go from here.

Finally, on my other P-1 machine, I get a mix of GPU72 and Primenet P-1 assignments. Looks to be about 50-50 but I don't have exact numbers. I can send logs if you need them.

Sorry dump so much on you, but this has the potential to be a big time saver. Plus the nerd in me has the need to figure out what I've managed to break. Thanks in advance for the help.

Last fiddled with by kjaget on 2012-08-15 at 14:01
kjaget is offline   Reply With Quote
Old 2012-08-17, 14:01   #28
chalsall
If I May
 
chalsall's Avatar
 
"Chris Halsall"
Sep 2002
Barbados

23×1,103 Posts
Default

Quote:
Originally Posted by kjaget View Post
Sorry dump so much on you, but this has the potential to be a big time saver. Plus the nerd in me has the need to figure out what I've managed to break. Thanks in advance for the help.
Thank you for the very detailed bug report.

Unfortunately I've been a little busy the last few days on "other stuff", so haven't had a chance to drill down on this. But I keep logs of all proxy activity, so with what you've provided it should fairly easy to figure out what's going on. I'll try to take care of this today.
chalsall is offline   Reply With Quote
Old 2012-08-17, 18:13   #29
kjaget
 
kjaget's Avatar
 
Jun 2005

12910 Posts
Default

Thanks. I appreciate the hard work on what's really just a hobby for all of us.
kjaget is offline   Reply With Quote
Old 2012-08-19, 04:42   #30
flashjh
 
flashjh's Avatar
 
"Jerry"
Nov 2011
Vancouver, WA

1,123 Posts
Default

Two of my assignments were completed earlier this month but they're still showing up on my assignments page:

58748471 & 58750213

Edit: On the Assignments page, can you make the other columns sortable so it's easier to find these guys earlier? Thanks.

Last fiddled with by flashjh on 2012-08-19 at 04:47
flashjh is offline   Reply With Quote
Old 2012-08-20, 21:34   #31
James Heinrich
 
James Heinrich's Avatar
 
"James Heinrich"
May 2004
ex-Northern Ontario

52×113 Posts
Default

Quote:
Originally Posted by flashjh View Post
Since your manual submission, my E values still don't show up. Also, the exponents with factors don't show b1/b2/e value.
My first guess is that my primenet spider is noticing these results (without B1/B2/E data) and clobbering the good values already submitted by GPU72. That's an unsubstantiated guess, I haven't actually investigated yet. Would you mind emailing me the affected results.txt to remind me to look into it, please?
James Heinrich is offline   Reply With Quote
Old 2012-08-20, 23:25   #32
flashjh
 
flashjh's Avatar
 
"Jerry"
Nov 2011
Vancouver, WA

1,123 Posts
Default

Quote:
Originally Posted by James Heinrich View Post
My first guess is that my primenet spider is noticing these results (without B1/B2/E data) and clobbering the good values already submitted by GPU72. That's an unsubstantiated guess, I haven't actually investigated yet. Would you mind emailing me the affected results.txt to remind me to look into it, please?
Email sent, thanks for the help.
flashjh is offline   Reply With Quote
Old 2012-08-21, 15:22   #33
James Heinrich
 
James Heinrich's Avatar
 
"James Heinrich"
May 2004
ex-Northern Ontario

52·113 Posts
Default

Quote:
Originally Posted by flashjh View Post
Email sent, thanks for the help.
From what I can see, you've re-submitted these results so my site now shows the correct B1/B2/E values for those exponents. I took a look through the P-1 results parsing functions and it seems to have all the appropriate checks in place to not clobber B1/B2/E with empty values. If you notice that the problem is still happening, please let me know a specific exponent that's affected (and don't manually submit results.txt to overwrite the broken data).
James Heinrich is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Automatic fetch of Trial Factoring work for GPU mfakt* LaurV GPU to 72 58 2014-10-07 07:12
GPU72 doesn't show all available DC work Mark Rose GPU to 72 2 2014-01-24 00:33
GPU72 proxy ignores work type changes Bdot GPU to 72 7 2013-12-18 22:21
New work types for GPU72? chalsall GPU to 72 72 2013-10-03 20:21
Completed 29M work not showing as completed in GPU72 Chuck GPU to 72 2 2013-02-02 03:25

All times are UTC. The time now is 09:55.

Tue Mar 31 09:55:22 UTC 2020 up 6 days, 7:28, 0 users, load averages: 1.47, 1.32, 1.24

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.