mersenneforum.org  

Go Back   mersenneforum.org > Factoring Projects > Aliquot Sequences

Reply
 
Thread Tools
Old 2013-01-25, 17:18   #1
Greebley
 
Greebley's Avatar
 
May 2009
Dedham Massachusetts USA

3·281 Posts
Default Infinite loop for ggnfs or msieve

I have an infinite loop. The output on the screen is given below. I tried deleting the ggnfs directory and restarting but it sill got stuck.

Would this be an issue with the version of ggnfs that I am using (factMSieve.pl) or is it a Msieve errror? I still have the directory if any info is needed (i.e. someone can look at fixing it).

Any help is appreciated.

Wish I had noticed sooner though - I think it was stuck here for weeks.

Code:
Msieve v. 1.50 (SVN 708)
Fri Jan 25 11:33:18 2013
random seeds: 60a77a00 478f19f1
factoring 294782945281443036769924359704667212222030701864239860546015487524546773319786755416994274078336889169500517402939684633098143 (126 digits)
searching for 15-digit factors
commencing number field sieve (126-digit input)
R0: -2505096342680248801698532
R1: 6755081246719
A0: -1004277637129580409296316427155
A1: -11530059735057689302279641
A2: 62033508360785688815
A3: 223925563022053
A4: -1030745140
A5: 2988
skew 232010.41, size 5.688e-012, alpha -5.767, combined = 1.643e-010 rroots = 3
elapsed time 00:00:02
-> ___________________________________________________________
-> | This is the factMsieve.pl script for GGNFS. |
-> | This program is copyright 2004, Chris Monico, and subject|
-> | to the terms of the GNU General Public License version 2.|
-> |__________________________________________________________|
-> This is client 1 of 1
-> Using 1 threads
-> Working with NAME=test...
-> Selected default factorization parameters for 126 digit level.
-> Selected lattice siever: /aliquot/ggnfs/gnfs-lasieve4I13e.exe
-> Creating param file to detect parameter changes...
-> Q0=4800001, QSTEP=100000.
-> makeJobFile(): q0=4800000, q1=4900000.
-> makeJobFile(): Adjusted to q0=4800001, q1=4900000.
-> Lattice sieving algebraic q-values from q=4800001 to 4900000.
=> "/aliquot/ggnfs/gnfs-lasieve4I13e.exe" -k -o spairs.out -v -n0 -a test.job
gnfs-lasieve4I13e: L1_BITS=15, SVN $Revision: 406 $
FBsize 335794+0 (deg 5), 399992+0 (deg 1)
total yield: 50253, q=4808207 (0.01173 sec/rel)

Last fiddled with by Batalov on 2013-01-25 at 18:34 Reason: added [code] tags
Greebley is offline   Reply With Quote
Old 2013-01-25, 17:37   #2
Batalov
 
Batalov's Avatar
 
"Serge"
Mar 2008
Phi(4,2^7658614+1)/2

933310 Posts
Default

It is the siever that may be stuck. Latest versions were not supposed to be stuck, but this is a Windows siever... hmmm.
I'll have a look.

Please post the exact test.job file.

EDIT: With a linux 64-bit+asm siever, there was no bug, it plowed over several times (with different lims in attempt to match your values of 'FBsize 335794+0 (deg 5), 399992+0 (deg 1)'). I'll try to debug with non-asm version on linux, but I will not debug on Windows; don't have the right tools. Would anyone try to reproduce the loop on Windows under debugger and report the hanging line?

Last fiddled with by Batalov on 2013-01-25 at 18:33
Batalov is offline   Reply With Quote
Old 2013-02-06, 18:25   #3
Greebley
 
Greebley's Avatar
 
May 2009
Dedham Massachusetts USA

11010010112 Posts
Default

There was no test.job so I tried running it again. For some reason (aliqueit may have done something) it started with a new polynomial search.

I then didn't get the same fail - it appears to have made it to linear algebra.

I therefore don't have a repro for this or any files. I will keep an eye out for it in case it occurs again and I can gather more info.

In the meantime be aware it's possible for your run to stop getting anywhere and if you are not paying attention can sit on the same number forever.
Greebley is offline   Reply With Quote
Old 2013-02-06, 19:08   #4
rcv
 
Dec 2011

11×13 Posts
Default

I encounter this problem (or a similar problem) every couple of months or so. I'm running 64-bit debian, with factmsieve.py, and with the following siever files:

Code:
-rwxr-xr-x 1 primenet primenet    1128456 Feb 22  2008 gnfs-lasieve4I15e
-rwxr-xr-x 1 primenet primenet    1132514 Feb 22  2008 gnfs-lasieve4I14e
-rwxr-xr-x 1 primenet primenet    1140662 Feb 22  2008 gnfs-lasieve4I13e
-rwxr-xr-x 1 primenet primenet    1157272 Feb 22  2008 gnfs-lasieve4I12e
My (easy) work-around is to interrupt the run, and edit the .job.resume file:

Code:
Q0: 6500000
QSTEP: 200000
QQ0: 6500000, 6500000, 6550000
QQ1: 6550000, 6550000, 6600000
QQ2: 6600000, 6600000, 6650000
QQ3: 6650000, 6650000, 6700000
I add a million or so to each Q value, except QSTEP, then resume the job. So far, it's always worked.

[Yes, I've heard people mention newer versions of the siever files, but I don't think I've seen an authoritative link to the "fixed" versions. For me, the pain of hunting down and testing unknown new versions exceeds the pain of this trivial work-around.]

Edit: Would anyone care to provide an authoritative link to source or executable?

Last fiddled with by rcv on 2013-02-06 at 19:10
rcv is offline   Reply With Quote
Old 2013-02-06, 19:28   #5
Dubslow
Basketry That Evening!
 
Dubslow's Avatar
 
"Bunslow the Bold"
Jun 2011
40<A<43 -89<O<-88

3×29×83 Posts
Default

https://sites.google.com/site/bbuhro...ion-code-links
Dubslow is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Msieve & ggnfs on MacOS xilman Msieve 8 2017-05-20 00:12
Factorizing with MSIEVE, GGNFS & Factmsieve.py Romuald Msieve 24 2015-11-09 20:16
Python Driver for GGNFS and MSIEVE Brian Gladman Msieve 740 2014-06-02 07:52
x86 ASM loop control: JUMP vs LOOP ewmayer Programming 23 2012-04-29 21:13
Error running GGNFS+msieve+factmsieve.py D. B. Staple Factoring 6 2011-06-12 22:23

All times are UTC. The time now is 18:38.

Sun Mar 7 18:38:04 UTC 2021 up 94 days, 14:49, 1 user, load averages: 1.96, 1.67, 1.62

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.