mersenneforum.org  

Go Back   mersenneforum.org > Factoring Projects > YAFU

Reply
 
Thread Tools
Old 2022-09-06, 23:17   #430
storm5510
Random Account
 
storm5510's Avatar
 
Aug 2009
Not U. + S.A.

7×11×31 Posts
Default

Quote:
Originally Posted by James Heinrich View Post
"i7" and "Xeon" are both nebulous descriptors that could describe any number of CPUs over decades. Perhaps specific model numbers would provide more of a clue as to perhaps which features are not supported on your "Xeon".
E5-1620 Sandy Bridge EP.

Version 1.34.5 runs without issues. Nothing later will.
storm5510 is offline   Reply With Quote
Old 2022-09-07, 09:00   #431
kotenok2000
 
Mar 2018

2×52 Posts
Default

https://www.cpu-world.com/CPUs/Xeon/...20E5-1620.html
Maybe it requires avx2?

Last fiddled with by kotenok2000 on 2022-09-07 at 09:03
kotenok2000 is offline   Reply With Quote
Old 2022-09-07, 17:47   #432
bsquared
 
bsquared's Avatar
 
"Ben"
Feb 2007

1110100010112 Posts
Default

It should work on systems without AVX2, but I don't have any of those to test on anymore, so apparently it doesn't. Based on where it crashes it would seem the problem lies in the ysieve library, since one of the first things yafu does is create and store a small list of primes.
bsquared is offline   Reply With Quote
Old 2022-09-07, 18:12   #433
kruoli
 
kruoli's Avatar
 
"Oliver"
Sep 2017
Porta Westfalica, DE

100110010112 Posts
Default

Yes, I have analyzed this before:

Quote:
Originally Posted by kruoli View Post
When running the current build on GIT on an Ivy Bridge processor, I get an invalid instruction error (MULX, since Ivy Bridge does not support BMI(2)) at 0x000000013F571B43. This happens when the prompt (>> ) is already displayed. Is the processor too old to be supported out of the box?
kruoli is offline   Reply With Quote
Old 2022-09-07, 20:52   #434
James Heinrich
 
James Heinrich's Avatar
 
"James Heinrich"
May 2004
ex-Northern Ontario

22×983 Posts
Default

I know my i7-3930K (also Sandy Bridge) doesn't run YAFU 2.x, but I had always assumed that was Windows-7 thing. I guess it's (also?) a hardware thing.

(is it sad that my main daily system is nearing 11 years old? )
Attached Thumbnails
Click image for larger version

Name:	3930K.png
Views:	63
Size:	32.2 KB
ID:	27294  
James Heinrich is online now   Reply With Quote
Old 2022-09-07, 21:38   #435
kruoli
 
kruoli's Avatar
 
"Oliver"
Sep 2017
Porta Westfalica, DE

3·409 Posts
Default

Quote:
Originally Posted by James Heinrich View Post
(is it sad that my main daily system is nearing 11 years old? )
No, I won't give up on my one voluntarily!
kruoli is offline   Reply With Quote
Old 2022-09-08, 15:54   #436
storm5510
Random Account
 
storm5510's Avatar
 
Aug 2009
Not U. + S.A.

7·11·31 Posts
Default

Quote:
Originally Posted by James Heinrich View Post
I know my i7-3930K (also Sandy Bridge) doesn't run YAFU 2.x, but I had always assumed that was Windows-7 thing. I guess it's (also?) a hardware thing.

(is it sad that my main daily system is nearing 11 years old? )
Only my i7-7700 is AVX2. The Xeon and i5 are not. These two date back to 2012. The i7 is four years old, (2018). I sourced the parts and built it myself. The Xeon can run Windows 10 or Ubuntu 20.04. I doubt the i5 could run Windows 10. It runs Windows 7 well enough.
storm5510 is offline   Reply With Quote
Old 2022-09-19, 19:20   #437
kotenok2000
 
Mar 2018

5010 Posts
Default

My amd fx 6100 ran windows 10
kotenok2000 is offline   Reply With Quote
Old 2022-09-20, 04:27   #438
wombatman
I moo ablest echo power!
 
wombatman's Avatar
 
May 2013

1,847 Posts
Default

I'm running into the following error while trying to compile the latest YAFU:

Code:
/usr/bin/ld: ./libysiqs.a(SIQS.o): in function `siqs_static_init':
/home/wombat/yafu/factor/qs/SIQS.c:2309: undefined reference to `nextRoots_32k_avx2_intrin'
Compilation instruction is "make USE_AVX2 NFS=1". Everything else seems to be building properly as the above is the only error.
wombatman is offline   Reply With Quote
Old 2022-09-20, 13:10   #439
bsquared
 
bsquared's Avatar
 
"Ben"
Feb 2007

E8B16 Posts
Default

Quote:
Originally Posted by wombatman View Post
I'm running into the following error while trying to compile the latest YAFU:

Code:
/usr/bin/ld: ./libysiqs.a(SIQS.o): in function `siqs_static_init':
/home/wombat/yafu/factor/qs/SIQS.c:2309: undefined reference to `nextRoots_32k_avx2_intrin'
Compilation instruction is "make USE_AVX2 NFS=1". Everything else seems to be building properly as the above is the only error.
You'll need to add USE_BMI2=1 to the make line as well. Most cpu's that have avx2 also have bmi2... if yours doesn't then you'll have to remove both the avx2 and bmi2 options.
bsquared is offline   Reply With Quote
Old 2022-11-13, 22:34   #440
richs
 
richs's Avatar
 
"Rich"
Aug 2002
Benicia, California

2×17×47 Posts
Default

I sieved an Aliquot C141 using Yafu 2.0 and when the filtering ran, every relation was an error -11. Looking at the .fb file below, somehow Yafu did not include skew, rlim, frmax, famax, srlpmax, or salpmax.

Code:
N 379940961516713825613865981760557035526784109230555165792877792447392213895676955608876175676740458184733360391979563490370537264576678836483
A0 17921599049871804734714330370707400
A1 884689986849071910726068107020
A2 1004298442072520798460436
A3 -54583391456339434
A4 -93062625051
A5 9180
R0 -2105596592265349121584460471
R1 1152139905935473
I got it to work by adding skew and the other parameters to the .fb file and running Yafu 1. I'm not sure if this was my error or if Yafu 2.0 did not include the parameters for some odd reason.
richs is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
yafu ignoring yafu.ini chris2be8 YAFU 9 2022-02-17 17:52
Running YAFU via Aliqueit doesn't find yafu.ini EdH YAFU 8 2018-03-14 17:22
YAFU-1.34 bsquared YAFU 119 2015-11-05 16:24
Yafu bug. storflyt32 YAFU 2 2015-06-29 05:19
yafu 1.32 bsquared YAFU 28 2012-07-20 16:17

All times are UTC. The time now is 21:56.


Sun Dec 4 21:56:50 UTC 2022 up 108 days, 19:25, 0 users, load averages: 0.70, 0.82, 0.83

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.

≠ ± ∓ ÷ × · − √ ‰ ⊗ ⊕ ⊖ ⊘ ⊙ ≤ ≥ ≦ ≧ ≨ ≩ ≺ ≻ ≼ ≽ ⊏ ⊐ ⊑ ⊒ ² ³ °
∠ ∟ ° ≅ ~ ‖ ⟂ ⫛
≡ ≜ ≈ ∝ ∞ ≪ ≫ ⌊⌋ ⌈⌉ ∘ ∏ ∐ ∑ ∧ ∨ ∩ ∪ ⨀ ⊕ ⊗ 𝖕 𝖖 𝖗 ⊲ ⊳
∅ ∖ ∁ ↦ ↣ ∩ ∪ ⊆ ⊂ ⊄ ⊊ ⊇ ⊃ ⊅ ⊋ ⊖ ∈ ∉ ∋ ∌ ℕ ℤ ℚ ℝ ℂ ℵ ℶ ℷ ℸ 𝓟
¬ ∨ ∧ ⊕ → ← ⇒ ⇐ ⇔ ∀ ∃ ∄ ∴ ∵ ⊤ ⊥ ⊢ ⊨ ⫤ ⊣ … ⋯ ⋮ ⋰ ⋱
∫ ∬ ∭ ∮ ∯ ∰ ∇ ∆ δ ∂ ℱ ℒ ℓ
𝛢𝛼 𝛣𝛽 𝛤𝛾 𝛥𝛿 𝛦𝜀𝜖 𝛧𝜁 𝛨𝜂 𝛩𝜃𝜗 𝛪𝜄 𝛫𝜅 𝛬𝜆 𝛭𝜇 𝛮𝜈 𝛯𝜉 𝛰𝜊 𝛱𝜋 𝛲𝜌 𝛴𝜎𝜍 𝛵𝜏 𝛶𝜐 𝛷𝜙𝜑 𝛸𝜒 𝛹𝜓 𝛺𝜔