Go Back > Fun Stuff > Lounge

Thread Tools
Old 2008-07-18, 15:58   #1
jinydu's Avatar
Dec 2003
Hopefully Near M48

2·3·293 Posts
Default P-1 Test Ruined by Restart?

(Note: This is unrelated to my other thread)

I received a brand new laptop today and installed Prime95 on it. Since it has a dual core processor (Penryn, no less ), I started two instances of prime95. I set the first instance to do first-time LL tests and was assigned M37209241. I set the second instance to run double-checks and got M20290463. The first core had to go through P-1 testing first, whereas the second core got straight to LL testing M20290463.

Everything was working fine... until I had to restart the computer. At the time of the restart, the first core was almost certainly still working on the P-1 test, while the second was already over 280,000 iterations into the LL test. After the reboot, the second core automatically resumed testing M20290463. Unfortunately, I wasn't so lucky with the first core. That instance of prime95 didn't even start. When I forced it to start using prime95 -A0 on the command prompt, it asked me whether or not I wanted to join GIMPS and basically pleaded total ignorance of M37209241. It is currently idling without an exponent.

I've checked through the files, and am now even more confused. The results file says "Self-test 2048K passed!"; 2048K is the FFT size for M37209241, not M20290463. The local file has all the settings I set for the first core. And the worktodo file has only one line of text, namely "Test=37209241,67,0". So it would seem like if the data for one test is missing, it should not be M37209241. Based on this, I am hopeful that the data is somewhere on the hard drive; but I don't know what to do about it.


EDIT: Just tried restarting again. The result was similar: The second instance started automatically and picked up right where it left off. The first instance did not start automatically. I then forced it to start using prime95 -A0 and once again it was idle and appeared to know nothing about M37209241. However, it did not ask me whether or not I wanted to join GIMPS and the advanced options were unlocked; so it apparently remembered what I did after the first restart.

One final thing: This computer is running Windows Vista Business.

Last fiddled with by jinydu on 2008-07-18 at 16:12
jinydu is offline   Reply With Quote
Old 2008-07-18, 16:47   #2
S485122's Avatar
Sep 2006
Brussels, Belgium

11×151 Posts

As far as I can tell this is the same problem as on your other configuration. If you want an easy way of running more than one instance of Prime95, run them from different directories.

As for your P-1 test there should be a file with a 003 extension. If you can setup a second instance of Prime95 you must recreate the worktodo.ini file. It should contain a line with :


S485122 is offline   Reply With Quote
Old 2008-07-18, 17:15   #3
ckdo's Avatar
Dec 2007
Cleves, Germany

2·5·53 Posts

If you don't want to rename your files, you can still start the two instances via "prime95 -A1" and "prime95" (without "-A0") ...
ckdo is offline   Reply With Quote
Old 2008-07-19, 08:55   #4
jinydu's Avatar
Dec 2003
Hopefully Near M48

33368 Posts

Two new developments...

1) Typing "prime95" (but NOT "prime95 -A0") in command prompt successfully loads the first instance. Not only that, the instance remembered everything about M37209241.

2) I've tried restarting the computer quite a few times. In all but one case, the first instance did not start automatically, which is rather strange because I didn't change any settings.

Last fiddled with by jinydu on 2008-07-19 at 08:56
jinydu is offline   Reply With Quote

Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Restart test? Or what to do? Thecmaster Hardware 8 2016-05-14 02:22
The Joys of 5 Ways We Ruined the Occupy Wall Street Generation Dubslow Soap Box 17 2012-05-14 08:51
Is it possible to restart? aketilander Software 3 2011-09-03 11:12
Restart ;) Svenie25 Twin Prime Search 4 2010-08-05 23:04
How should I restart? Unregistered Software 3 2003-11-19 23:19

All times are UTC. The time now is 06:36.

Tue Apr 20 06:36:00 UTC 2021 up 12 days, 1:16, 0 users, load averages: 2.97, 3.26, 3.19

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.