mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > Software

Closed Thread
 
Thread Tools
Old 2004-07-18, 21:15   #1
antiroach
 
antiroach's Avatar
 
Jun 2003

22·61 Posts
Default Problem with mprime (Fixed with mprime -d)

Hey, i have trouble getting mprime to do work for LMH. FIrst off im a linux newbie. I'm running mandrake 10. I got mprime to execute just fine. I was able to input some user info and preferences and the like. I have a worktodo.ini file that i copied over from my windows installation. But whenever I copy that file into the mprime directory and run mprime, it just hangs. CPU usage is negligible, and no output is produced. Am I doing something wrong? My goal is to let mprime continue factoring the exponents in my worktodo.ini file and write the results out to file. Any help would be appreciated.
antiroach is offline  
Old 2004-07-18, 23:13   #2
roy1942
 
Aug 2002

47 Posts
Default

Maybe the problem is in the format of your worktodo.ini file. Remember that in Windows, a text line ends with a carriage-return + line-feed pair, while in linux/unix, it just ends with a line-feed. Some programs to transfer files between computers - like ftp in ascii mode - will take care of the conversion, but others may not. I don't know how prime95 or mprime behave if they read the wrong type of file, but perhaps that could be your problem.
roy1942 is offline  
Old 2004-07-19, 04:07   #3
antiroach
 
antiroach's Avatar
 
Jun 2003

22·61 Posts
Default

wow i really should learn to read the documentation. ./mprime -d does wonders :)
Everything seems to be working now.
antiroach is offline  
Closed Thread

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
[Patch] CPU affinity prompt problem in mprime Linux / OS X build Explorer09 Software 1 2017-03-01 02:34
mprime messages line wrap problem (with patch) Explorer09 Software 5 2015-03-25 20:48
mprime 257 bug? programmeryh Software 4 2008-11-13 15:23
mprime finished factoring almost immediately, possible HW problem? optim Software 4 2004-06-21 22:19
Linux mprime client v22.8 problem Prime Monster Software 6 2002-08-29 11:14

All times are UTC. The time now is 07:54.

Thu Dec 3 07:54:53 UTC 2020 up 4:06, 0 users, load averages: 0.93, 1.07, 1.01

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.