mersenneforum.org  

Go Back   mersenneforum.org > Great Internet Mersenne Prime Search > Software

Reply
 
Thread Tools
Old 2008-11-15, 18:15   #210
Nelson
 
Nelson's Avatar
 
Apr 2008
Regensburg..^~^..Plzeň

5×17 Posts
Default

Quote:
Originally Posted by petrw1 View Post
Correction: It is my previous worktodo.ini assignments that went to ANONYMOUS.

It appears that even though the assignments show as belonging to ANONYMOUS; as they complete the credit is given to me as follows:
I was assigned the exponent below in v4 to factor from 65 to 69.
65 and 66 finished before the upgrade to v5 today.
67 (the last line below) finished by me in v5 and was credited to me.
However, it still shows as assigned to ANONYMOUS so I can only assume it will credit 68 and 69 bits to me to.
I'm curious when new assignments for CPU0 will start to show as belonging to me.

Code:
Exponent Status Data  
58291063 No factors below 2^65 
 Assigned Trial factoring to "ANONYMOUS" on 2008-10-28 
 History no factor from 2^63 to 2^64 by "Sara" on 2008-10-28 
 History no factor from 2^64 to 2^65 by "Sara" on 2008-10-28 
 History no factor from 2^67 to 2^68 by "petrw1" on 2008-11-15

I think that looks OK! Just doing your assigned work regardless of who it is assigned to will eventually have credit assigned to you properly especially in the case of "ANONYMOUS". If you fail to comlete your assignements someone else may get the credit having been assigned the work units to clean up expired work. Assignments from V5 should show up as belonging to your user name/team.

One thing I have noticed is some recommend stopping v25 when making changes to "worktodo.txt" which is not quite correct and all the help and undoc.txt files do not make the procedure clear. It is essential when modifying "worktodo.txt", "local.txt", "prime.txt" that prime95 be closed and restarted after modifications are made. A system restart will be required for it to run as a service with XP. Comments are also allowed within the parameter files using the semicolon meaning lines beginning with ";" will be ignored when being parsed.
Nelson is offline   Reply With Quote
Old 2008-11-15, 20:49   #211
penguin66
 
penguin66's Avatar
 
Oct 2008
Left of Albuquerque

1112 Posts
Default

Quote:
Originally Posted by petrw1 View Post
Correction: It is my previous worktodo.ini assignments that went to ANONYMOUS.

It appears that even though the assignments show as belonging to ANONYMOUS; as they complete the credit is given to me as follows:
I was assigned the exponent below in v4 to factor from 65 to 69.
65 and 66 finished before the upgrade to v5 today.
67 (the last line below) finished by me in v5 and was credited to me.
However, it still shows as assigned to ANONYMOUS so I can only assume it will credit 68 and 69 bits to me to.
I'm curious when new assignments for CPU0 will start to show as belonging to me.

Code:
Exponent Status Data  
58291063 No factors below 2^65 
 Assigned Trial factoring to "ANONYMOUS" on 2008-10-28 
 History no factor from 2^63 to 2^64 by "Sara" on 2008-10-28 
 History no factor from 2^64 to 2^65 by "Sara" on 2008-10-28 
 History no factor from 2^67 to 2^68 by "petrw1" on 2008-11-15
Someone else with a similar issue! All my assignments since I upgraded have shown as being assigned to ANONYMOUS and completed assignments are not being credited to me as well as results are showing as being completed by ANONYMOUS. Seems as if my user name was rejected even though I can pull up my v4 credit on my user name. I'd like to fix this too.

This is what one of the exponent status looks like when I check the exponent status on PrimeNet:
59512381No factors below2^67
AssignedTrial factoring to "ANONYMOUS" on 2008-11-14
Historyno factor from 2^63 to 2^64 by "monst" on 2008-07-05
Historyno factor from 2^64 to 2^65 by "ANONYMOUS" on 2008-11-13
Historyno factor from 2^65 to 2^66 by "ANONYMOUS" on 2008-11-13
Historyno factor from 2^66 to 2^67 by "ANONYMOUS" on 2008-11-14
penguin66 is offline   Reply With Quote
Old 2008-11-15, 20:57   #212
starrynte
 
starrynte's Avatar
 
Oct 2008
California

22·59 Posts
Default

assuming you entered the user id in prime95 and have linked your v4 id, i have no idea..
starrynte is offline   Reply With Quote
Old 2008-11-16, 02:10   #213
Nelson
 
Nelson's Avatar
 
Apr 2008
Regensburg..^~^..Plzeň

8510 Posts
Cool my rank way to high

Quote:
Originally Posted by penguin66 View Post
Someone else with a similar issue! All my assignments since I upgraded have shown as being assigned to ANONYMOUS and completed assignments are not being credited to me as well as results are showing as being completed by ANONYMOUS. Seems as if my user name was rejected even though I can pull up my v4 credit on my user name. I'd like to fix this too.

This is what one of the exponent status looks like when I check the exponent status on PrimeNet:
59512381No factors below2^67
AssignedTrial factoring to "ANONYMOUS" on 2008-11-14
Historyno factor from 2^63 to 2^64 by "monst" on 2008-07-05
Historyno factor from 2^64 to 2^65 by "ANONYMOUS" on 2008-11-13
Historyno factor from 2^65 to 2^66 by "ANONYMOUS" on 2008-11-13
Historyno factor from 2^66 to 2^67 by "ANONYMOUS" on 2008-11-14
Unless you linked your v4 statistics as described here and on your user account summary page near the top which can take a few days to be updated it will remain credited to anonymous. I'm hoping a lot more users will soon get their credit transferred so I can move down to a ranking of 950 instead of 50 for HighPriceRanch where I am now. I guess that's the glory of getting everything transferred so readily.

With the first v25.x George had said the transfer to the V5 server would be accomplished using the email addresses and informing all users of the change rather than the forum. The suddenness of the V4 server failure put things ahead of schedule but allows Scott to concentrate his efforts on the V5 server and not be divided between two servers. So the compilation of procedures for the change and will require some ingenuity on the part of users. Some are working on the help menu for v25.x maybe others are working on communication with older users. Instructions on the gimps homepage are pretty clear to me. Perhaps a message should be sent reminding users where help is available namely the Gimps homepage and this forum the first prerequisite though is reading what is already there. The only undescribed situation I am aware of is new users and the installation which is really only copying/extracting files to a folder. Actual installation occurs by executing the program itself. Shortcuts to the program are not installed in neither the program list nor the desktop and must be created by the user which many new computer users are not familiar with.

nelson
Nelson is offline   Reply With Quote
Old 2008-11-16, 15:02   #214
penguin66
 
penguin66's Avatar
 
Oct 2008
Left of Albuquerque

7 Posts
Default

Nelson-
Thanks for the help. Unfortunately, my v4 id is linked. This is my v5 id that is causing the problems.
penguin66 is offline   Reply With Quote
Old 2008-11-16, 22:19   #215
jinydu
 
jinydu's Avatar
 
Dec 2003
Hopefully Near M48

110110111102 Posts
Default

Weird. I just realized that M100,000,039 no longer appears on my account, nor am I listed under the exponent's status.

I dug through the prime.log file and found this:

PrimeNet success code with additional info:
WARNING: Estimated completion date is more than one year away. The assignment may be reassigned to another user after one year.
[Wed Nov 12 08:20:54 2008 - ver 25.7]
Unreserving M100000039
URL: (omitted)
RESPONSE:
pnErrorResult=0
pnErrorDetail=SUCCESS
==END==

I can add it again, but I don't know why this happened.
jinydu is offline   Reply With Quote
Old 2008-11-16, 22:24   #216
Prime95
P90 years forever!
 
Prime95's Avatar
 
Aug 2002
Yeehaw, FL

5·1,553 Posts
Default

Quote:
Originally Posted by jinydu View Post
Weird. I just realized that M100,000,039 no longer appears on my account, nor am I listed under the exponent's status.

I dug through the prime.log file and found this:.
Send me the prime.log file
Prime95 is offline   Reply With Quote
Old 2008-11-21, 22:39   #217
garo
 
garo's Avatar
 
Aug 2002
Termonfeckin, IE

276410 Posts
Default

I have an issue with the priority setting of Prime95 v25.7 on Windows XP. I'm running it on priority 2 as I want to run something "under" it to soak up the cycles when Prime95 is not running or out of work. At priority 1 I get process priority of 32 (normal) and thread priority 0 (for main and comm) threads and -15 (lowest) for the worker threads. This causes Prime95 to share CPU with the other app and is fine. But when I change the priority to 2, the worker threads get priority 0 and this causes the computer to become less responsive. 32,0 is normal process,thread and I believe too high for priority 2. You should try -2 for the worker thread.

Also, when I change priority in the program unpredictable stuff happens and different worker threads end up with different priorities occasionally. The behaviour here is non-deterministic.
garo is offline   Reply With Quote
Old 2008-11-22, 00:52   #218
James Heinrich
 
James Heinrich's Avatar
 
"James Heinrich"
May 2004
ex-Northern Ontario

22×29×31 Posts
Default

It seems that Prime95 only submits benchmark results if PrimeNet use is enabled, i.e. not for stresstest-only people. Would it be possible to at least ask the user if they would like to submit the benchmark result after it's been run? Possibly check the database to see if there is already a result for that CPU type at that clockspeed to avoid transmitting and storing a lot of duplicate results, but there's great potential to get a much wider range of benchmark data than is currently collected.
James Heinrich is offline   Reply With Quote
Old 2008-11-22, 01:51   #219
starrynte
 
starrynte's Avatar
 
Oct 2008
California

22×59 Posts
Default

Quote:
Originally Posted by James Heinrich View Post
Would it be possible to at least ask the user if they would like to submit the benchmark result after it's been run?
seconded, though my reason is because sometimes i run the benchmark only to test my overclock, yet i do not want to submit the benchmark
also, after the benchmark and/or timing an exponent the worker doesn't continue, is this expected
starrynte is offline   Reply With Quote
Old 2008-11-22, 04:05   #220
Prime95
P90 years forever!
 
Prime95's Avatar
 
Aug 2002
Yeehaw, FL

5×1,553 Posts
Default

Quote:
Originally Posted by garo View Post
But when I change the priority to 2, the worker threads get priority 0 and this causes the computer to become less responsive..
I'll fix it. I misread the SetThreadPriority documentation.
Prime95 is offline   Reply With Quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Prime95 version 27.3 Prime95 Software 148 2012-03-18 19:24
Prime95 version 26.3 Prime95 Software 76 2010-12-11 00:11
Prime95 version 25.5 Prime95 PrimeNet 369 2008-02-26 05:21
Prime95 version 25.4 Prime95 PrimeNet 143 2007-09-24 21:01
When the next prime95 version ? pacionet Software 74 2006-12-07 20:30

All times are UTC. The time now is 18:48.


Tue Jan 18 18:48:37 UTC 2022 up 179 days, 13:17, 0 users, load averages: 1.20, 1.29, 1.35

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.

This forum has received and complied with 0 (zero) government requests for information.

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.
A copy of the license is included in the FAQ.

≠ ± ∓ ÷ × · − √ ‰ ⊗ ⊕ ⊖ ⊘ ⊙ ≤ ≥ ≦ ≧ ≨ ≩ ≺ ≻ ≼ ≽ ⊏ ⊐ ⊑ ⊒ ² ³ °
∠ ∟ ° ≅ ~ ‖ ⟂ ⫛
≡ ≜ ≈ ∝ ∞ ≪ ≫ ⌊⌋ ⌈⌉ ∘ ∏ ∐ ∑ ∧ ∨ ∩ ∪ ⨀ ⊕ ⊗ 𝖕 𝖖 𝖗 ⊲ ⊳
∅ ∖ ∁ ↦ ↣ ∩ ∪ ⊆ ⊂ ⊄ ⊊ ⊇ ⊃ ⊅ ⊋ ⊖ ∈ ∉ ∋ ∌ ℕ ℤ ℚ ℝ ℂ ℵ ℶ ℷ ℸ 𝓟
¬ ∨ ∧ ⊕ → ← ⇒ ⇐ ⇔ ∀ ∃ ∄ ∴ ∵ ⊤ ⊥ ⊢ ⊨ ⫤ ⊣ … ⋯ ⋮ ⋰ ⋱
∫ ∬ ∭ ∮ ∯ ∰ ∇ ∆ δ ∂ ℱ ℒ ℓ
𝛢𝛼 𝛣𝛽 𝛤𝛾 𝛥𝛿 𝛦𝜀𝜖 𝛧𝜁 𝛨𝜂 𝛩𝜃𝜗 𝛪𝜄 𝛫𝜅 𝛬𝜆 𝛭𝜇 𝛮𝜈 𝛯𝜉 𝛰𝜊 𝛱𝜋 𝛲𝜌 𝛴𝜎 𝛵𝜏 𝛶𝜐 𝛷𝜙𝜑 𝛸𝜒 𝛹𝜓 𝛺𝜔