Thread: YAFU 2.0
View Single Post
Old 2021-09-02, 17:08   #207
Plutie
 
"Evan"
Dec 2020
Montreal

23·32 Posts
Default

Quote:
Originally Posted by Stargate38 View Post
I can't get CUDA Poly selection to work.

Code:
searching leading coefficients from 8942 to 9192
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
error: GPU sort engine not found at "C:\Numbers\aliqueit112\cub\sort_engine.dll"
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
error: GPU sort engine not found at "C:\Numbers\aliqueit112\cub\sort_engine.dll"
error: GPU sort engine not found at "C:\Numbers\aliqueit112\cub\sort_engine.dll"
error: GPU sort engine not found at "C:\Numbers\aliqueit112\cub\sort_engine.dll"
selected card has CUDA arch 7.5
error: GPU sort engine not found at "C:\Numbers\aliqueit112\cub\sort_engine.dll"
error: GPU sort engine not found at "C:\Numbers\aliqueit112\cub\sort_engine.dll"
Anyone know where to get that Sort_engine.dll? I tried a version that I found on this forum, but YAFU gave me this:

Code:
searching leading coefficients from 9442 to 9692
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
deadline: 8640000 CPU-seconds per coefficient
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
selected card has CUDA arch 7.5
deadline: 8640000 CPU-seconds per coefficient
deadline: 8640000 CPU-seconds per coefficient
deadline: 8640000 CPU-seconds per coefficient
deadline: 8640000 CPU-seconds per coefficient
deadline: 8640000 CPU-seconds per coefficient
deadline: 8640000 CPU-seconds per coefficient
deadline: 8640000 CPU-seconds per coefficient
error (line 1128): CUDA_ERROR_FILE_NOT_FOUND
error (line 1128): CUDA_ERROR_FILE_NOT_FOUND
YAFU Info:

Code:
YAFU Version 2.06
Built with Microsoft Visual C/C++ 1929
Using GMP-ECM 7.0.5-dev, Powered by MPIR 3.0.0
Detected Intel(R) Core(TM) i5-9300H CPU @ 2.40GHz
Detected L1 = 32768 bytes, L2 = 8388608 bytes, CL = 64 bytes
Using 1 random witness for Rabin-Miller PRP checks
Cached 664579 primes; max prime is 9999991
Number I'm trying to factor:

Code:
48459122254139394182129172328473262875134312328758582582515084646652819439706917682551935490060136608549891
Anyone know what file is missing when it says "CUDA_ERROR_FILE_NOT_FOUND"? I think error messages should be made more specific/verbose.
Which version of msieve are you using? I would recommend you download the updated source code from https://sourceforge.net/p/msieve/code/HEAD/tree/trunk/ and build it yourself from the build.cuda.vs directory.

Edit: This is more of something you should attempt if the solution above from Brian Gladman doesn't work for you.

Last fiddled with by Plutie on 2021-09-02 at 17:10
Plutie is offline   Reply With Quote