View Single Post
Old 2004-10-02, 21:15   #1
sirius56
 

542810 Posts
Angry Segmentation Fault

I've run 7 prime number tests smoothly and then ran into problems with this assigned number. I get the error shown below. I've tried varying allocated memory from 32 to 256 MB, tried two fresh Fedora 2 installs, kernels 2.6 and 2.8. Nothing else is running on my 2.8 GHz Pentium with 512 MB RAM besides mprime. Also ran a day of torture tests.

Does anyone have any suggestions of what I can else I can try to get around the segmentation fault? I don't think I am able to do any recompilation of mprime.

Thank you for your help. I'd hate to abandon GIMPS because of this bug--it's been fun.

--------------------------------------------------------------------------------------------------------------
Mersenne number primality test program version 23.9
Starting P-1 factoring on M25855931 with B1=300000, B2=6375000
Chance of finding a factor is an estimated 5.14%
P-1 on M25855931 with B1=300000, B2=6375000
Starting stage 1 GCD - please be patient.
Stage 1 GCD complete. Time: 119.442 sec.
Segmentation fault
  Reply With Quote