View Single Post
Old 2020-08-17, 12:46   #1
keisentraut
 
Jul 2020

22×3 Posts
Default mfaktc 0.21 - CUDA runtime wrong

I want to compile and run mfaktc 0.21 on my Arch Linux laptop. This has worked well until a few months ago, but now it doesn't, likely because of some upgrade which I didn't pay attention to....
I have a GeForce GTX 950M. It is only capable of doing around 130GHz days per day of factoring. Compute Capability is 5.0, the card is supported by CUDA toolkit 6.0-11.0. I have installed cuda package 11.0 from the Arch Linux official repository. I uncommented this line in the Makefile.
Code:
 NVCCFLAGS += --generate-code arch=compute_50,code=sm_50 # CC 5.x GPUs will use this code
All of this has worked flawlessly until a few months ago, but now I get the following error message when I run mfaktc:
Code:
CUDA version info   binary compiled for CUDA  11.0
  CUDA runtime version      32.66
  CUDA driver version       11.0
ERROR: CUDA runtime version must match the CUDA toolkit version used during compile!
Why the heck is the CUDA runtime version 32.66? Version 32 does not even exist, does it?
keisentraut is offline   Reply With Quote