View Single Post
Old 2016-11-09, 01:48   #5
Gordon
 
Gordon's Avatar
 
Nov 2008

3×167 Posts
Default

Quote:
Originally Posted by EdH View Post
I'm running the following command on many threads/machines:
Code:
ecm -maxmem NNNN -save residuesNNN.txt 2900000000 2900000000 <ecmIn
This is to catch the stage 1 residues to provide to someone with a better computer for handling stage 2 operations.

I know the -maxmem option is really only for stage 2, but some of the troubles appear to be a memory issue, so I'm trying it in the command.

My trouble is that I keep getting "Killed," "Aborted" and:
Code:
GNU MP: Cannot allocate memory (size=537395216)
The above is from a machine with -maxmem set to 1000. These errors are mixed in with successful runs, but on some of my machines the ratio of errors to successes is pretty high.
I often get this specific size, as well:
Code:
GNU MP: Cannot allocate memory (size=134348816)
Test runs with verbose don't seem to get me much more information:
Code:
ecm -v -v -v -maxmem 1000 -save residueTest.txt 2900000000 2900000000 <ecmIn >>ecmTestRun
Killed
ecmTestRun:
Code:
GMP-ECM 7.0.3 [configured with GMP 6.1.1, --enable-asm-redc] [ECM]
Tuned for x86_64/core2/params.h
Running on math42
Input number is 2946089330333814475136036009797674301714904698125983205350145085
43624382856308454582943295881369613178204666034390617841242524699661693911485248
69909406500896547611862071404959591325864761463 (191 digits)
Using MODMULN [mulredc:1, sqrredc:1]
I haven't tried running ecm under gdb, since I'm still not familiar with it enough and am assuming the Killed/Aborted/size messages are from normal ECM actions, rather than crashes.

I haven't really found anything explaining the messages in the documentation, although I might not have done a thorough enough search.

Does GMP-ECM try to check for enough memory for stage 2 before it completes stage 1? Is there a time when GMP-ECM needs a large block in stage 1? The documentation seems to say, "No."

Any thoughts, or suggestions? Or, are these machines just on the edge of their capabilities?

Thanks for any assistance that can be provided...
I had to check your memory request numbers twice, they are only 500 meg, I've run into memory allocation errors trying to allocate 4gb before (on a 32gb machine).

Your "Test" is on a B1 of 2.9 billion right? and 191 digits (633 bits) is a really tiny number have you tried GPU-ECM?
Gordon is offline   Reply With Quote