View Single Post
Old 2020-07-09, 14:04   #1
Random Account
storm5510's Avatar
Aug 2009

2·971 Posts
Default MPrime with Windows 10 Linux Subsystem

Getting all this set up was a learning experience. After loosening a few teeth I managed to get it all working properly. Ubuntu 20.04 LTS is the Linux side. I had to cheat a bit to get all the files in the proper place. I used a command prompt window to do a directory search of the HD to find the mprime folder I had created with the Ubuntu shell. It was way down in the User/AppData area. Once I navigated to it, I pinned it in the File Explorer.

I tried to run it by using the standard ./mprime -d command inside the shell. It said it was unable to create some files and could not find my worktodo file. Placing sudo at the front solved the problem. In this shell-only setup, I do not know if the permissions can be elevated to where the use of sudo would not be needed.

There is one concern: Heat. During Stage 1, the temperature of the CPU will stay above 85°C and will sometimes spike to 90°C. The "Throttle" setting does not work with mprime in this case. I suspect this has more to do with Windows 10 than anything else. There is probably another way to cut the heat down some, Affinity. In Prime95. it is set to two threads for a single worker and two threads for the helper. I did this in local.txt. Changing this to one and three might help.

This is all I have. I shared this in case anyone in the future wanted to try doing this. If anyone has any suggestions or comments, please feel free to write them. Thank you!

storm5510 is offline   Reply With Quote