View Single Post
Old 2008-05-23, 13:33   #31
mdettweiler
A Sunny Moo
 
mdettweiler's Avatar
 
Aug 2007
USA (GMT-5)

3×2,083 Posts
Default

Quote:
Originally Posted by em99010pepe View Post
It's a server problem, if you go to the server page you will see the stats are stuck too. This is so stupid, the client should be independent of the server, if it has work it should continue to work and not get stuck at 99.9% when the cache is full. This llrnet client is so buggy.
Hmm...I don't think there's a bug in the stats, the reason why they would appear stuck is because there's no work being returned. However, it is quite odd that everybody's LLRnet clients would all freeze at the same time--even my Linux clients froze! (I finally realized the Linux clients do freeze after all--just they do it a little differently. Instead of freezing at 99.9% with cache full, they just stop requesting work from the server, run down the workunit cache [or the refill setting in the case of the batching client], and get stuck. A Ctrl-C or pkill won't stop them, you have to stop them with "pkill -SIGKILL llrnet".)

Both of my clients are restarted and back online now, and I imagine everyone else's that aren't back on yet will be soon. Most of the rally participants should be able to read these posts, notice that their clients aren't working (if they didn't notice already) and restart them; what I'm a little worried about are Flatlander's clients, which might have the very bad fortune to be all frozen only a day or two after he came last came home and un-froze them. He won't be there to un-freeze them now since he's on vacation, so they might end up idle until he comes back.
mdettweiler is offline