View Single Post
Old 2020-10-21, 22:16   #1
EdH
 
EdH's Avatar
 
"Ed Hall"
Dec 2009
Adirondack Mtns

3×11×107 Posts
Default Tribulations of Upgrading Ubuntu from 16.04 LTS to 20.04 LTS

This will probably seem like a rant. Maybe it is! Maybe this will just be a funny story some day. . .

I have many machines that I decided to upgrade to 20.04 LTS (via 18.04 LTS) now that I can make openmpi and ecmpi run on Ubuntu 20.04

All my machines are run remotely. Except for some laptops and all-in-ones, they're headless and many are not in a real easy to reach location.

Of course, I did a few that are closer at hand before trying to upgrade the bulk, but that didn't save me. Here's a list of trouble spots:

NONE (well, mostly none) of my factoring programs work any more. I have to recompile and reinstall GMP, GMP-ECM, Msieve, YAFU, CADO-NFS, ecmpi and, of course, many of these have to be done in a particular order. But, worse yet, several wouldn't work with their original folders using make clean, etc. Nooo. . . I have to start fresh with a new folder with programs like YAFU and CADO-NFS. And, it's not because they're in UPPER case - ecmpi behaved that way, too.

Ah, but let's add in that after several successes, I found that the auto login for my headless remote machines was turned off, so my VNC connections no longer worked. At least my SSH sessions allowed me to remotely repair that BS.

But, wait! There's more! Some machines didn't make it past 18.04 because when they reset to complete the upgrade they decided they could no longer reach out to the Internet! I can reach them over the LAN, but that's where they stop. If I can't get them to upgrade to 20.04, they are going to be useless and I'll probably have to wipe them and put a new 20.04 install on them.

But, wait! Also, the 20.04 upgrade changes the "Don't Suspend" to "Suspend in 20 minutes!" Guess how I found that out! Did I mention my machines are uncomfortable to physically access?

Back to the LAN-Locked 18.04 machines: If anyone is still reading, if they actually looked at this tread in the first place, any ideas? All my machines are set up with static IPs, but for these I went back and forth with DHCP and Static just to see if they might iron themselves out, but no joy. I also tried different DNS addresses between the router base and Google's 8.8.8.8 and 1.1.1.1 that I heard of somewhere. In case it matters, the title bar icon shows it is not working correctly by placing a question mark version where the dual arrows used to appear. I can ping the router and 8.8.8.8 or 1.1.1.1, but not other IPs or DNS entries.

If anyone has any thoughts about the Internet issue, I wouldn't mind reading them. I "think" I have all the rest under control, even if it is going to take a long time to get these machines factoring again.
EdH is offline   Reply With Quote