Thread: mtsieve
View Single Post
Old 2020-06-04, 03:15   #344
Citrix
 
Citrix's Avatar
 
Jun 2003

32·52·7 Posts
Default

Quote:
Originally Posted by rogue View Post
Hmm. I will have to run some more tests then. Is this the same error you were seeing before? What command line parameters are you using?
Code:
gcwsievecl.exe -p 3770000000000 -P 4000000000000 -b 2 -n 825 -N 1000 -s +
Same error. Crashes after printing banner. Though the gcwsievecl.exe from latest release does work as I mentioned before.

I believe it has something to do with not having proper libraries at the time of compile etc. I do get the following warning. Not sure if it makes a difference.

Code:
In file included from cullen_woodall/../core/../opencl/../CL/cl.h:22,
                 from cullen_woodall/../core/../opencl/Device.h:22,
                 from cullen_woodall/../core/App.h:26,
                 from cullen_woodall/../core/FactorApp.h:14,
                 from cullen_woodall/../core/AlgebraicFactorApp.h:14,
                 from cullen_woodall/CullenWoodallApp.h:16,
                 from cullen_woodall/CullenWoodallWorker.h:11,
                 from cullen_woodall/CullenWoodallWorker.cpp:12:
cullen_woodall/../core/../opencl/../CL/../CL/cl_version.h:22:104: note: #pragma message: cl_version.h: CL_TARGET_OPENCL_VERSION is not defined. Defaulting to 220 (OpenCL 2.2)
 #pragma message("cl_version.h: CL_TARGET_OPENCL_VERSION is not defined. Defaulting to 220 (OpenCL 2.2)")
Citrix is online now   Reply With Quote