View Single Post
Old 2016-02-05, 23:11   #17
ewmayer
2ω=0
 
ewmayer's Avatar
 
Sep 2002
Rep├║blica de California

11×19×47 Posts
Default

There are two distinct issues here - [1] the basic code-build and [2] the automated Linux/x86-oriented build scripts - which should be tackled in turn. I'll let Alex focus on [2] since he developed the scripts.

As to [1], the OP mentions having 'tried' the pre-build-script-wrapped 14.1 release - what precisely was tried? The manual build instructions on the README page? Note that due to the non-x86 CPUs here we are stuck with the non-SIMD basic scalar-double C build. But it's still always useful to work through build and code issues on non-primary-target platforms, to make/keep the code as portable as reasonably possible.

So to the OP (or anyone else with access to this platform - I will look into a guest account over the weekend), try the most-basic manual build first: straight C, unthreaded - i.e. no USE_ flags of any kind in the compile command.

As for the threading-related preprocessor #error, if this platform supports pthreads it should be a simple matter of tweaking the platform.h header to look in the right place for the pthreads-related header files. Looking at the #error line Alex quoted in my platform.h file, it's clear the

#include <pthread.h>

is not finding the pthread.h file. Is there one in the /include tree on this platform?
ewmayer is offline   Reply With Quote