View Single Post
Old 2016-01-15, 17:45   #7
wombatman
I moo ablest echo power!
 
wombatman's Avatar
 
May 2013

1,741 Posts
Default

No problem. It builds without error under MinGW--I can do, for instance, ecm factoring and the like without any issue. I haven't tried an nfs(), but I'll do that and report back. Maybe I can at least narrow down what's going on for you.

Edit: nfs() on a small (91 digits) number works fine all the way through. And to confirm that it's siqs() related, I ran the same number through there--it crashed after building and processing the matrix:

Code:
largest cycle: 17 relations
matrix is 74160 x 74841 (18.5 MB) with weight 4256736 (56.88/col)
sparse part has weight 4256736 (56.88/col)
filtering completed in 3 passes
matrix is 67465 x 67529 (16.8 MB) with weight 3861614 (57.18/col)
sparse part has weight 3861614 (57.18/col)
saving the first 48 matrix rows for later
matrix is 67417 x 67529 (14.5 MB) with weight 3347595 (49.57/col)
sparse part has weight 3112970 (46.10/col)
matrix includes 64 packed rows
using block size 27011 for processor cache size 12288 kB
commencing Lanczos iteration
memory use: 11.6 MB
lanczos halted after 1067 iterations (dim = 67415)
recovered 17 nontrivial dependencies
Lanczos elapsed time = 12.1930 seconds.
Sqrt elapsed time = 0.0680 seconds.
SIQS elapsed time = 303.6504 seconds.

Last edit for now: The crash occurs at free_siqs(thread_data[0].sconf); in siqs.c (as confirmed by strategically placed printf() lines). So it looks like something with the pthread library. I'll futz around more with it--good task for a sick day.

Last fiddled with by wombatman on 2016-01-15 at 18:44
wombatman is offline   Reply With Quote