View Single Post
Old 2014-12-22, 03:29   #8
TheCount
 
TheCount's Avatar
 
Sep 2013
Perth, Au.

9810 Posts
Default

I tried gcwsievecl_1.0.2 without success.
GPU crashes when it starts sieving:
Code:
>gcwsievecl64.exe -v -C -W -b200 -B201 -n2 -t2 -N1e5 -P1e6
gcwsievecl v1.0.2, a GPU program to find factors of Cullen and Woodall numbers (n*b^n+c where b and n are fixed)
Quick elimination of terms info (in order of check):
99998 because the term is even
63411 because the term is divisible by a prime < 100
Platform 0 is an Advanced Micro Devices, Inc. AMD Accelerated Parallel Processing, version OpenCL 1.2 AMD-APP (1573.4)
Device 0 is an Advanced Micro Devices, Inc. Tahiti
workGroupSize = 409600 = 200 * 64 * 32 (blocks * workGroupSizeMultiple * deviceComputeUnits)
Running with 2 threads
Allocated memory (prior to sieving): 268 MB in CPU, 93 MB in GPU
Sieve started: (cmdline) 0 <= p < 1000000 with 36589 terms
I tried one thread and lower blocks but same issue.
Running Catalyst 14.9 with a 7970 AMD GPU.
Bug: Woodall formula in -h help incorrect.
Bug: -t1 says "Running with 1 threads", should be "Running with 1 thread".
Was able to compile with Visual Studio 2012 no problem.
Keen to use this app if it can be made to work.
TheCount is offline   Reply With Quote