View Single Post
Old 2021-08-28, 22:40   #24
Just call me Henry
henryzz's Avatar
Sep 2007
Liverpool (GMT/BST)

32×5×7×19 Posts

Originally Posted by WraithX View Post
What happens if you specify 0 for B2? Like this:
echo "(2^499-1)/20959" | ./ecm -gpu -cgbn -gpucurves 3584 -sigma 3:1000 20000 0
The same thing.

If I run less curves at once it works. Possibly just that my gpu is pathetic (750 Ti):
echo "(2^499-1)/20959" | ./ecm -gpu -cgbn -sigma 3:1000 20000
GMP-ECM 7.0.5-dev [configured with GMP 6.2.99, --enable-asm-redc, --enable-gpu, --enable-assert, --enable-openmp] [ECM]
Input number is (2^499-1)/20959 (146 digits)
Using B1=20000, B2=3804582, sigma=3:1000-3:1319 (320 curves)
Computing 320 Step 1 took 756ms of CPU time / 1269ms of GPU time
Computing 320 Step 2 on CPU took 7488ms

Last fiddled with by henryzz on 2021-08-28 at 22:42
henryzz is offline   Reply With Quote