View Single Post
Old 2010-06-06, 00:06   #11
gd_barnes
 
gd_barnes's Avatar
 
May 2007
Kansas; USA

3×7×487 Posts
Default

Port 9000 went down about 2-1/2 hours ago with a "Couldn't append to file (prpserver.log)" error message. It then said it has a "Segmentation fault".

But here is the weird part: The prpserver program is completely missing. It no longer exists at all! It's like it got deleted on the fly or something. When I tried to execute ./prpserver, it said "No such file or directory.".

Here is my solution:

1. It appears that the prpserver.log possibly got too large. So I'm renaming it like Max did with prpserver-0518.log. I will call it prpserver-0605.log. It was > 500 MB.

2. Copied the prpserver program over from another folder that contained PRPnet 3.2.6.

3. Restarted the server with ./prpserver.

Everything seems to be working now.

I'm sorry about the problems everyone.

Max, should we be renaming these prpserver.logs every once in a while or is there a way to make it quit writing out so many messages. These files are huge. I can't help but think writing so many messages to them actually caused the server to go down.

Karsten, I think Max gave you remote access to my machine now. Have you tried getting into it yet? If so, could you babysit it for a little while?

I'm going out to eat and to a movie now. I hope to be able to check it again in 4-5 hours.


Gary
gd_barnes is offline   Reply With Quote