View Single Post
Old 2020-05-12, 23:23   #182
ewmayer
2ω=0
 
ewmayer's Avatar
 
Sep 2002
Rep├║blica de California

2·5,693 Posts
Default

Update on the multi-GPU test-frame build is "finally getting somewhere", but that is preceded by a loud "oh dear lord". First to the latter...

So after the rigmarole of repacking mobo/cpu bundle #1 and returning to seller, bundle #2 - the dual-core-Celeron (sse2 only) cheapie, basically a very nice mobo with a minimal CPU - arrived late last week, I unpacked and assembled things and DLed the mobo manual over the weekend, then tried it out. Ruh-roh ... same issue as before - all the diagnostic LEDs indicate all is well, but no video-out signal. This mobo has onboard gfx, had first tried that, then installed one of the still-waiting-for-a-home Radeon VII trio I'd bought for this build. Still nothing. So at that point I start looking for bad video-out stuff of the 'wtf?' variety, and eventually found it in form of the little 6"-long vga-to-hdmi adapter cable I was using. Have used that for last several years to be able to connect to my wifi-less little Odroid C2 for Mlucas ARM builds, but had retired that system (except for future build-only purposes) a few months ago, and just pulled the adapter cable from it for use with the newer mobos which lack vga ports. To see if it might be the adapter, unboxed the Odroid and hooked up as before - no video signal. Tried using the monitor-attached vga cable with the hdmi adapater in my Haswell system (which has a vga port, i.e. normally uses just the vga cable) - no video signal. Somewhere between my final Odroid use and now, the little piece of sh*t just decided to stop functioning.

This is intensely irritating, to have such a basic, unpowered component simply go flaky from one day to the next, with no obvious signs of wear or damage, resulting in a multi-week delay and many hours of wasted time and frustration. Good grief.

Anyhow, moving forward, no use crying over spilled milk, water under the bridge, etc - gonna contact the seller of mobo #1, apologize and explain the cable issue, and offer to refund at least his return-shipping expense. Mobo #2 cost a bit less than #1, but further annoying in that the CPU is vastly inferior (#1 was 8-core Ryzen5 with avx2 support, #2 is 2-core Celeron with sse2, no avx-anything). But mybe better to not be tempted to use the CPU for GIMPS work, because in either case the watts-per-FLOP pales versus the expected R7 throughput.

So trying to install gpuOwl, hit a snag:
Code:
git clone https://github.com/preda/gpuowl && cd gpuowl && make
Cloning into 'gpuowl'...
remote: Enumerating objects: 107, done.
remote: Counting objects: 100% (107/107), done.
remote: Compressing objects: 100% (88/88), done.
remote: Total 5126 (delta 58), reused 41 (delta 19), pack-reused 5019
Receiving objects: 100% (5126/5126), 12.59 MiB | 7.08 MiB/s, done.
Resolving deltas: 100% (3684/3684), done.
./tools/expand.py < gpuowl.cl > gpuowl-expanded.cl
cat head.txt gpuowl-expanded.cl tail.txt > gpuowl-wrap.cpp
echo \"`git describe --long --dirty --always`\" > version.new
diff -q -N version.new version.inc >/dev/null || mv version.new version.inc
echo Version: `cat version.inc`
Version: "v6.11-278-ga39cc1a"
g++ -MT Pm1Plan.o -MMD -MP -MF .d/Pm1Plan.Td -Wall -O2 -std=c++17   -c -o Pm1Plan.o Pm1Plan.cpp
g++ -MT GmpUtil.o -MMD -MP -MF .d/GmpUtil.Td -Wall -O2 -std=c++17   -c -o GmpUtil.o GmpUtil.cpp
In file included from GmpUtil.cpp:3:
GmpUtil.h:6:10: fatal error: gmpxx.h: No such file or directory
    6 | #include <gmpxx.h>
      |          ^~~~~~~~~
compilation terminated.
make: *** [Makefile:30: GmpUtil.o] Error 1
I had previously tried to install GMP like so:
Code:
sudo apt install libgmp
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libgmp
Then did package-search on the Ubntu site, closest I found was libgmp10:
Code:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libgmp10 is already the newest version (2:6.1.2+dfsg-4).
0 upgraded, 0 newly installed, 0 to remove and 264 not upgraded.
Any clues as to the GMP-incompatibility issue welcome.

Last fiddled with by ewmayer on 2020-05-12 at 23:26
ewmayer is offline   Reply With Quote