mersenneforum.org

mersenneforum.org (https://www.mersenneforum.org/index.php)
-   NFS@Home (https://www.mersenneforum.org/forumdisplay.php?f=98)
-   -   mi64: inverse does not exist (https://www.mersenneforum.org/showthread.php?t=21278)

wreck 2016-05-08 05:24

mi64: inverse does not exist
 
In the process to log the progress of NFS@Home,
sometimes, I found some WU are lost,
and then I dig it more this day, and found,

[url]https://escatter11.fullerton.edu/nfs/result.php?resultid=59210837[/url]

[CODE]
<core_client_version>7.6.22</core_client_version>
<![CDATA[
<message>
Incorrect function.
(0x1) - exit code 1 (0x1)
</message>
<stderr_txt>
boinc initialized
work files resolved, now working
-> projects/escatter11.fullerton.edu_nfs/lasieve5f_1.11_windows_x86_64.exe
-> -a
-> -f
-> 4340260000
-> -c
-> 10000
-> -R
-> -o
-> ../../projects/escatter11.fullerton.edu_nfs/G2m1285_2_4340260_2_r1523667159_0
-> ../../projects/escatter11.fullerton.edu_nfs/G2m1285.poly
mi64: inverse does not exist
00:24:07 (5608): called boinc_finish

</stderr_txt>
]]>
[/CODE]

From,
[url]https://escatter11.fullerton.edu/nfs/workunit.php?wuid=51982403[/url]
This WU has been signed to 6 different computers, and got the same error,
with both Linux and Windows.

When searching the error information form source,
it seems like it come from
lasieve5-20081105\fbgen64.c
line 85 to 98,
[CODE]
/* uses same auxiliary variables as mm64 */
static u64_t mi64(u64_t x)
{
if (!mm64_init)
{
mpz_init(mm64_aux1);
mpz_init(mm64_aux2);
mm64_init=1;
}
mpz_set_ull(mm64_aux1,x);
mpz_set_ull(mm64_aux2,mod64);
if (!mpz_invert(mm64_aux1,mm64_aux1,mm64_aux2))
Schlendrian("mi64: inverse does not exist\n");
return mpz_get_ull(mm64_aux1);
}
[/CODE]

I have not enough knowledge or time to dig out the reason,
so I pop it out here to others.

ggnfs's source could found at
[url]http://mersenneforum.org/showpost.php?p=169889&postcount=28[/url]
[url]http://www.mersenneforum.org/showpost.php?p=333328&postcount=1[/url]

chris2be8 2016-05-08 15:44

A few questions that I hope might help lead someone to the answer:

What is the poly for that job?
What does the job file contain? (LPBA, MFBA, special-Q range etc).
Have any WUs for that job completed successfully? If so what special-Qs worked?

Chris


All times are UTC. The time now is 07:20.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.