mersenneforum.org

mersenneforum.org (https://www.mersenneforum.org/index.php)
-   Software (https://www.mersenneforum.org/forumdisplay.php?f=10)
-   -   mfaktc 0.21 - CUDA runtime wrong (https://www.mersenneforum.org/showthread.php?t=25847)

keisentraut 2020-08-17 12:46

mfaktc 0.21 - CUDA runtime wrong
 
I want to compile and run mfaktc 0.21 on my Arch Linux laptop. This has worked well until a few months ago, but now it doesn't, likely because of some upgrade which I didn't pay attention to....
I have a GeForce GTX 950M. It is only capable of doing around 130GHz days per day of factoring. Compute Capability is 5.0, the card is supported by CUDA toolkit 6.0-11.0. I have installed cuda package 11.0 from the Arch Linux official repository. I uncommented this line in the Makefile.
[CODE]
NVCCFLAGS += --generate-code arch=compute_50,code=sm_50 # CC 5.x GPUs will use this code
[/CODE]All of this has worked flawlessly until a few months ago, but now I get the following error message when I run mfaktc:
[CODE]CUDA version info binary compiled for CUDA 11.0
CUDA runtime version 32.66
CUDA driver version 11.0
ERROR: CUDA runtime version must match the CUDA toolkit version used during compile!
[/CODE]Why the heck is the CUDA runtime version 32.66? Version 32 does not even exist, does it?

kriesel 2020-08-17 15:52

Check the runtime is present with permissions set to allow access and the runtime's version matches the binary's version. When there's an issue it will give gibberish for version number.

Similar to[CODE]CUDA version info
binary compiled for CUDA 8.0
CUDA runtime version 8.0
CUDA driver version 9.20
[/CODE]

keisentraut 2020-08-18 07:03

Ok, so this was totally stupid, sorry for asking in the first place: I recently had to put kernel updates on hold because of some unrelated regression. This prevented the nvidia driver from loading and therefore, it didn't work. It was the gibberish version number which got me baffled and made me not look into the obvious things.


All times are UTC. The time now is 05:54.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.