mersenneforum.org

mersenneforum.org (https://www.mersenneforum.org/index.php)
-   YAFU (https://www.mersenneforum.org/forumdisplay.php?f=96)
-   -   YAFU 2.0 (https://www.mersenneforum.org/showthread.php?t=26681)

rogue 2021-08-25 21:42

[QUOTE=bsquared;586505]Yes it does, but while it seems to work for me, people have reported problems/crashes there as well.

Given the availability nowadays of WSL2 and a much better visual studio implementation as of v2.06, I am actually in the process of abandoning the mingw64/msys2 build option and code from yafu. All these different options are getting to be too much for me to maintain.[/QUOTE]

I think it is important to support other platforms. If interested I could build and test on OS X.

bsquared 2021-08-26 13:31

[QUOTE=rogue;586525]I think it is important to support other platforms. If interested I could build and test on OS X.[/QUOTE]

I just mean that I don't plan to keep building/testing on msys2 and won't be releasing any more windows executables that are produced by mingw64/msys2. I will always have a windows executable - it will just be produced by MSVC going forward. And WSL2 is another option running yafu on windows.

If you want to try to build and test on OS X please do! I will support you if I can. I've also had people express interest in getting yafu to run on apple's M1 arm-based processor. But with the heavy reliance on x86/x64 assembly code I have slim hopes of that working any time soon.

bsquared 2021-08-26 13:36

[QUOTE=BudgieJane;586520]
I would like to thank Ben for all his work so far, and would like to say thank-you in advance for future developments.[/QUOTE]

It's my pleasure, thank you. And please keep letting me know about issues; I may not always have an answer but it's how I learn. And nothing will get better if I don't know there is a problem.

rogue 2021-08-26 18:47

[QUOTE=bsquared;586551]I just mean that I don't plan to keep building/testing on msys2 and won't be releasing any more windows executables that are produced by mingw64/msys2. I will always have a windows executable - it will just be produced by MSVC going forward. And WSL2 is another option running yafu on windows.

If you want to try to build and test on OS X please do! I will support you if I can. I've also had people express interest in getting yafu to run on apple's M1 arm-based processor. But with the heavy reliance on x86/x64 assembly code I have slim hopes of that working any time soon.[/QUOTE]

What is the best way for me to contact you? PM? e-mail? Discord? Something else?

bsquared 2021-08-26 20:19

PM will work for now.

bur 2021-08-31 10:27

I have a problem with the output file yafu generates. It contains the input number and factors in the format:

(input#)/factor1/factor2/factor3

Apparently factordb is unable to read this format. It's not hard to change it to input#=factor1*factor2*factor3 which factordb can read, but I wonder if it's possible to have yafu output the factors in a different way?

Stargate38 2021-09-02 15:59

I can't get CUDA Poly selection to work.

[code]searching leading coefficients from 8942 to 9192
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
error: GPU sort engine not found at "C:\Numbers\aliqueit112\cub\sort_engine.dll"
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
error: GPU sort engine not found at "C:\Numbers\aliqueit112\cub\sort_engine.dll"
error: GPU sort engine not found at "C:\Numbers\aliqueit112\cub\sort_engine.dll"
error: GPU sort engine not found at "C:\Numbers\aliqueit112\cub\sort_engine.dll"
selected card has CUDA arch 7.5
error: GPU sort engine not found at "C:\Numbers\aliqueit112\cub\sort_engine.dll"
error: GPU sort engine not found at "C:\Numbers\aliqueit112\cub\sort_engine.dll"[/code]Anyone know where to get that Sort_engine.dll? I tried a version that I found on this forum, but YAFU gave me this:

[code]searching leading coefficients from 9442 to 9692
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
deadline: 8640000 CPU-seconds per coefficient
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
selected card has CUDA arch 7.5
deadline: 8640000 CPU-seconds per coefficient
deadline: 8640000 CPU-seconds per coefficient
deadline: 8640000 CPU-seconds per coefficient
deadline: 8640000 CPU-seconds per coefficient
deadline: 8640000 CPU-seconds per coefficient
deadline: 8640000 CPU-seconds per coefficient
deadline: 8640000 CPU-seconds per coefficient
error (line 1128): CUDA_ERROR_FILE_NOT_FOUND
error (line 1128): CUDA_ERROR_FILE_NOT_FOUND[/code]YAFU Info:

[code]YAFU Version 2.06
Built with Microsoft Visual C/C++ 1929
Using GMP-ECM 7.0.5-dev, Powered by MPIR 3.0.0
Detected Intel(R) Core(TM) i5-9300H CPU @ 2.40GHz
Detected L1 = 32768 bytes, L2 = 8388608 bytes, CL = 64 bytes
Using 1 random witness for Rabin-Miller PRP checks
Cached 664579 primes; max prime is 9999991[/code]Number I'm trying to factor:

[code]48459122254139394182129172328473262875134312328758582582515084646652819439706917682551935490060136608549891[/code]

Anyone know what file is missing when it says "CUDA_ERROR_FILE_NOT_FOUND"? I think error messages should be made more specific/verbose.

Brian Gladman 2021-09-02 17:06

[QUOTE=Stargate38;587072]I can't get CUDA Poly selection to work.

Anyone know what file is missing when it says "CUDA_ERROR_FILE_NOT_FOUND"? I think error messages should be made more specific/verbose.[/QUOTE]

I think the msieve sort engine is missing, here is a link to a zip file containing it:

[url]https://drive.google.com/file/d/1wGhHGffiuVS6u04N-JEfRvuBDOSzujmN/view?usp=sharing[/url]

I assume that the directory 'cub' containing sort_engine.dll has to be in the directory holding the yafu executable file.

Plutie 2021-09-02 17:08

[QUOTE=Stargate38;587072]I can't get CUDA Poly selection to work.

[code]searching leading coefficients from 8942 to 9192
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
error: GPU sort engine not found at "C:\Numbers\aliqueit112\cub\sort_engine.dll"
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
error: GPU sort engine not found at "C:\Numbers\aliqueit112\cub\sort_engine.dll"
error: GPU sort engine not found at "C:\Numbers\aliqueit112\cub\sort_engine.dll"
error: GPU sort engine not found at "C:\Numbers\aliqueit112\cub\sort_engine.dll"
selected card has CUDA arch 7.5
error: GPU sort engine not found at "C:\Numbers\aliqueit112\cub\sort_engine.dll"
error: GPU sort engine not found at "C:\Numbers\aliqueit112\cub\sort_engine.dll"[/code]Anyone know where to get that Sort_engine.dll? I tried a version that I found on this forum, but YAFU gave me this:

[code]searching leading coefficients from 9442 to 9692
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
deadline: 8640000 CPU-seconds per coefficient
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
using GPU 0 (NVIDIA GeForce GTX 1650)
selected card has CUDA arch 7.5
selected card has CUDA arch 7.5
deadline: 8640000 CPU-seconds per coefficient
deadline: 8640000 CPU-seconds per coefficient
deadline: 8640000 CPU-seconds per coefficient
deadline: 8640000 CPU-seconds per coefficient
deadline: 8640000 CPU-seconds per coefficient
deadline: 8640000 CPU-seconds per coefficient
deadline: 8640000 CPU-seconds per coefficient
error (line 1128): CUDA_ERROR_FILE_NOT_FOUND
error (line 1128): CUDA_ERROR_FILE_NOT_FOUND[/code]YAFU Info:

[code]YAFU Version 2.06
Built with Microsoft Visual C/C++ 1929
Using GMP-ECM 7.0.5-dev, Powered by MPIR 3.0.0
Detected Intel(R) Core(TM) i5-9300H CPU @ 2.40GHz
Detected L1 = 32768 bytes, L2 = 8388608 bytes, CL = 64 bytes
Using 1 random witness for Rabin-Miller PRP checks
Cached 664579 primes; max prime is 9999991[/code]Number I'm trying to factor:

[code]48459122254139394182129172328473262875134312328758582582515084646652819439706917682551935490060136608549891[/code]

Anyone know what file is missing when it says "CUDA_ERROR_FILE_NOT_FOUND"? I think error messages should be made more specific/verbose.[/QUOTE]

Which version of msieve are you using? I would recommend you download the updated source code from [url]https://sourceforge.net/p/msieve/code/HEAD/tree/trunk/[/url] and build it yourself from the build.cuda.vs directory.

Edit: This is more of something you should attempt if the solution above from Brian Gladman doesn't work for you.

Stargate38 2021-09-02 18:12

I'm using the most recent YAFU 2.x executable (from BSquared's GitHub), with internal poly selection. Brian Gladman's solution didn't work completely (still getting "error (line 1128): CUDA_ERROR_FILE_NOT_FOUND").

EDIT: I redownloaded YAFU from the GitHub repo, and it's working now. Must've downloaded the version that BudgieJane attached on post #196.

bsquared 2021-09-02 18:35

[QUOTE=Stargate38;587088]I'm using the most recent YAFU 2.x executable (from BSquared's GitHub), with internal poly selection. Brian Gladman's solution didn't work completely (still getting "error (line 1128): CUDA_ERROR_FILE_NOT_FOUND").

EDIT: I redownloaded YAFU from the GitHub repo, and it's working now. Must've downloaded the version that BudgieJane attached on post #196.[/QUOTE]

I think CUDA_ERROR_FILE_NOT_FOUND refers to the stage1_core_sm**.ptx file; it is supposed to be next to the executable. The sort_engine.dll file should be in a directory called cub beneath the executable.


All times are UTC. The time now is 14:57.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.