-   kriesel (
-   -   drafts in progress, comments would probably be premature (

kriesel 2019-07-15 16:26

drafts in progress, comments would probably be premature
(whatever I happen to be writing at the moment, or thinking about doing later)

Please wait.
Your understanding, patience, and cooperation will be appreciated.
And it may save you some time.

Please do not post here. Posts by others in this thread will be moved or deleted without warning or recourse.
Constructive posts are welcome in the discussion threads, identified with [COLOR=Green][I][B]bold [/B][/I][I][B]green italic text[/B][/I][/COLOR] in the site-map/table of contents (link below).

Top of reference tree: [URL=""][/URL]

kriesel 2019-12-19 16:41

Gpu memory requirements for PRP versus exponent
Gpu memory requirements for P-1 versus exponent

Top of reference tree: [URL=""][/URL]

kriesel 2020-01-25 15:23

Starfish reference thread
Starfish is likely to be closed source, as a precaution against certain features being modified to create a DoS tool.

Top of reference tree: [URL=""][/URL]

kriesel 2020-01-25 15:25

Starfish discussion thread
This is the place to discuss the Starfish software, propose new features, ask questions you haven't been able to figure out on your own after making some effort, etc.

Top of reference tree: [URL=""][/URL]

kriesel 2020-05-01 21:05

links, test comments, etc

Test environment:

kriesel 2020-05-01 21:06

Wagstaff numbers
tf, primality testing, links etc.

kriesel 2020-06-10 23:50

Updated set of FAQs?

kriesel 2020-07-23 17:04

Xeon phi
[B]Knight's Corner PCIe 7120A Coprocessor[/B]

[B] Software Setup[/B]
Because it's a coprocessor with its own RAM and OS, installation and setup involves two inherently differing operating systems (coprocessor uOS and host Linux or Windows) and communication between them. This arrangement is discussed in the [URL=""]Puget Systems online articles[/URL]. [URL][/URL]

I chose to initially install mine on an active PCIe extender, in a system with an Asrock BTC Pro motherboard and i7-4790 cpu, and plenty of power. (An error, as we'll see later.)
First attempt, Asrock; partitioned drive for Windows 10, FAT32 commons area, Linux; installed Windows 10 first; Ubuntu later; then install onto Ubuntu and use [URL=""]GRUB Customizer[/URL] to put Windows 10 as default boot to accommodate my usual use)
I was pleasantly surprised to see Ubuntu recognize and make sense of the Windows NTFS partition.

(MPSS download, unzip, install)

This system had plenty of power to run the card, but after progressing through the MPSS install process, I ran into "not enough resources", checked the BIOS settings, and found it had no way to set >4GB addressing for PCI/PCIe. I remembered setting exactly that in preparation for card installation but apparently it had been done to some other system. Dead end for this attempt. Maybe useful practice up to that point.

Second attempt, Lenovo D30 with Windows 10 already installed. Evict an RX550 to free up space. This system had had a Radeon VII installed before and has a ~KW power supply. The physical installation of the 7120A is a very tight fit though.
Install MPSS after Cygwin and doing ssh-keygen.
Was able to get various mic utilities to run, display coprocessor status, etc.

Before I got back to it, the system crashed with stop code 116. So not sure if I recorded all the relevant installation process & messages.

The coprocessor should be able to run Linux GIMPS cpu applications such as Mlucas, mprime, Mfactor, subject to the limits of on-card RAM size.


ssh/login issues / setup [URL][/URL]
Similar issue on the coprocessor. Sorting that out should prove interesting.
Meanwhile it's been removed to free the slot and power for use of a fast gpu.

(add photos)

[B]Knight's Landing as cpu on SuperMicro K1SPE motherboard[/B]
Taking advantage of an eBay listing for a [URL=""]7210[/URL] bare bones system found on eBay, I placed an order ($499 US plus taxes & shipping) before alerting Ernst and the rest of GIMPS to the opportunity. The system received was a 7250 Xeon Phi with large radiator, liquid loop, no DRAM, no OS, no HD, and unexpectedly no power cord. The front power switch was not connected. Motherboard info is [URL=""]here[/URL]. [URL][/URL] It's a different style case, but the following has a lot of info on the K1SPE MB and BIOS [URL=""][/URL]. Motherboard related downloads are at [URL];[/URL] enter K1SPE as motherboard model.
It includes [URL=""]IPMI[/URL] among its features. Haven't tried using that yet. SuperMicro's [URL=""]downloads[/URL] related to IPMI might be useful for such an attempt. Windows IPMI support [URL][/URL]
From the Linux perspective, [URL][/URL]
And there's also this cautionary tale [URL][/URL]

I chose to set up for dual boot from the start; install and partition the boot drive as part of first OS install.

Installed Windows 10 Pro x64 from USB DVD drive, then did successive updates until current. The DVD version of Windows I had recognized 28 of the real cores, ~1.8MB of L1 cache, 14MB of the L2 cache, 16GB MCDRAM. Prime95 v30.3b6 run attempts crashed before even appearing on the monitor. If curious about the details, see [URL=""]this post[/URL] and its attached image. [URL];[/URL] CPU-Z capture [URL=""]here;[/URL]

Updating Windows 10 to v1909 brought recognition of all the processor's cores, all 4.3MB of L1 cache, all 34MB of L2 cache and 16GB MCDRAM, and effortless running of prime95 V30.3b6. (More about that [URL=""]here[/URL].) [URL][/URL] Defaulting to dozens of workers with 4 cores each was not what I would have chosen. It's nearly optimal for aggregate throughput, but latency for the current GIMPS 100M wavefront could be a problem. I switched it later to 4 workers. That change sped getting enough successful double checks done to allow assignments at lower GIMPS assignment category numbers.
Benchmarking with hyperthreading in prime95 does x2, x3, and x4 HT, which are almost always progressively slower. (More detail at [URL][/URL] and its following post.) Benchmark results in second attachment of [URL=""]this post[/URL]. [URL][/URL]
It commonly runs prime95 or prime95+Mfactor at above the nominal clock rate, sometimes at full turbo rate or even above. (With the motherboard-top side cover off.) While preparing this I checked clock rate, and was surprised to see 0.00 GHz displayed occasionally by Task Manager, 1.49 GHz otherwise.

I've also run Mfactor on it.

Haven't gotten around to installing Linux in the other drive partition yet. I had planned to also put Ubuntu on it, but after reading Ernst Mayer's experience attempting Linux installs, beginning at [URL][/URL], Ernst's experience suggests the full CentOS image and a wired NIC is the way to go for Linux on this type system. [URL=""]This post[/URL] reiterates Intel's statements on OS compatibility.

This system has been very problematic for getting through POST and a boot. One morning it took 45 minutes and many attempts to POST, completing boot on the second time it reached any sign of Windows starting. It had always failed on the consecutive few previous days when I was less persistent.
It also seems VERY sensitive to being tilted or touched while running, or even stepping on the LAN cable that lies on some carpet. These actions produce a red HDD light on the motherboard and all function ceases, until a power cycle, POST and boot succeed. Supermicro first level tech support did not have much to say about that.

An attempt at a WSL2 install was a bust. The cpu lacks some required virtualization support, or I missed some BIOS setting or Windows installation choice to enable its support. The Intel [URL=""]spec sheet[/URL] for the 7250 says no VT-x or VT-d support. There are several other quite large "datasheets" available for the Xeon Phi x200:

Datasheet Volume 1, Electrical (147 pages) [URL][/URL]

Datasheet Volume 2, Registers (378 pages) [URL][/URL]

Thermal/Mechanical Specification and Design Guide (114 pages) [URL][/URL]

Specification Update (19 pages) [URL][/URL]

Some observations and possible BIOS tweaks later are in [URL=""]this post. [/URL][URL][/URL]
Also, configure BIOS power-returns setting at the FIRST opportunity, from "Last State" to "Power On". See posts [URL=""]73[/URL] and [URL=""]74[/URL] of the Xeon Phi forum thread for why.

The high core count (68 on a 7250) is too much for some Windows utilities for checking core loads or temperatures. See [URL][/URL]

An attempt to add both a 64GB DIMM and an RX550 low profile gpu worked only in the mechanical sense. There was just enough space to maneuver the gpu into installation position under the coolant lines that pass over the PCIe slots, only into the slot nearest the cpu. All 10+ attempts to start failed, by instant illumination of the HDD LED red on the motherboard, with no POST progress or video signal produced. The power and reset switches connecting to the motherboard are ineffectual after that LED lights; the power must be cut externally to try again.

Removal of the gpu but leaving the DIMM in place in slot A eventually produced a successful POST and boot after many tries. The system crashed about an hour later. A second boot ran overnight and continued until shutdown, >12 hours. Prime95 operation was drastically slowed however; two of 4 workers running primality tests show 40+ TIMES the previous iteration time, and one shows 80+ TIMES; there's no comparison data for the fourth which was running P-1 factoring. Windows Task Manager is confused, showing 234 cores and similarly but not quite proportionally overstated cache amounts. The logical processor count was correct.

Which memory mode the system ran on is unknown, but it appears to be flat mode or hybrid, since Windows 10 Task Manager reported 80GB in 9 occupied out of 14 slots; 16GB of MCDRAM occupies 8 nominal slots, and the 6 DIMM slots have only A occupied, with a 64GB DIMM. Cache amounts were increased also. I saw nowhere in the BIOS portion of the manual to select memory mode. Since the DRAM's presence was devastating to performance, it was removed and returned for a refund.

More recently, I found the following in the specification update:
"[FONT=sans-serif]KNL25.[/FONT][FONT=sans-serif]Operating With DDR4-2400 Memo[/FONT][FONT=sans-serif]ry May Cause Unpredictable System [/FONT][FONT=sans-serif]Behavior[/FONT]
[FONT=sans-serif]Problem:[/FONT][FONT=sans-serif]Operating the processor with DDR4 memory [/FONT][FONT=sans-serif]configured to operate at 2400 MT/s may[/FONT][FONT=sans-serif] cause unpredictable system behavior.[/FONT]
[FONT=sans-serif]Implication:[/FONT][FONT=sans-serif]When the erratum occurs, the system will exhibit unpredictable system behavior.[/FONT]
[FONT=sans-serif]Workaround:[/FONT][FONT=sans-serif]It is possible for BIOS to contain a workaround for this erratum.[/FONT]
[FONT=sans-serif]Status:[/FONT][FONT=sans-serif]No Fix[/FONT][FONT=sans-serif]"[/FONT]

There are multiple indications the hardware does not support DIMMS larger than 64GB each. SuperMicro's web pages list DIMM product numbers up to 32GB DIMM or 64GB LRDIMM as possible types to install, but nothing larger. Intel's cpu specifications for the [URL=""]7210[/URL] or [URL=""]7250[/URL] indicate maximum addressable memory 384GB consistent with 64GB DIMM as the maximum size in the 6 DIMM slots. Page 12 of the [URL=""]datasheet volume 1[/URL] says "Six DDR4 channels, each channel limited to one DIMM per channel (max. DIMM capacity is 64 GB), 384 GB capacity total."

There's also a considerable cost premium currently per GB with higher density; 32GB are about $125 ($4/GB); 64GB LRDIMM ~$300 each ($4.7/GB); 128GB ~$1000 each ($7.8/GB) or higher each. DIMM memory provides much lower bandwidth than the MCDRAM. Fully popuplating the slots would probably help. Even at 32GB DIMM prices that costs more than the base unit.

Updating to Windows 10 Pro v20H2 is slow and is completed.

The same RX550 that seemingly caused boot problems in the 7250 system was successfully installed and operating in a 7210 system on the same motherboard type. I may give 32GB DIMM(s) a try in the 7210 someday.

(For more background, see the Xeon Phi discussion [URL=""]thread[/URL] in the hardware subforum) [URL][/URL]

kriesel 2020-08-24 04:11

History and evolution of Mersenne prime searching
Antiquity (discovery of Mersenne primes, early methods of finding them etc)
Early interest as a result of relationship to perfect numbers N=2[SUP]n-1[/SUP] (2[SUP]n[/SUP] - 1)

Precomputer (Euler enhanced trial division; Lucas test; Lehmer)

Mersenne and Fermat Numbers, Raphael Robinson [URL][/URL]

Prime95 TF, LL, LLDC. Addition of ECM, P-1. Change from database & emailed assignment blocks, to PrimeNet API internet auto and manual assignents and reporting

Curtis Cooper slides on finding Mp43 [URL][/URL]


Recent developments (lots of them!)
Jacobi check; PRP with GEC; PRP proof of work and correctness; attempts to use squarings for both PRP and P-1; P-1 error correction;

Cloud computing

Future prospects

kriesel 2020-10-07 06:28

installing version upgrades
A post for each app? May be easier for users to find if in each app's specific reference thread. see prime95 for an example

kriesel 2020-10-12 22:18

Something about ecm memory and time scaling in prime95

All times are UTC. The time now is 20:34.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.