mersenneforum.org

mersenneforum.org (https://www.mersenneforum.org/index.php)
-   GMP-ECM (https://www.mersenneforum.org/forumdisplay.php?f=55)
-   -   GMP-ECM with --enable-openmp flag set in configure = bad results? (https://www.mersenneforum.org/showthread.php?t=21660)

GP2 2016-10-16 01:35

GMP-ECM with --enable-openmp flag set in configure = bad results?
 
1 Attachment(s)
In the README file for GMP-ECM, it mentions using the possibility of using the --enable-openmp flag with the configure command. This enables multithreading and greater parallelism in stage 2.

I ran configure with this flag and compiled 7.0.4, and "make check" indicated the tests were passed. However, when I tried testing it, it missed a P-1 factor it should have found.

First I ran:

[CODE]echo "[URL="http://www.mersenne.ca/exponent/20173"]2^20173-1[/URL]" | ./ecm -pm1 -save toto.txt 50e6 50e6[/CODE]

which finds the composite factor 237664504975279983867404174809 = 121039 * 525947712473 * 3733330406447, which are the first three factors of M20173 (2,20173−)

Then I ran:

[CODE]./ecm -resume toto.txt 50e6 150e6[/CODE]

This choice of B1 and B2 should find the fourth factor
242259284775981115080842803960207
= 2kp + 1, k = 3 × 449773 × 628373 × 49835969 × 142103537

However, ecm-7.0.4 configured with --enable-openmp does not find this fourth factor, whereas ecm-7.0.3 configured without --enable-openmp does find it.

This was using gcc 4.8 on Linux, which presumably implies support of OpenMP 3.1, which are both somewhat outdated versions, but these are standard on Amazon Linux.

The save file toto.txt is included as an attachment. The second command above (stage 2) takes only a few seconds to complete.

Is there any more extensive test suite for gmp-ecm beyond what is provided by "make check" ?

xilman 2016-10-16 06:24

[QUOTE=GP2;445140]In the README file for GMP-ECM, it mentions using the possibility of using the --enable-openmp flag with the configure command. This enables multithreading and greater parallelism in stage 2.

I ran configure with this flag and compiled 7.0.4, and "make check" indicated the tests were passed. However, when I tried testing it, it missed a P-1 factor it should have found.
...

Is there any more extensive test suite for gmp-ecm beyond what is provided by "make check" ?[/QUOTE]I suggest that you raise this question with the dev team. They are much more likely to give you a definitive and/or helpful answer than the folk here.

GP2 2016-10-16 08:51

[QUOTE=xilman;445150]I suggest that you raise this question with the dev team. They are much more likely to give you a definitive and/or helpful answer than the folk here.[/QUOTE]

One reason I posted here was to warn other users or get feedback about whether anyone else has tried to enable OpenMP, and also providing a very simple test case that can be checked in a few seconds.

xilman 2016-10-16 10:21

[QUOTE=GP2;445152]One reason I posted here was to warn other users or get feedback about whether anyone else has tried to enable OpenMP, and also providing a very simple test case that can be checked in a few seconds.[/QUOTE]Good point, and a useful contribution. Nonetheless you should mail [email]ecm-discuss@lists.gforge.inria.fr[/email] so that a much wider audience learns about the issue and so that a fix can be prepared.


All times are UTC. The time now is 02:04.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.