mersenneforum.org

mersenneforum.org (https://www.mersenneforum.org/index.php)
-   Software (https://www.mersenneforum.org/forumdisplay.php?f=10)
-   -   Early Beta of version 24.11 (https://www.mersenneforum.org/showthread.php?t=3934)

Peter Nelson 2005-04-20 23:22

I have tried the latest files on Windows and Linux. As for my earlier post about the static linux build not producing benmarks of factoring, this new version/build has fixed it and benchmarking works fine.

I notice that on Linux the version in About is 24.11.2 whilst I expected the 2 to change to a 3 or something. Additionally when results go in logfile etc I think the version is only reported as the first two numbers and omit the third. Certainly this is the case in Windows Help About.

Just a suggestion but could you treat the third number as a kind of build/release number (ie it changes every time) and arrange for it to be used at all times?

This would help us know which machines have which of the 3 (so far) released versions of 24.11 and provide proper comparison of benchmarks (since efficiency alters with changes) and help bug reports be attributed to the right build.

PhilF 2005-04-20 23:46

As long as we're talking about program improvements, what would be handy for me is a way to specify the path where the 2nd backup file is stored. That way I can keep one on the local drive and one on a network drive, both being constantly updated.

db597 2005-04-21 16:03

[QUOTE=PhilF]As long as we're talking about program improvements, what would be handy for me is a way to specify the path where the 2nd backup file is stored. That way I can keep one on the local drive and one on a network drive, both being constantly updated.[/QUOTE]

That would be a nice feature. Also, if one hardisk crashes, with the backup in the same directory, everything is still lost.

ric 2005-04-22 07:06

Communication issue with the latest beta (Error 1)
 
I'm reporting a small communication issue related to the latest 24.11 beta: when communicating behind a proxy server, I always have Primenet Error 1 as response.

The issue does not arise in the same 24.11 when I communicate without a proxy (i.e. via direct dialup), and is not related to some misconfigured element: the same machine communicates successfully via the same proxy configuration (primenet.ini, and so on) if I only restore version 24.6. I've also tried to regenerate the masked password (just in case) via ProxyMask, to no result.

Did anybody else experience the same behaviour?
ric

PS: environment is WinXP Prof Ed SP1 on a 2Ghz Compaq Evo, non-influent firewall local software (ISS Desktop Protector v7.0, Kerio PF 4)

Prime95 2005-04-22 13:04

[QUOTE=ric]I'm reporting a small communication issue related to the latest 24.11 beta: when communicating behind a proxy server, I always have Primenet Error 1 as response. [/QUOTE]

Please try putting "SendPortNumber=1" in primenet.ini. Then let me know if that helps or not.

ric 2005-04-22 13:21

Yes, now it works nicely via proxy.
 
Did as per your recommendation, restarted, now it communicates nicely via proxy - haven't tried yet the dialup (=no proxy), but it's not urgent.

One last small question: I've browsed rapidly the documentation, but I haven't found any reference to this SendPortNumber parameter. Is this intentional?

George, many thanks again for your recommendation.
ric

eldel 2005-04-22 15:58

Tried it here - still getting Primenet Error 1.

Opteron running W2K3 Enterprise x64 Edition build 3790 with SP1.

Derek

eldel 2005-04-22 17:02

However - a complete stop and restart (reboot the machine) caused it to work. Thanks to ric for the idea.

Prime95 2005-04-22 22:40

SendPortNumber is brand new --- unfortunately.

A user reported that his proxy server did not work because of the ":80" in "http://mersenne.org:80/blahblah" sent by prime95.

So, since the :80 in theory is superfluous, I removed it. But, I added this SendPortNumber ini setting in case some proxy server required the :80.

Alas, we've now proven that some proxy servers require the :80 and some fail with the :80. It's just nuts.

So, I'll make sending the :80 the default (same as all previous versions of prime95) and add a description of SendPortNumber to undoc.txt.

Xyzzy 2005-04-23 02:29

Windows Server 2003 Enterprise x64 Edition

[code]AMD Athlon(tm) 64 Processor 3400+
CPU speed: 2402.97 MHz
CPU features: RDTSC, CMOV, Prefetch, 3DNow!, MMX, SSE, SSE2
L1 cache size: 64 KB
L2 cache size: 512 KB
L1 cache line size: 64 bytes
L2 cache line size: 64 bytes
L1 TLBS: 32
L2 TLBS: 512
Prime95 version 24.11, RdtscTiming=1
Best time for 512K FFT length: 23.648 ms.
Best time for 640K FFT length: 27.952 ms.
Best time for 768K FFT length: 33.717 ms.
Best time for 896K FFT length: 40.733 ms.
Best time for 1024K FFT length: 45.252 ms.
Best time for 1280K FFT length: 60.393 ms.
Best time for 1536K FFT length: 73.928 ms.
Best time for 1792K FFT length: 89.212 ms.
Best time for 2048K FFT length: 99.531 ms.
Best time for 58 bit trial factors: 3.154 ms.
Best time for 59 bit trial factors: 3.160 ms.
Best time for 60 bit trial factors: 3.368 ms.
Best time for 61 bit trial factors: 3.451 ms.
Best time for 62 bit trial factors: 4.038 ms.
Best time for 63 bit trial factors: 4.706 ms.
Best time for 64 bit trial factors: 5.677 ms.
Best time for 65 bit trial factors: 6.666 ms.
Best time for 66 bit trial factors: 6.631 ms.
Best time for 67 bit trial factors: 6.627 ms.[/code]

Xyzzy 2005-04-23 13:14

1 Attachment(s)
If I add this to the top of my worktodo.ini I get an immediate crash...

[code]ECM=791,11000000,0,736,0,0,1,0[/code]Right now it is at the end of my worktodo.ini and it hasn't crashed... The status button shows everything okay...


All times are UTC. The time now is 08:23.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.