mersenneforum.org

mersenneforum.org (https://www.mersenneforum.org/index.php)
-   Information & Answers (https://www.mersenneforum.org/forumdisplay.php?f=38)
-   -   [Comm thread May 4 09:22] ERROR: Unable to open spool file. (https://www.mersenneforum.org/showthread.php?t=26767)

drkirkby 2021-05-04 15:21

I submitted the results manually, using the results.json.txt file. That reports the familiar fact that it is not prime. But there's no option to upload the proof file. So if someone can tell me how I can upload a proof file, I will do so. If need be I can put it on a webserver, and someone download it from there.



Dave

paulunderwood 2021-05-04 15:36

[QUOTE=drkirkby;577627]I submitted the results manually, using the results.json.txt file. That reports the familiar fact that it is not prime. But there's no option to upload the proof file. So if someone can tell me how I can upload a proof file, I will do so. If need be I can put it on a webserver, and someone download it from there.
[/QUOTE]

gpuOwl comes with a file called [URL="https://github.com/preda/gpuowl/blob/master/tools/upload.py"]upload.py[/URL] which I use like this

./upload.py PaulUnderwood <blah>.proof

mprime should do the upload automatically given a communication.

drkirkby 2021-05-04 18:36

[QUOTE=paulunderwood;577628]gpuOwl comes with a file called [URL="https://github.com/preda/gpuowl/blob/master/tools/upload.py"]upload.py[/URL] which I use like this

./upload.py PaulUnderwood <blah>.proof

mprime should do the upload automatically given a communication.[/QUOTE] I was going to use your python script, but I see the file has now gone from the disk, so I assume the proof got uploaded.
I'm still getting this error about being unable to open a spool file when mprime starts.
[CODE][Comm thread May 4 19:27] ERROR: Unable to open spool file.[/CODE]
However, if I start mprime as root, I don't get the error. Very odd. A permissions problem somewhere, but nothing in the directory is owned by root.
Dave

paulunderwood 2021-05-04 18:44

[url]https://www.mersenne.org/report_exponent/?exp_lo=110826539&full=1[/url] now shows "verified" :smile:

I can only reiterate that you run [C]ls -laR | grep root[/C] in your mprime directory.

drkirkby 2021-05-04 19:46

[QUOTE=paulunderwood;577643][URL]https://www.mersenne.org/report_exponent/?exp_lo=110826539&full=1[/URL] now shows "verified" :smile:

I can only reiterate that you run [C]ls -laR | grep root[/C] in your mprime directory.[/QUOTE]It is not something in the directory containing the files for gimps. Everything in there is own by me. Obviously if I run the program is root, some of the files become owned by root, but I changed the ownership back. I don't know if the program is trying to write to /var/spool or something like that. The permissions on the directory don't allow that.


All times are UTC. The time now is 02:07.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.