mersenneforum.org

mersenneforum.org (https://www.mersenneforum.org/index.php)
-   YAFU (https://www.mersenneforum.org/forumdisplay.php?f=96)
-   -   YAFU 2.0 (https://www.mersenneforum.org/showthread.php?t=26681)

James Heinrich 2021-09-24 13:30

1 Attachment(s)
NFS screen output shows up ugly under Win10, see attached. Something about mangled CRLF I guess?

Stargate38 2021-09-24 21:50

1 Attachment(s)
I've had that happen too. It must be a bug in YAFU, as it doesn't happen in other command line software.

James Heinrich 2021-09-25 12:41

Would it be possible to have YAFU (optionally) output to factor.log a partial-progress report on ECM, either after every <1000> curves, or better would be if no output to factor.log has happened in the last <60> minutes. It would be useful (to me anyways) to both easily check progress on a remote machine and provide some fallback in the event of power failure or similar.

BudgieJane 2021-09-26 10:29

[QUOTE=bsquared;588423]
The freq is unused, I think tune just assigns it the value '42' for now. Because, reasons.[/QUOTE]

According to Douglas Adams, 42 is the answer to the meaning of life, the universe, and everything. Maybe they are the reasons?

James Heinrich 2021-09-26 19:25

Is there somewhere a complete-idiot's-guide (i.e. Windows user) to getting YAFU2 compiled and working on linux (CentOS 8 in my case) ?

EdH 2021-09-26 20:08

[QUOTE=James Heinrich;588761]Is there somewhere a complete-idiot's-guide (i.e. Windows user) to getting YAFU2 compiled and working on linux (CentOS 8 in my case) ?[/QUOTE]Have you looked at my "[URL="https://www.mersenneforum.org/showthread.php?t=26764"]How I install YAFU2 onto my Ubuntu Machines[/URL]" to see if it might help? It does not go into the details of using all the options, but it may be a place to start.

henryzz 2021-09-26 20:09

[QUOTE=James Heinrich;588761]Is there somewhere a complete-idiot's-guide (i.e. Windows user) to getting YAFU2 compiled and working on linux (CentOS 8 in my case) ?[/QUOTE]


Written for an older version but [url]https://mersenneforum.org/showthread.php?t=23087[/url] should be useful. Any differences to this probably should be added (in an appendix if they don't affect Ubuntu).

BudgieJane 2021-09-26 20:39

I just updated tune_info for yafu 2.07 in my yafu.ini file

[CODE]
tune_info=Intel(R) Core(TM) i7-4710MQ CPU @ 2.50GHz,WIN64,8.66985e-06,0.221065,19.753,0.0695336,96.607,42[/CODE]
and then ran yafu 2.07 on a small number. Imagine my surprise when this turned up on the screen:
[CODE]
fac: check tune params contained invalid parameter(s), ignoring tune info.
qs_mult = 0.000000e+00
qs_exp = 0.000000e+00
qs_freq = 0.000000e+00
nfs_mult = 0.000000e+00
nfs_exp = 0.000000e+00
nfs_freq = 0.000000e+00[/CODE]
This seems strange when yafu claims that the parameters that it itself wrote to my yafu.ini file not 15 minutes earlier are invalid.
What's occurring?

EdH 2021-09-26 22:27

[QUOTE=henryzz;588765]Written for an older version but [URL]https://mersenneforum.org/showthread.php?t=23087[/URL] should be useful. Any differences to this probably should be added (in an appendix if they don't affect Ubuntu).[/QUOTE]I've done a separate one for YAFU2. See the previous post I got in just before yours, so you missed it. Thanks for the mention.

EdH 2021-09-26 22:33

[QUOTE=BudgieJane;588767]I just updated tune_info for yafu 2.07 in my yafu.ini file
. . .
and then ran yafu 2.07 on a small number. Imagine my surprise when this turned up on the screen:
. . .

[This seems strange when yafu claims that the parameters that it itself wrote to my yafu.ini file not 15 minutes earlier are invalid.
What's occurring?[/QUOTE]Try another "git pull." I think the earlier one I was experiencing this with, was also 2.07, but it was an earlier commit. My latest pull has been working fine with its new tune_info.

BudgieJane 2021-09-27 09:21

[QUOTE=EdH;588779]Try another "git pull." I think the earlier one I was experiencing this with, was also 2.07, but it was an earlier commit. My latest pull has been working fine with its new tune_info.[/QUOTE]

Thanks for the hint. I downloaded the executable, then ran tune again. No change.


All times are UTC. The time now is 04:36.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.