mersenneforum.org

mersenneforum.org (https://www.mersenneforum.org/index.php)
-   YAFU (https://www.mersenneforum.org/forumdisplay.php?f=96)
-   -   YAFU 2.0 (https://www.mersenneforum.org/showthread.php?t=26681)

James Heinrich 2021-08-24 13:01

3 Attachment(s)
[QUOTE=BudgieJane;586247]I'm having problems with version 2.06. It works OK on my new computer, running Windows 10 Pro, but it will not run on my old ones running Windows 7 Pro. It puts up the welcome message, waits something like half a minute, then quietly returns me to the command prompt[/QUOTE]I also just tried v2.06 (from [url=https://github.com/bbuhrow/yafu/archive/refs/heads/master.zip]master.zip[/url] downloaded an hour ago) on my i7-3930K on Win7pro64 where [c]yafu-x64.exe[/c] also fails. The first time I ran it it took a few (maybe 5) seconds before the crash dialog came up, subsquent runs in comes up near-immediately:[code]Problem signature:
Problem Event Name: APPCRASH
Application Name: yafu-x64.exe
Application Version: 0.0.0.0
Application Timestamp: 611c3335
Fault Module Name: yafu-x64.exe
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 611c3335
Exception Code: c000001d
Exception Offset: 0000000000001300
OS Version: 6.1.7601.2.1.0.256.48
Locale ID: 1033
Additional Information 1: e63c
Additional Information 2: e63cb477893153aa77789ca6de3c6a1b
Additional Information 3: b40b
Additional Information 4: b40bbb931625d5f5f8d166d47cac51f6[/code]
[url=https://www.dependencywalker.com/]Dependency Walker[/url] shows the same list of missing DLLs that [i]BudgieJane[/i] [url=https://www.mersenneforum.org/showthread.php?p=586394]listed[/url].
edit: [url=https://social.msdn.microsoft.com/Forums/en-US/a28331ae-19a3-4a34-b3ba-1e8fd4430375/missing-apimswincore-dlls]this thread[/url] may contain relevant details.

bsquared 2021-08-24 13:16

If there is a setting in visual studio 2019 where I can link these things statically then I'd do that, but I don't know how at the moment.

I don't have access to any win7 systems to test on.

Brian Gladman 2021-08-24 14:52

Here is a link to a zip file containing a statically linked YAFU x64 binary that might be worth a try:

[url]https://drive.google.com/file/d/1RaZuOfO-2L-InyHQc29pph0OvuYBS_Yy/view?usp=sharing[/url]

for those having DLL issues. I have to admit it seems unlikely to offer a solution.

James Heinrich 2021-08-24 15:08

[QUOTE=Brian Gladman;586412]Here is a link to a zip file containing a statically linked YAFU x64 binary that might be worth a try ... for those having DLL issues. I have to admit it seems unlikely to offer a solution.[/QUOTE]I tried it, it crashed the same way as the original.

Brian Gladman 2021-08-24 18:21

[QUOTE=James Heinrich;586413]I tried it, it crashed the same way as the original.[/QUOTE]

I am not surprised since my build (and I suspect all current YAFU builds) use Windows SDK v10.

To get a working Windows 7 version all of yafu, mpir, gmp-ecm, ggnfs, pthreads and its other dependencies would all have to be rebuilt using Windows SDK 8.1 and this would be considerable undertaking.

BudgieJane 2021-08-24 18:50

Version 2.01 works OK on my Win-7 machine.

WraithX 2021-08-24 19:05

1 Attachment(s)
I am missing the same dll files as Budgie and James, but yafu 2.06 works fine on my Windows 7 Pro x64 computer.

I tried yafu-x64.exe from [url]https://github.com/bbuhrow/yafu[/url]
I tried yafu-x64.exe from master.zip from [url]https://github.com/bbuhrow/yafu/archive/refs/heads/master.zip[/url]
I tried the statically linked yafu-x64.exe that Brian shared

All of them work for me.

I was going to guess a possible instruction set issue, but I see that Budgie's i7-4710MQ has the same extensions as my E5-2687W v4. (except mine has TSX which is missing from Budgie's, but I wouldn't guess that's important here)

James's C000001D could make sense since his processor doesn't support as many instruction sets as Budgie's or mine. His processor is missing AVX2 and FMA3 (and TSX). Maybe this is contributing?

I found this online about C000001D. I'm not sure if this narrows down what might be going wrong, but maybe it can help with troubleshooting.
C000001D STATUS_ILLEGAL_INSTRUCTION EXCEPTION_ILLEGAL_INSTRUCTION

Budgie, can you run yafu-x64.exe and then after it crashes/stops, can you check your Windows Event Viewer -> Windows Logs -> Application log (or maybe System log) to see if the error is recorded in there? Maybe that will give us more information on what's going wrong?

BudgieJane 2021-08-24 20:51

Log Name: Application
Source: Application Error
Date: 24/08/2021 21:45:39
Event ID: 1005
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: JaneLT3
Description:
Windows cannot access the file for one of the following reasons: there is a problem with the network connection, the disk that the file is stored on, or the storage drivers installed on this computer; or the disk is missing. Windows closed the program yafu-x64.exe because of this error.

Program: yafu-x64.exe
File:

The error value is listed in the Additional Data section.
User Action
1. Open the file again. This situation might be a temporary problem that corrects itself when the program runs again.
2. If the file still cannot be accessed and
- It is on the network, your network administrator should verify that there is not a problem with the network and that the server can be contacted.
- It is on a removable disk, for example, a floppy disk or CD-ROM, verify that the disk is fully inserted into the computer.
3. Check and repair the file system by running CHKDSK. To run CHKDSK, click Start, click Run, type CMD, and then click OK. At the command prompt, type CHKDSK /F, and then press ENTER.
4. If the problem persists, restore the file from a backup copy.
5. Determine whether other files on the same disk can be opened. If not, the disk might be damaged. If it is a hard disk, contact your administrator or computer hardware vendor for further assistance.

Additional Data
Error value: 00000000
Disk type: 0
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Application Error" />
<EventID Qualifiers="49152">1005</EventID>
<Level>2</Level>
<Task>100</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2021-08-24T20:45:39.000000000Z" />
<EventRecordID>664519</EventRecordID>
<Channel>Application</Channel>
<Computer>JaneLT3</Computer>
<Security />
</System>
<EventData>
<Data>
</Data>
<Data>yafu-x64.exe</Data>
<Data>00000000</Data>
<Data>0</Data>
</EventData>
</Event>

Log Name: Application
Source: Application Error
Date: 24/08/2021 21:45:39
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: JaneLT3
Description:
Faulting application name: yafu-x64.exe, version: 0.0.0.0, time stamp: 0x611c3335
Faulting module name: yafu-x64.exe, version: 0.0.0.0, time stamp: 0x611c3335
Exception code: 0xc000001d
Fault offset: 0x0000000000002403
Faulting process id: 0x4d4
Faulting application start time: 0x01d79928fdf3fa53
Faulting application path: C:\Users\Jane\Documents\Maths\yafu\Versions\yafu-2.06\yafu-x64.exe
Faulting module path: C:\Users\Jane\Documents\Maths\yafu\Versions\yafu-2.06\yafu-x64.exe
Report Id: 3d352f22-051c-11ec-8f66-0cd292d9c1cc
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Application Error" />
<EventID Qualifiers="0">1000</EventID>
<Level>2</Level>
<Task>100</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2021-08-24T20:45:39.000000000Z" />
<EventRecordID>664518</EventRecordID>
<Channel>Application</Channel>
<Computer>JaneLT3</Computer>
<Security />
</System>
<EventData>
<Data>yafu-x64.exe</Data>
<Data>0.0.0.0</Data>
<Data>611c3335</Data>
<Data>yafu-x64.exe</Data>
<Data>0.0.0.0</Data>
<Data>611c3335</Data>
<Data>c000001d</Data>
<Data>0000000000002403</Data>
<Data>4d4</Data>
<Data>01d79928fdf3fa53</Data>
<Data>C:\Users\Jane\Documents\Maths\yafu\Versions\yafu-2.06\yafu-x64.exe</Data>
<Data>C:\Users\Jane\Documents\Maths\yafu\Versions\yafu-2.06\yafu-x64.exe</Data>
<Data>3d352f22-051c-11ec-8f66-0cd292d9c1cc</Data>
</EventData>
</Event>

BudgieJane 2021-08-24 21:34

1 Attachment(s)
Don't know if you want to see this also:

BudgieJane 2021-08-24 21:45

[QUOTE=Brian Gladman;586412]Here is a link to a zip file containing a statically linked YAFU x64 binary that might be worth a try:

[url]https://drive.google.com/file/d/1RaZuOfO-2L-InyHQc29pph0OvuYBS_Yy/view?usp=sharing[/url]

for those having DLL issues. I have to admit it seems unlikely to offer a solution.[/QUOTE]

I got a system error: The program can't start because nvcuda.dll is missing from your computer. Try reinstalling the program to fix this problem.

Brian Gladman 2021-08-25 08:25

[QUOTE=BudgieJane;586438]I got a system error: The program can't start because nvcuda.dll is missing from your computer. Try reinstalling the program to fix this problem.[/QUOTE]

It seems that I have missed a DLL dependency in the build.

I have run through all the library dependencies again to check they are static and rebuilt it here:

[url]https://drive.google.com/file/d/1L9SGu0_rv_CwdPofShq_zRqk1-d5SckP/view?usp=sharing[/url]

There are so many dependencies in building YAFU so its still possible that I have still missed a DLL dependency somewhere (in this case it should work if CUDA 11.4 is installed on your host since the DLL dependency would then be found).


All times are UTC. The time now is 21:58.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.