mersenneforum.org

mersenneforum.org (https://www.mersenneforum.org/index.php)
-   PrimeNet (https://www.mersenneforum.org/forumdisplay.php?f=11)
-   -   Primenet Server - Official Maintenance Thread (https://www.mersenneforum.org/showthread.php?t=21648)

Madpoo 2018-12-28 05:11

Doing a reboot of the server soon - updating the backup software, so that's important. :smile:

It's 2018-12-28 @ 5:11 AM with an expected downtime ~ 15 minutes.

EDIT: Back online. Okay, it was more like 18 minutes.

Madpoo 2019-02-04 03:09

Maintenance scheduled - 2019-02-04 @ 03:15 (UTC)
 
I'm going to go ahead and do some updates on the Primenet server:
2019-02-04 @ 03:15 (UTC)

I noticed a funny period of SQL queries taking long and even though it's stabilized (and only lasted a few minutes about 30 hours ago) I wanted to go ahead and update things.

I'm only doing SQL updates so the downtime should be minimal, ~ 5 minutes.

EDIT: yup, it was about 5 minutes, all done.

Madpoo 2019-03-24 05:48

Maintenance about to start
 
I'm about to do some updating on the server.

It'll be down probably 30 minutes, and I'm starting at 05:50 UTC on 2019-03-24

EDIT: All done

Madpoo 2019-04-20 16:44

Maintenance - 2019-04-20 @ 16:40 UTC
 
I'm taking the server offline for a few minutes for some SQL related maintenance.

I could have done it offline but I'm altering some tables that would make it slow and non-responsive anyway which would only be more frustrating for people. :smile:

I expect it to finish in a few more minutes.

EDIT: Back in action. Took longer to update that pesky table than I had hoped... probably would have been faster to drop the indices, alter it, then recreate indices. Oh well. All done.

Madpoo 2019-04-21 06:58

More SQL maintenance - 2019-04-21 @ 06:55 UTC
 
There is more SQL maintenance happening right now. At least this time I waited until later in the evening in the US.

Working on some tables, dropping and adding columns. It affects web visits so I disabled the web service while the work is happening.

ETA about 25 minutes

EDIT: Back online - didn't take as long as I thought.

Madpoo 2019-05-15 18:04

May 2019 maintenance
 
I'm going to be taking the server offline for a brief period to do some routine maintenance.

I expect to start @ 18:10 UTC (2019-05-15) and it should be ~ 20 minutes (it's now 18:05 UTC, so yeah... 5 minutes from now)

UPDATE: It finished a little ahead of time (by a few minutes). Good to go.

kriesel 2019-05-15 22:24

Is this what happens during server maintenance?
 
1 Attachment(s)
In response to <link removed by LaurV>

I got a null page (no assignments, no error message)
Or maybe it relates to my slow but unreliable DSL.

Madpoo 2019-05-18 16:41

[QUOTE=kriesel;516868]In response to <url removed>

I got a null page (no assignments, no error message)
Or maybe it relates to my slow but unreliable DSL.[/QUOTE]

It worked for me (for anyone clicking on that original link, just note that you will get an assignment as a result). :smile:

LaurV 2019-05-20 03:15

Worked for me too. I got an assignment ([m]91338227[/m]) which I am going to work on. I removed the link from original post however. Curious people will click on it, and this seems to me a way to trick people in getting unwanted assignments, which they will not work, and will stay there and clutter the DB.

(No, it didn't trick me, because I read Madpoo's post first, before clicking, and I needed one new assignment, but it would for sure do trick me, if not for Madpoo's post, because I am a curious monkey!)

kriesel 2019-05-20 14:16

No trick intended. The point was, I went for a manual assignment, and instead of it working as usual, returning one or more assignments with aid(s), it returned an incomplete page as shown in the attached screen capture image, which might have been due to the maintenance going on at the time. It worked for me before that, and after that. It's not at all surprising that it would work days after the maintenance was completed; that [B]is[/B] the intended result of maintenance!

Madpoo 2019-05-21 04:14

[QUOTE=kriesel;517259]No trick intended. The point was, I went for a manual assignment, and instead of it working as usual, returning one or more assignments with aid(s), it returned an incomplete page as shown in the attached screen capture image, which might have been due to the maintenance going on at the time. It worked for me before that, and after that. It's not at all surprising that it would work days after the maintenance was completed; that [B]is[/B] the intended result of maintenance![/QUOTE]

Just a little behind-the-scenes...

When I'm going to do any maintenance like installing the Microsoft patches, my first step is to stop the web services before installing anything. There's usually a very good chance the patches are going to stop/start web services, especially when doing .NET framework stuff, so I just avoid it and stop it altogether.

I suppose if the timing is just right, I could stop the web services and something that was "in progress" could get killed off prematurely.

Typically though, when you stop the web server, it lets any outstanding requests complete first. The only time it would kill anything is if it took longer than the timeout period to complete (something like 30 seconds... I forget). I don't always pay attention to how long it takes to stop, but it's entirely possible.


All times are UTC. The time now is 05:53.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.