mersenneforum.org

mersenneforum.org (https://www.mersenneforum.org/index.php)
-   Msieve (https://www.mersenneforum.org/forumdisplay.php?f=83)
-   -   Might someone recall which revision of msieve still worked with CUDA 6.5 and arch 1.2? (https://www.mersenneforum.org/showthread.php?t=21774)

EdH 2016-11-26 14:51

Might someone recall which revision of msieve still worked with CUDA 6.5 and arch 1.2?
 
I thought I remembered being able to run poly selection once upon a time, but in trying to step back, I'm having little luck.

After days of backtracking I have the mentioned version of CUDA running and the later versions of msieve compiling. But, as expected, the current msieve complains about my ancient hardware.

Earlier versions won't compile due to missing CUDA components, even though all paths seem correct and all "missing" files are present.

Is there a particular revision that I might have more success with in reviewing? I have bounced through many of them with varying results, but none encouraging.

Thanks...

EdH 2016-11-26 15:30

Update
 
I have revision 900 working now, after modifying a few lines of msieve to change arch 1.0 to 1.2. But, I would still like to know the most current revision in which I could do this, if anyone might know.

This is not a pressing issue.

Thanks for all...

RichD 2016-11-26 17:13

From the history code log I find:
[CODE][r980] by brgladman
Update Visual Studio 2013 build to CUDA 7.0 and remove unsupported compute capabilities (1.1 and 1.3)[/CODE]

EdH 2016-11-26 17:37

[QUOTE=RichD;447854]From the history code log I find:
[CODE][r980] by brgladman
Update Visual Studio 2013 build to CUDA 7.0 and remove unsupported compute capabilities (1.1 and 1.3)[/CODE][/QUOTE]
Thanks! This is probably somewhere I should be able to find it, but I'm ignorant to where that is. Something from a subversion call, perhaps?

EdH 2016-11-26 20:44

[QUOTE=EdH;447856]Thanks! This is probably somewhere I should be able to find it, but I'm ignorant to where that is. Something from a subversion call, perhaps?[/QUOTE]
OK, just to let every(any)one know, I found it via:
[code]
svn log https://svn.code.sf.net/p/msieve/code/trunk
[/code]In case anyone is interested in the same area, my dilemma was that my system wouldn't accept arch 1.0 and the earlier msieve code had 1.0 and 1.3 support, but not 1.2. I changed all the 1.0 references to 1.2 and everything compiled and now runs using r979.

Thanks to all...


All times are UTC. The time now is 17:14.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.